Форум программистов, компьютерный форум, киберфорум
Наши страницы
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.86/7: Рейтинг темы: голосов - 7, средняя оценка - 4.86
Алена77
0 / 0 / 0
Регистрация: 15.06.2015
Сообщений: 12
1

Формула с условиями ЕСЛИ

15.06.2015, 16:07. Просмотров 1323. Ответов 11
Метки нет (Все метки)

Помогите, пожалуйста, с моими скудными познаниями в Excel, никак не получается создать формулу. Уже два дня бьюсь, и никак. Нужна простая таблица, где под значением 1 подразумевалось бы 0,5, значение 200 было бы 1, 300 – 2, и 400 – 3, а потом все суммировалось.
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
15.06.2015, 16:07
Ответы с готовыми решениями:

Формула ЕСЛИ с 6 условиями
Доброго времени суток. Не как не могу решить проблему с формулой нужно что бы...

Формула ЕСЛИ с двумя условиями
Мне нужно сделать двойную формулу ЕСЛИ, но у меня не получается, т.е. двойное...

Логическая формула с условиями
Привет ребята! Слушайте, кто шарит в формулах Excel? я ваще дерево полное, но...

Формула с несколькими условиями
Уважаемые форумчане,подскажите с формулой,нужно в ячейке D1 функцию =ЕСЛИ(И( ...

Формула расчёта с определёнными условиями
Всем привет! Как в таблице подсчитать Итого? Необходимо разбить число 200 на...

11
bort-747
42 / 64 / 9
Регистрация: 07.06.2013
Сообщений: 471
Записей в блоге: 1
15.06.2015, 16:34 2
Код
=ЕСЛИ(A1=1;0.5;ЕСЛИ(A1=200;1;ЕСЛИ(A1=300;2;ЕСЛИ(A1=400;3;"неверные данные"))))
А вот с:
Цитата Сообщение от Алена77 Посмотреть сообщение
а потом все суммировалось.
Непонятно что должно суммироваться
1
Алена77
0 / 0 / 0
Регистрация: 15.06.2015
Сообщений: 12
15.06.2015, 17:02  [ТС] 3
Извиняюсь, но не знаю как прикрепить файл. В общем, в колонку А пишем значения: 1, 200, 300, 400, а в колонку В нужна формула, чтобы при вбивании в А1 например 200, в В1 выставлялось значение 1. Сумма значений колонки В.
0
Вложения
Тип файла: xls Книга2.xls (13.5 Кб, 8 просмотров)
bort-747
42 / 64 / 9
Регистрация: 07.06.2013
Сообщений: 471
Записей в блоге: 1
15.06.2015, 18:55 4
Лучший ответ Сообщение было отмечено chumich как решение

Решение

ловите
1
Вложения
Тип файла: xls книга2.xls (27.5 Кб, 9 просмотров)
Алена77
0 / 0 / 0
Регистрация: 15.06.2015
Сообщений: 12
15.06.2015, 19:32  [ТС] 5
Bort-747, огромное Вам спасибо, то что нужно, Вы Голова с Большой буквы. Все таки, Excel удивительная программа. Я ни в коем случае не хочу Вас утруждать, просто хочу спросить, возможно ли в этой проге сделать так, чтобы эти все действия происходили в одном столбце А, то есть, если в столбце А1 - 200, в А2 - 300, итого =СУММ(А1:А2) равно 3.
0
bort-747
42 / 64 / 9
Регистрация: 07.06.2013
Сообщений: 471
Записей в блоге: 1
15.06.2015, 19:48 6
Ловите
1
Вложения
Тип файла: xlsx Книга2.2.xlsx (8.4 Кб, 10 просмотров)
Алена77
0 / 0 / 0
Регистрация: 15.06.2015
Сообщений: 12
15.06.2015, 20:02  [ТС] 7
Извините за мой тупизм, но я так понимаю, что надо связать таблицу из книга2.xls c книга2.2.xlsx, или дело в расширении xlsx, я еще пользуюсь 2003 офисом, формула книга2.2 не работает.
0
Вячеслав Я
Эксперт MS Access
2804 / 1349 / 212
Регистрация: 13.05.2011
Сообщений: 4,107
15.06.2015, 20:52 8
Алена77, я вижу в файле Книга2.2 в формуле ЕСЛИ указано очень много раз (не считал, но много). Знаю, что в версии Офиса 2003 в формуле допускается ЕСЛИ не более 7 раз. С этим у самого были неудобства. Поэтому формулу расписывал на несколько ячеек, по 7 ЕСЛИ в каждой. В новых версиях Офиса может быть эта проблема решена. Проверте, попробуйте оставить условие ЕСЛИ 7 раз и тогда в вашем 2003 годе может пойдет.
1
kasan
Чорумфанин
338 / 339 / 319
Регистрация: 06.03.2014
Сообщений: 896
15.06.2015, 20:56 9
Лучший ответ Сообщение было отмечено Алена77 как решение

Решение

Предложу вариант без if().
1
Вложения
Тип файла: xls Книга2.3.xls (19.5 Кб, 8 просмотров)
Вячеслав Я
Эксперт MS Access
2804 / 1349 / 212
Регистрация: 13.05.2011
Сообщений: 4,107
15.06.2015, 21:17 10
Алена77, решил заглянуть в ваш файл. Так все на много проще. Предлагаю свой вариант в формате 2003 года
пишите формулу для одной ячейки, растаскиваете ее далее и все
Код
=ЕСЛИ(A2=1;0,5;ЕСЛИ(A2=200;1;ЕСЛИ(A2=300;2;ЕСЛИ(A2=400;3;0))))
1
Вложения
Тип файла: xls Книга2.4.xls (26.5 Кб, 6 просмотров)
Алена77
0 / 0 / 0
Регистрация: 15.06.2015
Сообщений: 12
15.06.2015, 21:47  [ТС] 11
Огромное спасибо всем, кто откликнулся. Особое спасибо форумчанину Kasan, благодаря Вам я разложила все по полочкам, получилась супер-конфетка.
0
Fairuza
Модератор
5206 / 2634 / 471
Регистрация: 23.11.2010
Сообщений: 8,690
15.06.2015, 21:51 12
Еще вариант, если пустых ячеек не будет, можно оставить просто ВПР()
Код
=ЕСЛИ(A2="";"";ВПР(A2;{1;0,5:200;1:300;2:400;3};2))
2
15.06.2015, 21:51
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
15.06.2015, 21:51

Нужна формула суммирования с условиями
Здравствуйте.Нужна формула суммирования с условиями,макрос не подходит.Есть в...

Формула подсчёта ячеек с условиями
Здравствуйте! Подскажите пожалуйста формулу,описание задачи в файле.

Функция ЕСЛИ с двумя условиями
Добрый день, наверно задача стара как мир, но не смог найти в поиске. Есть...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
12
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru