Форум программистов, компьютерный форум, киберфорум
Наши страницы
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/5: Рейтинг темы: голосов - 5, средняя оценка - 5.00
ДимитрийСибирск
0 / 0 / 0
Регистрация: 28.07.2015
Сообщений: 5
1

Ошибка Знач в функции

30.07.2015, 21:46. Просмотров 916. Ответов 9
Метки нет (Все метки)

Код
=ЕСЛИ(И(ИНДЕКС('[01_Itog.xls]1738'!$F$8:$AS$371;(ПОИСКПОЗ(C2;'[01_Itog.xls]1738'!$F:$F;0));'[01_Itog.xls]1738'!P$1)<>0;ИНДЕКС('[уникальные данные.xlsx]Sheet1'!$C:$F;ПОИСКПОЗ(C2&D1;'[уникальные данные.xlsx]Sheet1'!$C:$C&'[уникальные данные.xlsx]Sheet1'!$F:$F);'[уникальные данные.xlsx]Sheet1'!$D:$D)>$AH$2);ИНДЕКС('[уникальные данные.xlsx]Sheet1'!$C:$F;ПОИСКПОЗ(C2&D1;'[уникальные данные.xlsx]Sheet1'!$C:$C&'[уникальные данные.xlsx]Sheet1'!$F:$F);'[уникальные данные.xlsx]Sheet1'!$D:$D);"")
Формула в файле 3 ячейка D2 листе анализ данных. Формула проверяет два значения на удовлетворения условиям. Если оба условия выполняются, то значение второй проверяемой ячейки приравнивается к ячейке с формулой, иначе ячейка должна оставаться пустой. Файл 1_Itog не смог прислать, ввиду его размера, скриншот файла приложен.
0
Миниатюры
Ошибка Знач в функции  
Вложения
Тип файла: xlsx 3.xlsx (84.4 Кб, 4 просмотров)
Тип файла: xlsx уникальные данные.xlsx (72.7 Кб, 3 просмотров)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
30.07.2015, 21:46
Ответы с готовыми решениями:

Ошибка #ЗНАЧ!
=ЕСЛИ(И(C6&gt;=0;C6&lt;=1);SIN(C6)*EXP(C6));ЕСЛИ(C6&gt;1;2*COS(C6)*COS(C6);C6+КОРЕНЬ(1+C6*C6))

Выдается ошибка Знач
Не могу понять где ошибка.... На листе &quot;командное&quot; почему - не хочет считать ячейку С16

Умножение матриц - ошибка #ЗНАЧ
Происходит ошибка умножения матриц. Не пойму в чем проблема. Все поля заполняются #ЗНАЧ. Кто-то...

Ошибка ЗНАЧ при вычислении формулы
Добрый день! Возникает ошибка ЗНАЧ при использовании формулы ПОИСКПОЗ Прилагаю пример, в чем...

Ошибка в *ЗНАЧ причина не могу найти
Господа, помогите решить проблему. При импорте данных из интернета вставляются цифры и текст...

9
Genbor
94 / 92 / 34
Регистрация: 25.06.2015
Сообщений: 256
31.07.2015, 06:45 2
Если файл не влазит, его нужно архивировать. По картинке разбираться вряд ли кто будет - это мазохизм.
Кроме того, это правилам противоречит (п.18)

На вскидку - попробуй в первом логическом условии поставить не
Код
<>0
, а
Код
<>""
0
Vlad999
3023 / 1847 / 576
Регистрация: 02.11.2012
Сообщений: 4,677
31.07.2015, 09:40 3
вот эта часть формулы
Код
ПОИСКПОЗ(C2&D1;'C:\temp\[уникальные данные.xlsx]Sheet1'!$C:$C&'C:\temp\[уникальные данные.xlsx]Sheet1'!$F:$F)
говорит о том что нужно формулу вводить как формулу массива.
ctrl+shift+enter
0
ДимитрийСибирск
0 / 0 / 0
Регистрация: 28.07.2015
Сообщений: 5
31.07.2015, 19:24  [ТС] 4
Приложил все файлы
0
Вложения
Тип файла: rar Формула.rar (188.9 Кб, 3 просмотров)
31.07.2015, 19:24
Genbor
94 / 92 / 34
Регистрация: 25.06.2015
Сообщений: 256
31.07.2015, 21:20 5
В формуле у тебя какая-то вакханалия.
Я сначала кучу вопросов начал тебе писать, но быстро понял, что так мы не договоримся. Поэтому проще будет, если ты мне скажешь, что не так, если что-то будет "не так".
Вот формула. Вставляй в первую ячейку (D2) и тяни на всю таблицу.
Код
=ЕСЛИ(И(ИНДЕКС('[01_Itog.xls]1738'!$D$2:$AS$371;(ПОИСКПОЗ($C2;'[01_Itog.xls]1738'!$C:$C;0));ПОИСКПОЗ(D$1;'[01_Itog.xls]1738'!$D$1:$AG$1;0))<>0;ИНДЕКС('[уникальные данные.xlsx]Sheet1'!$D:$D;ПОИСКПОЗ(1;ИНДЕКС(($C2='[уникальные данные.xlsx]Sheet1'!$C:$C)*(D$1='[уникальные данные.xlsx]Sheet1'!$F:$F););))>$AH2);ИНДЕКС('[уникальные данные.xlsx]Sheet1'!$D:$D;ПОИСКПОЗ(1;ИНДЕКС(($C2='[уникальные данные.xlsx]Sheet1'!$C:$C)*(D$1='[уникальные данные.xlsx]Sheet1'!$F:$F););));"")
Поскольку в твоих таблицах нужные сочетания пользователя и услуги встречается всего пару раз - чаще всего выходит #н/д. А даты не выходят никогда потому что больше заданной вообще практически нет.
От этого вообще можно избававиться, если в корень добавить функцию =еслиошибка:
Код
=ЕСЛИОШИБКА((ЕСЛИ(И(ИНДЕКС('[01_Itog.xls]1738'!$D$2:$AS$371;(ПОИСКПОЗ($C2;'[01_Itog.xls]1738'!$C:$C;0));ПОИСКПОЗ(D$1;'[01_Itog.xls]1738'!$D$1:$AG$1;0))<>0;ИНДЕКС('[уникальные данные.xlsx]Sheet1'!$D:$D;ПОИСКПОЗ(1;ИНДЕКС(($C2='[уникальные данные.xlsx]Sheet1'!$C:$C)*(D$1='[уникальные данные.xlsx]Sheet1'!$F:$F););))>$AH2);ИНДЕКС('[уникальные данные.xlsx]Sheet1'!$D:$D;ПОИСКПОЗ(1;ИНДЕКС(($C2='[уникальные данные.xlsx]Sheet1'!$C:$C)*(D$1='[уникальные данные.xlsx]Sheet1'!$F:$F););));""));"")
И проверь диапазоны. Особенно вот эту часть,
Код
$D$2:$AS$371
которая с непонятного для меня перепуга была
Код
$F$8:$AS$371
Может я че не понял.
0
ДимитрийСибирск
0 / 0 / 0
Регистрация: 28.07.2015
Сообщений: 5
03.08.2015, 07:03  [ТС] 6
Для упрощения задачи сделал один файл, куда накидал данные с 2 файлов, пока первая часть формулы правильная, сейчас пытаюсь совместить со вторым условием.

Код
=ЕСЛИ(ИНДЕКС('Данные файла Itog'!$C$1:$AG$335;ПОИСКПОЗ($C1;'Данные файла Itog'!$C$1:$C$335;0);ПОИСКПОЗ(E$1;'Данные файла Itog'!$C$1:$AG$1;0))<>0;1;0)
Добавлено через 8 минут
Получается, мне надо найти строку, в которой будет два нужных мне значения, формула выдаёт ошибку знач:
Код
=ИНДЕКС('Уникальные данные с выгрузки'!C1:F2667;ПОИСКПОЗ(Расчёт!C2&D1;'Уникальные данные с выгрузки'!C1:C2667&'Уникальные данные с выгрузки'!F1:F2667;0);1)
Извиняюсь за свою тупость, с excel работаю первый раз.
0
Genbor
94 / 92 / 34
Регистрация: 25.06.2015
Сообщений: 256
03.08.2015, 07:18 7
А моей формулой воспользоваться гордость не позволяет?
0
ДимитрийСибирск
0 / 0 / 0
Регистрация: 28.07.2015
Сообщений: 5
03.08.2015, 07:49  [ТС] 8
При написании формулы руководствовался данным сайтом: http://http://www.excelworld.ru/publ...teria/17-1-0-1

Добавлено через 53 секунды
Цитата Сообщение от Genbor Посмотреть сообщение
А моей формулой воспользоваться гордость не позволяет?
Ни коим образом не игнорировал вашу формулу, сейчас адаптирую её под один файл

Добавлено через 15 минут
Цитата Сообщение от Genbor Посмотреть сообщение
В формуле у тебя какая-то вакханалия.
Не могу понять, почему мы ищем 1 в конце?
Код
 ПОИСКПОЗ(1;ИНДЕКС(($C2='[уникальные данные.xlsx]Sheet1'!$C:$C)*(D$1='[уникальные данные.xlsx]Sheet1'!$F:$F););));"")
0
Genbor
94 / 92 / 34
Регистрация: 25.06.2015
Сообщений: 256
03.08.2015, 11:27 9
Мы ищем "1", потому, что
Код
=ИНДЕКС(($C2='[уникальные данные.xlsx]Sheet1'!$C:$C)*(D$1='[уникальные данные.xlsx]Sheet1'!$F:$F);)
при совпадении параметров вернет "1".
0
ДимитрийСибирск
0 / 0 / 0
Регистрация: 28.07.2015
Сообщений: 5
03.08.2015, 16:35  [ТС] 10
Добавил файл,в котором объединены все 3 файла. Может теперь будет удобнее.
0
Вложения
Тип файла: rar Общий файл.rar (179.1 Кб, 1 просмотров)
03.08.2015, 16:35
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
03.08.2015, 16:35

Ошибка #ЗНАЧ при подсчете значения
Приветствую всех. В ячейке A2 есть формула: =ЕСЛИ(A1=1;100;&quot;&quot;). В ячейке A3 другая формула =A2+100....

Попытка присвоить значение ячейке в функции выдает #ЗНАЧ
Создаю пустую таблицу. В VBA создаю модуль с единственной ф-цией: Public Function MUSOR() ...

Ошибка #ЗНАЧ! подскажите можно ли исправить в моей работе
Откуда и почему берется - происходит данная ошибка - читала, но как ее исправить, чтоб у меня...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
10
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru