Форум программистов, компьютерный форум, киберфорум
Наши страницы
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/4: Рейтинг темы: голосов - 4, средняя оценка - 5.00
Sylar
2 / 2 / 1
Регистрация: 06.06.2012
Сообщений: 121
1

Формула ЕСЛИ с 6 условиями

22.12.2015, 18:16. Просмотров 835. Ответов 4
Метки нет (Все метки)

Доброго времени суток.
Не как не могу решить проблему с формулой нужно что бы было 6 условий
если
40<G6<35 то 3500 если нет то идет дальше перебирать условия
36>G6>30;то 3000 если нет то идет дальше перебирать условия
31>G6>25;то 2500 если нет то идет дальше перебирать условия
26>G6>20;то 2000 если нет то идет дальше перебирать условия
21>G6>15;то 1500 если нет то идет дальше перебирать условия
16>G6>11;то 1000 если нет то идет дальше перебирать условия
11>G6; то 0

намудрил такое но не получается что бы перебирал условия останавливается на 2м
Код
=ЕСЛИ(40<G6<35;3500;ЕСЛИ(36>G6>30;3000;ЕСЛИ(31>G6>25;2500;ЕСЛИ(26>G6>20;2000;ЕСЛИ(21>G6>15;1500;ЕСЛИ(16>G6>11;1000;ЕСЛИ(G6>12;0)))))))
0
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
22.12.2015, 18:16
Ответы с готовыми решениями:

Формула с условиями ЕСЛИ
Помогите, пожалуйста, с моими скудными познаниями в Excel, никак не получается...

Формула ЕСЛИ с двумя условиями
Мне нужно сделать двойную формулу ЕСЛИ, но у меня не получается, т.е. двойное...

Логическая формула с условиями
Привет ребята! Слушайте, кто шарит в формулах Excel? я ваще дерево полное, но...

Формула с несколькими условиями
Уважаемые форумчане,подскажите с формулой,нужно в ячейке D1 функцию =ЕСЛИ(И( ...

Формула расчёта с определёнными условиями
Всем привет! Как в таблице подсчитать Итого? Необходимо разбить число 200 на...

4
Казанский
14416 / 5962 / 1585
Регистрация: 24.09.2011
Сообщений: 9,395
22.12.2015, 18:55 2
Лучший ответ Сообщение было отмечено Sylar как решение

Решение

Sylar, принцип такой
Код
=просмотр(G6;{0;11;16;21;26;31;36};{0;1000;1500;2000;2500;3000;3500})
1
Fairuza
Модератор
5208 / 2636 / 471
Регистрация: 23.11.2010
Сообщений: 8,690
22.12.2015, 18:58 3
Код
=ЕСЛИ(G6>40;3500;ЕСЛИ(G6>30;3000;ЕСЛИ(G6>25;2500;ЕСЛИ(G6>20;2000;ЕСЛИ(G6>15;1500;ЕСЛИ(G6>11;1000;0)))))
не до конца понимаю условия, но суть примерно такая
1
Казанский
14416 / 5962 / 1585
Регистрация: 24.09.2011
Сообщений: 9,395
22.12.2015, 19:01 4
Про выражения вида 40<G6<35 читайте тут: Вычислить значение выражения (исправить код)
1
AlexM
1923 / 1404 / 571
Регистрация: 04.09.2015
Сообщений: 2,772
22.12.2015, 20:43 5
Формула считает так же как формула Казанского
Код
=(ПОИСКПОЗ(G6;{0:11:11:16:21:26:31:36})-1)*500
Добавлено через 1 час 23 минуты
С ЕСЛИ()
Код
=ЕСЛИ(G6<11;0;ЕСЛИ(G6<16;2;ЕСЛИ(G6<21;3;ЕСЛИ(G6<26;4;ЕСЛИ(G6<31;5;ЕСЛИ(G6<36;6;7))))))*500
Добавлено через 17 минут
Еще вариант
Код
=МАКС((G6>={0:11:16:21:26:31:36})*{0:2:3:4:5:6:7})*500
=ВПР(G6;{0;0:11;2:16;3:21;4:26;5:31;6:36;7};2)*500
3
22.12.2015, 20:43
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
22.12.2015, 20:43

Формула подсчёта ячеек с условиями
Здравствуйте! Подскажите пожалуйста формулу,описание задачи в файле.

Нужна формула суммирования с условиями
Здравствуйте.Нужна формула суммирования с условиями,макрос не подходит.Есть в...

Функция ЕСЛИ с несколькими условиями
Здравствуйте! Помогите, пожалуйста!!!! Есть таблица, с наименованием товара....


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru