Форум программистов, компьютерный форум, киберфорум
Наши страницы
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.75/4: Рейтинг темы: голосов - 4, средняя оценка - 4.75
Lylu
0 / 0 / 0
Регистрация: 14.01.2016
Сообщений: 6
1

Функция ЕСЛИ с несколькими условиями

14.01.2016, 12:48. Просмотров 726. Ответов 4
Метки нет (Все метки)

Здравствуйте!
Помогите, пожалуйста!!!!
Есть таблица, с наименованием товара. Один продукт имеет несколько комплектующих. Нужно, чтобы при наличии всех комплектующих программа выводила сумму. При отсутствии хотя бы одного из них, в колонке "наличие" отображался 0. Я написала формулу, но при отсутствии компл 1 - в ячейки "наличие" отображается "ЗНАЧ". А мне надо именно "0".
0
Вложения
Тип файла: xlsx Книга1.xlsx (9.1 Кб, 10 просмотров)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
14.01.2016, 12:48
Ответы с готовыми решениями:

Функция ЕСЛИ с несколькими условиями
Здравствуйте!Задали решить задачу через ЕСЛИ Помогите пожалуйста

Функция ЕСЛИ с несколькими условиями
Доброго времени суток! Задали решить задачу. Все написала,но почему то он...

Функция с несколькими условиями
=ЕСЛИ(A1<(-1);(-2*x*sin(A1));.... Как мне правильно записать данную...

Логическая функция с несколькими условиями
Здарвствуйте! Помогите записать формулу с логической функцией, учитывая...

Excel. функция с несколькими условиями при учете времени эфира
Здраствуйте Уважаемые форумчане. Помогите начинающему. нужно автоматизировать...

4
Fairuza
Модератор
5209 / 2638 / 471
Регистрация: 23.11.2010
Сообщений: 8,690
14.01.2016, 13:03 2
Lylu, как вариант, исключительно для приведенного примера
Код
=ЕСЛИ(СЧЁТЗ(C2:C3)<СЧЁТЗ(B2:B3);0;E2)
0
Lylu
0 / 0 / 0
Регистрация: 14.01.2016
Сообщений: 6
14.01.2016, 15:22  [ТС] 3
Fairuza!! ГРОМАДНОЕ СПАСИБО!!!
0
AlexM
1971 / 1440 / 583
Регистрация: 04.09.2015
Сообщений: 2,880
14.01.2016, 21:49 4
Можно так
Код
=(СЧЁТЗ(C2:C3)=СЧЁТЗ(B2:B3))*E2
Добавлено через 37 минут
Еще вариант
Код
=НЕ(СЧИТАТЬПУСТОТЫ(B2:C3))*E2
1
Fairuza
Модератор
5209 / 2638 / 471
Регистрация: 23.11.2010
Сообщений: 8,690
14.01.2016, 22:29 5
Lylu, воспользуйтесь формулами AlexM, т.к. мой вариант при определенных условиях даст ошибку
0
14.01.2016, 22:29
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
14.01.2016, 22:29

Функция Если с тремя условиями
Не могу разобраться. По условию нужно составить функцию если, думала легко не...

Функция ЕСЛИ с двумя условиями
Добрый день, наверно задача стара как мир, но не смог найти в поиске. Есть...

Функция ЕСЛИ с несколькими значениями
Добрый вечер! Имеется задание:создайте таблицу со следующими столбцами: «ФИО ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru