Форум программистов, компьютерный форум, киберфорум
Наши страницы
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
asfnafns
0 / 0 / 0
Регистрация: 18.02.2016
Сообщений: 5
#1

Сравнение значений внутри столбца и с другими столбцами на разных листах - MS Excel

18.02.2016, 03:10. Просмотров 563. Ответов 9
Метки нет (Все метки)

Добрый день.
Прошу помочь с решением вопроса.
Необходимо, чтобы значения столбца "дело" сравнивались между собой, а также между значениями в таком же столбце, но на других листах. В случае обнаружения повторяющегося значения, необходимо выводить информацию в столбец "дубль". (например цифру, обозначающую кол-во дублей или просто индикатор того, что дубль найден).
В идеале, в столбец "где дубль" нужно вывести информацию из столбца "короб", в котором дублируется значение "дело".
В каждом листе будет по несколько десятков тысяч строк. Также планируется использовать этот файл в совместном доступе, чтобы несколько человек вводили информацию на разные листы.
Информация о нахождении дубля должна выводиться в реальном времени.
0
Вложения
Тип файла: xlsx пример.xlsx (9.8 Кб, 7 просмотров)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
18.02.2016, 03:10
Я подобрал для вас темы с готовыми решениями и ответами на вопрос Сравнение значений внутри столбца и с другими столбцами на разных листах (MS Excel):

Сравнение диапазонов значений на разных листах
Здравствуйте, помогите сравнить 4 столбца, желательно формулой если можно....

Сравнение нескольких столбцов на разных листах
Добрый день, уважаемые знатоки! Подскажите пожалуйста по такому вопросу: ...

Поиск, сравнение, выборка значений разных столбцов. Сложение и их подсчёт
Здравствуйте форумчане. Возникла трудность в решении задачи. Прошу помочь!...

Объединение чекбоксов на разных листах
Доброго времени суток! На листе1 и на листе2 по чекбоксу. Как через макрос...

Поиск значения в 2 разных листах
Добрый день! Подскажите, пожалуйста, как можно искать значение в двух разных...

Как сделать СУММЕСЛИМН в разных листах?
Здравствуйте, помогите пожалуйста! Я начинающий в экзеле. Я хочу найти общую...

9
AlexM
1728 / 1312 / 527
Регистрация: 04.09.2015
Сообщений: 2,584
18.02.2016, 09:10 #2
формула для С2 Лист1
Код
=СЧЁТЕСЛИ(A$2:A$9999;A2)+СЧЁТЕСЛИ(Лист2!A$2:A$9999;A2)+СЧЁТЕСЛИ(Лист3!A$2:A$9999;A2)
Очень непонятное задание. Покажите в примере как вы видите решение. Что должно получится в ячейках столбца D?
1
Fairuza
Модератор
5204 / 2632 / 471
Регистрация: 23.11.2010
Сообщений: 8,690
18.02.2016, 09:21 #3
asfnafns, на самом листе можно дубли условным форматированием показать
Количество на других листах дублей подсчитать формулой
Код
=СЧЁТЕСЛИ(Лист2!$A$2:$A$11;Лист1!A2)+СЧЁТЕСЛИ(Лист3!$A$2:$A$19;Лист1!A2)
Цитата Сообщение от asfnafns Посмотреть сообщение
В идеале, в столбец "где дубль" нужно вывести информацию из столбца "короб", в котором дублируется значение "дело".
вот тут не совсем понятно
1
Вложения
Тип файла: xlsx пример (1).xlsx (11.2 Кб, 6 просмотров)
asfnafns
0 / 0 / 0
Регистрация: 18.02.2016
Сообщений: 5
18.02.2016, 10:55  [ТС] #4
Спасибо за предложенные решения!
Если будет найден дубль, в столбце D должна быть информация из столбца B той строки, где найден дубль.
Но это не так важно. И в случае более чем двух дублей работать не будет, как я понимаю.

Более насущная для меня проблема - как заставить excell обрабатывать данные онлайн. Т.е чтобы все люди, которые вводят информацию на разных листах смогли сразу увидеть, есть ли дубль.
Попробовал два файла связать между собой. Если добавить новую строку в файл 1, надо будет его сохранить, а потом ещё и заново открыть файл 2. И только в этом случае в файле 2 будет найден дубль.
С общим доступом к одной книге тоже не вышло.

Есть какие-то ещё варианты?
0
Fairuza
Модератор
5204 / 2632 / 471
Регистрация: 23.11.2010
Сообщений: 8,690
18.02.2016, 11:08 #5
asfnafns, т.е формулу на лист1 и такую же лист2 - не работает? ссылки только на разные листы, разумеется
0
asfnafns
0 / 0 / 0
Регистрация: 18.02.2016
Сообщений: 5
18.02.2016, 11:30  [ТС] #6
На одном компьютере работает, на нескольких в реальном времени не работает.
Попробуйте создать два файла и свяжите их между собой аналогично листам. Может быть у вас получится.
0
Fairuza
Модератор
5204 / 2632 / 471
Регистрация: 23.11.2010
Сообщений: 8,690
18.02.2016, 12:22 #7
asfnafns, так у Вас два файла или один общий?
0
asfnafns
0 / 0 / 0
Регистрация: 18.02.2016
Сообщений: 5
18.02.2016, 16:50  [ТС] #8
Я попробовал оба варианта. Не работает. Но мне без разницы, будет ли это два файла, или один, в котором одновременно будут работать несколько человек
0
Fairuza
Модератор
5204 / 2632 / 471
Регистрация: 23.11.2010
Сообщений: 8,690
18.02.2016, 17:03 #9
asfnafns, давайте для начала Вы объясните для чего это нужно?
0
asfnafns
0 / 0 / 0
Регистрация: 18.02.2016
Сообщений: 5
25.02.2016, 16:29  [ТС] #10
Чтобы два или более человек вводили уникальные значения на разных компьютерах и excell проверял онлайн уникальность значений
0
25.02.2016, 16:29
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
25.02.2016, 16:29
Привет! Вот еще темы с решениями:

Автоматическое заполнение столбцов на разных листах
Добрый день уважаемые форумчане! Прошу помощи! Просмотрела многие темы, но...

Сумма диапазонов на разных листах по одному критерию
Доброго дня! Как сделать суммирование строк, которые располагаются на разных...

Сведение таблиц на разных листах в одну с Excel
Задача, вроде, простая, но никак не пойму, как к ней подступиться. То ли можно...

Как сложить значения по одной дате, если они в разных листах
Есть лист 1 в нём дата, в других листах 1-100 (например) где-то есть эта дата и...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
10
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru