Форум программистов, компьютерный форум, киберфорум
Наши страницы
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/5: Рейтинг темы: голосов - 5, средняя оценка - 5.00
Kamekadze_rus
0 / 0 / 0
Регистрация: 25.08.2015
Сообщений: 33
1

Поиск определённого текста в разных вкладках и подсчёт их общего количества

25.02.2016, 11:56. Просмотров 933. Ответов 3
Метки нет (Все метки)

Во вкладке 1 и 2 имеется определённое количество разных городов (Москва, Новосибирск и т.д. многие из них повторяются) К примеру во вкладке 1 Москва 3 раза во вкладке 2 Москва 2 раза повторяется.

Нужна формула которая посчитает количество к каждого города сумарно из вкладки 1 и вкладки 2
И выведет их количество в определённой ячейке (для Москвы 5)
Что то на подобии счёт если только чтоб захватывало данные из разных вкладок.

Я считаю так: Сначала считаю по каждой вкладке, (через счётесли) а затем их другой формулой суммирую (тупо ячейка из 1 вкладки + ячейка из 2 вкладки и т.д.)

Можно ли это как то упростить и свести в 1 формулу?
Проблема в том что у меня много вкладок и будем так говорить городов тоже много
0
Вложения
Тип файла: xlsx Города.xlsx (12.3 Кб, 3 просмотров)
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
25.02.2016, 11:56
Ответы с готовыми решениями:

Поиск, сравнение, выборка значений разных столбцов. Сложение и их подсчёт
Здравствуйте форумчане. Возникла трудность в решении задачи. Прошу помочь!...

Подсчёт количества консультаций
имеется файл в котором автоматизируются расчеты нагрузки. на 2 листе в в...

Подсчёт количества значений в ячейках
Здравствуйте! Возникла такая проблема, - никак не могу составить формулу для...

Подсчёт количества значений по условию
Подскажите, пожалуйста, где ошибка в формуле? Нужно посчитать количество...

Подсчет общего количества номеров группы
Есть столбец "Группы", в строках расположены числа, которые являются номером...

3
OLEGOFF
971 / 432 / 108
Регистрация: 27.02.2013
Сообщений: 1,266
25.02.2016, 14:19 2
Kamekadze_rus,попробуйте так,может поможет?
Код
=СЧЁТЕСЛИ('1'!B$2:B$19;'1'!A25)+СЧЁТЕСЛИ('2'!B$2:B$19;'2'!A25)
1
Fairuza
Модератор
5206 / 2634 / 471
Регистрация: 23.11.2010
Сообщений: 8,690
25.02.2016, 14:28 3
Лучший ответ Сообщение было отмечено Kamekadze_rus как решение

Решение

Вариант, формула массива на лист Итог
Код
=СУММ(--('1'!$B$1:$B$19=D3);--('2'!$B$2:$B$19=D3))
1
Вложения
Тип файла: xlsx Города.xlsx (13.1 Кб, 5 просмотров)
Kamekadze_rus
0 / 0 / 0
Регистрация: 25.08.2015
Сообщений: 33
25.02.2016, 14:45  [ТС] 4
Спасибо! оба варианта подходят!
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
25.02.2016, 14:45

Подсчёт количества видимых ячеек соответствующих определенному условию
Пытаюсь реализовать процентное соотношение ответов на вопросы. Необходимо...

Подсчёт количества текстового значения ячейки в нескольких диапазонах
Помогите пожалуйста с формулой подсчёта... При подсчёте в одном диапазоне я...

Подсчёт суммы из ячеек разных листов при выборе диапазона
Здравствуйте! Есть макрос, который при выполнении считает сумму со всех ячеек...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru