Форум программистов, компьютерный форум, киберфорум
Наши страницы

MS Office Excel

Войти
Регистрация
Восстановить пароль
 
swordsmaster
0 / 0 / 0
Регистрация: 07.04.2016
Сообщений: 7
#1

Упрощение функции ЕСЛИ(ИЛИ) - MS Excel

25.04.2016, 11:15. Просмотров 264. Ответов 13
Метки нет (Все метки)

Добрый день!
Помогите оптимизировать массивную формулу.
В примере, журнал учета рабочего времени. Сотрудники указывают время входа/выхода. Столбец С заполняется автоматически табельными номерами при вводе фамилии.
Столбец I заполняется в соответствии со значениями столбца H.
Главная проблема в этом самом столбце H. Формула получилась длинная и неудобно редактируемая. При появлении новых сотрудников или увольнении существующих, ее приходится переписывать практически полностью.
Есть варианты ее улучшить?

Заранее спасибо!
0
Вложения
Тип файла: xls List.xls (79.5 Кб, 6 просмотров)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
25.04.2016, 11:15
Я подобрал для вас темы с готовыми решениями и ответами на вопрос Упрощение функции ЕСЛИ(ИЛИ) (MS Excel):

Функция ЕСЛИ внутри функции ИЛИ внутри ЕСЛИ - MS Excel
Здравствуйте! Помогите решить, пожалуйста, данную задачу. =ЕСЛИ(ИЛИ(A2=ЕСЛИ(A1=1;"Отбор";"");B2=ЕСЛИ(A1=1;"Отбор";""));"Да";"Нет"),...

Используя функции ЕСЛИ и ИЛИ, определить стоимость разговора - MS Excel
Доброго времени суток! Есть одна очень трудная формула, с которой никак не могу справиться... Может кто сможет помочь? Суть в...

Нужно дополнить формулу условием ЕСЛИ или И или ИЛИ - MS Excel
Здравствуйте, второй день собираю формулу на подстановку данных в столбце, сегодня нашел вариант и почти правильно работает, но загвоздка в...

И ИЛИ ЕСЛИ НЕ - MS Excel
Добрый день.Не могу решить задачу,объясните как решать ее. "Построить формулу для определения зависимости y от х с использованием...

ЕСЛИ+ИЛИ (И) - MS Excel
Доброго времени суток. Нужна помощь в сложной формуле на несколько действий. Если кратко, суть формулы в том, чтоб: 1) проанализировать 2...

Формулы ЕСЛИ И ИЛИ - MS Excel
=ЕСЛИ(И((G5+H5)<=0;(F5<=0);(O5+P5)>=1000;(X5+W5)>=1000;(AE5+AF5)>=1000);"Новый нормальный";...

13
Fairuza
Модератор
5204 / 2632 / 470
Регистрация: 23.11.2010
Сообщений: 8,690
25.04.2016, 11:29 #2
Лучший ответ Сообщение было отмечено автором темы, экспертом или модератором как ответ
swordsmaster, объясните словами что эта формула делает в столбце Н?

Добавлено через 3 минуты
В таблице на листе 2 добавьте соответствие "ОВП;корпоративная газета;редакция по ТРК" и ВПР() по табельному номеру, если правильно понимаю
1
swordsmaster
0 / 0 / 0
Регистрация: 07.04.2016
Сообщений: 7
25.04.2016, 11:38  [ТС] #3
Цитата Сообщение от Fairuza Посмотреть сообщение
swordsmaster, объясните словами что эта формула делает в столбце Н?
Эта формула определяет какой из сотрудников к какому отделу принадлежит. И определив, выводит название этого отдела.
Сделал это вручную, таким кривым способом, потому как немного не понимаю, как иначе.

Цитата Сообщение от Fairuza Посмотреть сообщение
В таблице на листе 2 добавьте соответствие "ОВП;корпоративная газета;редакция по ТРК" и ВПР() по табельному номеру, если правильно понимаю
Возле каждого сотрудника, написать в каком он отделе?
0
AlexM
1722 / 1306 / 524
Регистрация: 04.09.2015
Сообщений: 2,567
25.04.2016, 11:47 #4
Лучший ответ Сообщение было отмечено автором темы, экспертом или модератором как ответ
Если доработать таблицу на Лист2, то формула получится
Код
=ВПР(D5;Лист2!A$2:C$18;3;0)
1
Вложения
Тип файла: xls List_1.xls (73.5 Кб, 3 просмотров)
swordsmaster
0 / 0 / 0
Регистрация: 07.04.2016
Сообщений: 7
25.04.2016, 11:56  [ТС] #5
Цитата Сообщение от Fairuza Посмотреть сообщение
В таблице на листе 2 добавьте соответствие "ОВП;корпоративная газета;редакция по ТРК" и ВПР() по табельному номеру, если правильно понимаю
Цитата Сообщение от AlexM Посмотреть сообщение
Если доработать таблицу на Лист2, то формула получится

Спасибо огромное! Уже понял свою ошибку. Даже стыдно

Еще раз спасибо за быстрый ответ!
0
AlexM
1722 / 1306 / 524
Регистрация: 04.09.2015
Сообщений: 2,567
25.04.2016, 11:59 #6
Для Щеголь М.В. ВПР() возвращает 0, чтобы нули спрятать сделан пользовательский формат ячеек тип ;;;@
0
AlexM
1722 / 1306 / 524
Регистрация: 04.09.2015
Сообщений: 2,567
25.04.2016, 12:05 #7
ВПР() для столбца I
Код
=ЕСЛИ(H5=0;"";ВПР(H5;Лист2!F$2:G$4;2;0))
0
Вложения
Тип файла: xls List_2.xls (70.5 Кб, 2 просмотров)
swordsmaster
0 / 0 / 0
Регистрация: 07.04.2016
Сообщений: 7
25.04.2016, 12:39  [ТС] #8
Цитата Сообщение от AlexM Посмотреть сообщение
Для Щеголь М.В. ВПР() возвращает 0, чтобы нули спрятать сделан пользовательский формат ячеек тип ;;;@
Для Щеголь возвращает 0, просто потому что у Вас не заполнено поля отдела для него, если я правильно понимаю.
0
AlexM
1722 / 1306 / 524
Регистрация: 04.09.2015
Сообщений: 2,567
25.04.2016, 12:42 #9
Цитата Сообщение от swordsmaster Посмотреть сообщение
потому что у Вас не заполнено поля отдела для него
Так и ваша ЕСЛИ() возвращала пусто для Щеголь. Поэтому я оставил в таблице незаполненную ячейку для него.
0
swordsmaster
0 / 0 / 0
Регистрация: 07.04.2016
Сообщений: 7
25.04.2016, 12:47  [ТС] #10
Цитата Сообщение от AlexM Посмотреть сообщение
Так и ваша ЕСЛИ() возвращала пусто для Щеголь. Поэтому я оставил в таблице незаполненную ячейку для него.
Исправил. Значит условие ЕСЛИ для столбца I и не нужно, я так понимаю. Достаточно просто ВПР.

В еще незаполненных ячейках ВПР выдает #Н/Д. Убрать его можно только условным форматированием? Закрашивать пустые ячейки?
0
AlexM
1722 / 1306 / 524
Регистрация: 04.09.2015
Сообщений: 2,567
25.04.2016, 12:52 #11
Лучще с ЕСЛИ()
Код
=ЕСЛИ(D5="";"";ВПР(D5;Лист2!A$2:C$18;3;0))
0
swordsmaster
0 / 0 / 0
Регистрация: 07.04.2016
Сообщений: 7
25.04.2016, 13:08  [ТС] #12
Цитата Сообщение от AlexM Посмотреть сообщение
Лучще с ЕСЛИ()
Код
=ЕСЛИ(D5="";"";ВПР(D5;Лист2!A$2:C$18;3;0))
А не могли бы Вы тогда пояснить необходимость пользовательского формата, как указали выше. И самого выражения ЕСЛИ...
Не могу понять, что он делает...
0
AlexM
1722 / 1306 / 524
Регистрация: 04.09.2015
Сообщений: 2,567
25.04.2016, 13:14 #13
Если на Лист2 таблица полностью заполнена, то нуля не будет, значит пользовательский формат не нужен.
Если ячейка в столбце D пустая, то ВПР() вернет Н/Д. ЕСЛИ() делает проверку, если в ячейке столбца D пусто, то выводить пусто, если фамилия в D есть, то работает ВПР()
1
swordsmaster
0 / 0 / 0
Регистрация: 07.04.2016
Сообщений: 7
25.04.2016, 13:26  [ТС] #14
Цитата Сообщение от AlexM Посмотреть сообщение
Если на Лист2 таблица полностью заполнена, то нуля не будет, значит пользовательский формат не нужен.
Если ячейка в столбце D пустая, то ВПР() вернет Н/Д. ЕСЛИ() делает проверку, если в ячейке столбца D пусто, то выводить пусто, если фамилия в D есть, то работает ВПР()
Понял, спасибо! Запутался во множестве кавычек )))
Так намного лучше.

Спасибо за разъяснения!
0
25.04.2016, 13:26
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
25.04.2016, 13:26
Привет! Вот еще темы с ответами:

Excel ЕСЛИ И ИЛИ - MS Excel
В ячейку С9 записать: - абсолютное значение разницы чисел из ячеек C7 и C8, если числа в C7 и C8 положительные - разность между C8 и...

Если(И(ИЛИ. матрица 4*2 - MS Excel
Подскажите пжлст как решить матрицу 4*2 согласно примера. Я пытаюсь через ЕСЛИ(И(ИЛИ но не могу написать формулу. Какой способ наиболее...

По функции ЕСЛИ - MS Excel
Есть список студентов, их набранные баллы, факультет с проходным баллом и условие меньше 100 баллов студент не поступает вообще. Как...

Аргументы функции если - MS Excel
Доброго времени суток, участники форума. Обращаюсь к вам вот с каким вопросом: Задана функция ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
14
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru