Форум программистов, компьютерный форум, киберфорум
Наши страницы
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.83/6: Рейтинг темы: голосов - 6, средняя оценка - 4.83
webz
3 / 3 / 0
Регистрация: 11.02.2016
Сообщений: 23
1

Функция ЕСЛИ с двумя условиями

27.07.2016, 18:48. Просмотров 1114. Ответов 3
Метки нет (Все метки)

Добрый день, наверно задача стара как мир, но не смог найти в поиске.

Есть список товаров (5000 шт) от 50+ производителям.
у двоих производителей свои фиксированные курсы (ячейки G2 и G3)
у остальных курс ЦБ (ячейка G4)
Задача: расчитать формулой столбец D (цена в рублях) по логике.
Если значение ячейки равно "поставщик1", то цена умнощаеться на один курс
Если значение ячейки равно "поставщик2", то цена умнощаеться на второй курс
В противном случае, умножается на третий курс

Знаний хватило только на сравнение одного поля
Код
=ЕСЛИ(B2="Поставщик1";C2*G2;C2*G4)
0
Миниатюры
Функция ЕСЛИ с двумя условиями  
Вложения
Тип файла: xlsx пример автозаполнения курса.xlsx (12.6 Кб, 5 просмотров)
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
27.07.2016, 18:48
Ответы с готовыми решениями:

Формула ЕСЛИ с двумя условиями
Мне нужно сделать двойную формулу ЕСЛИ, но у меня не получается, т.е. двойное...

Функция Если с тремя условиями
Не могу разобраться. По условию нужно составить функцию если, думала легко не...

Функция ЕСЛИ с несколькими условиями
Доброго времени суток! Задали решить задачу. Все написала,но почему то он...

Функция ЕСЛИ с несколькими условиями
Здравствуйте! Помогите, пожалуйста!!!! Есть таблица, с наименованием товара....

Функция ЕСЛИ с несколькими условиями
Здравствуйте!Задали решить задачу через ЕСЛИ Помогите пожалуйста

3
Fairuza
Модератор
5206 / 2634 / 471
Регистрация: 23.11.2010
Сообщений: 8,690
27.07.2016, 20:19 2
Лучший ответ Сообщение было отмечено webz как решение

Решение

Чуть додумать если Вашу формулу)
Код
=C2*ЕСЛИ(B2="Поставщик1";60;ЕСЛИ(B2="Поставщик2";62;65))
1
webz
3 / 3 / 0
Регистрация: 11.02.2016
Сообщений: 23
27.07.2016, 20:32  [ТС] 3
Fairuza, просто курсы меняються. Поэтому вывел их отдельно, чтобы лишний раз не лезть в формулу.
P.S. Спасибо, за наводку. В итое получилась вот такая формула
Код
=C2*ЕСЛИ(B2="Поставщик1";$G$2;ЕСЛИ(B2="Поставщик2";$G$3;$G$4))
0
Vlad999
2813 / 1728 / 516
Регистрация: 02.11.2012
Сообщений: 4,317
28.07.2016, 09:23 4
еще вариант для общего развития
Код
=C2*ЕСЛИОШИБКА(ВПР(B2;$F$2:$G$3;2;);$G$4)
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
28.07.2016, 09:23

Построить график функции от одной переменной с двумя условиями,условный оператор "если"
Построить график функции от одной переменной с двумя условиями,условный...

Выборка с двумя условиями
Доброго времени суток. Существует задача (не из жизни, но всё-равно нужно...

Поиск в диапазоне с двумя условиями
Добрый вечер! Помогите поправить формулу или написать заново. Файл во...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru