Форум программистов, компьютерный форум, киберфорум
Наши страницы
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/6: Рейтинг темы: голосов - 6, средняя оценка - 4.67
sv-zzz
0 / 0 / 0
Регистрация: 05.11.2016
Сообщений: 11
1

Перенос значений из строк в столбцы. При выполнении по 2-х условий, объединение данных в одну строку. Удаление

25.11.2016, 12:17. Просмотров 1123. Ответов 7
Метки нет (Все метки)

Добрый день, подскажите, как решить задачу.
Есть выгрузка данных, необходимо перенести значения строк со значением «есть на складе», «продано», «заказ» в соответствующие столбцы. При совпадении номера склада и кода – объединить данные в рамках одной строки и удалить лишние.
Файл более 3000 срок. Опыт в Экселе не большой, если можно самый простой вариант..
Заранее благодарю за помощь
0
Вложения
Тип файла: xlsx пример2.xlsx (28.9 Кб, 7 просмотров)
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
25.11.2016, 12:17
Ответы с готовыми решениями:

Перенос данных с листов при выполнении условий
Доброго времени суток Всем! Нужна помощь! Таблица прилагается. Имеются более 60 объектов , по...

Перенос строки на другой лист, при выполнении 2 условий
Добрый день. Имеется лист общего списка сотрудников, необходимо, чтобы при выполнении условия...

Объединение строк в одну строку
здравствуйте! как организовать в bat такое приведу пример 1.txt написано "ира" во втором 2.txt...

Объединение массива строк в одну строку
Объединение массива строк в одну строку. В чем ошибка? Заранее спасибо! #include <stdio.h> ...

Объединение/склеивание группы строк в одну строку
Здравствуйте, задача следующая... Существует файл 1.txt, в котором находится очень много строк в...

7
AlexM
2039 / 1472 / 599
Регистрация: 04.09.2015
Сообщений: 2,961
25.11.2016, 13:33 2
Лучший ответ Сообщение было отмечено sv-zzz как решение

Решение

5 формул массива, ввод тремя клавишами Ctrl+Shift+Enter.
Ошибку в столбцах I,J и K вскрыть функцией ЕСЛИОШИБКА()
1
Вложения
Тип файла: rar sv-zzz.rar (16.9 Кб, 6 просмотров)
Fairuza
5213 / 2642 / 471
Регистрация: 23.11.2010
Сообщений: 8,690
25.11.2016, 13:35 3
Проще всего это сделать сводной таблицей
0
Вложения
Тип файла: xlsx пример2.xlsx (34.2 Кб, 5 просмотров)
sv-zzz
0 / 0 / 0
Регистрация: 05.11.2016
Сообщений: 11
26.11.2016, 21:29  [ТС] 4
Спасибо, AlexM, т.к. со сводными таблицами работать не умею, попробовала ваш вариант.
Долго мучилась с формулами, не получается... почему то подставляются не всегда правильные значения или вообще не подставляются.
На втором листе я скопировала ваш ответ, подставила в формулы больший размер данных - проблема та же. Подскажите что не так.
0
Вложения
Тип файла: xlsx 111_01.xlsx (97.4 Кб, 4 просмотров)
26.11.2016, 21:29
AlexM
2039 / 1472 / 599
Регистрация: 04.09.2015
Сообщений: 2,961
26.11.2016, 23:17 5
Вы в столбце I неправильно ввели формулу массива. Неточности в работе формул не заметил.
Ошибки убрал не функцией ЕСЛИОШИБКА(), а условным форматированием.
Вам советую использовать функцию.
0
Вложения
Тип файла: xlsx 111_02.xlsx (95.7 Кб, 7 просмотров)
sv-zzz
0 / 0 / 0
Регистрация: 05.11.2016
Сообщений: 11
27.11.2016, 00:40  [ТС] 6
подскажите, плз, в чем ошибка, я видимо туплю..
1-я формула в столбце I с вашего листа, вторая с моего
=ВПР($G5&$H5&I$2;ЕСЛИ({1;0};$A$3:$A$200&$B$3:$B$200&$C$3:$C$200;$D$3:$D$200);2;0)
=ВПР($G5&$H5&I$2;ЕСЛИ({1;0};$A$3:$A$200&$B$3:$B$200&$C$3:$C$200;$D$3:$D$200);2;0)
все совпадает...
ваша работает, у меня - нет
0
AlexM
2039 / 1472 / 599
Регистрация: 04.09.2015
Сообщений: 2,961
27.11.2016, 00:48 7
Такое впечатление, что вы не внимательно читаете ответы
Цитата Сообщение от AlexM Посмотреть сообщение
Вы в столбце I неправильно ввели формулу массива.
Цитата Сообщение от AlexM Посмотреть сообщение
5 формул массива, ввод тремя клавишами Ctrl+Shift+Enter.
При правильном вводе формул массива, формулы автоматически обрамляются фигурными скобками, т.е. получается так {=формула}
0
sv-zzz
0 / 0 / 0
Регистрация: 05.11.2016
Сообщений: 11
27.11.2016, 13:43  [ТС] 8
Спасибо, все получилось, формула в I действительно была без скобок{...}. Не обратила внимание. т.к. обычно, если не считывает Ctrl+Shift+Enter - то вообще не считает, а тут считает, но не правильно...
0
27.11.2016, 13:43
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
27.11.2016, 13:43

Перенос данных строк в столбцы
Добрый день! Пожалуйста помогите с сортировкой данных. Мне нужно записать данные из строк в...

Перенос данных при соблюдении условий
Добрый день, уважаемые форумчане. Есть две таблицы. в одной наименование товара и дата покупки. в...

Можно ли автоматизировать перенос данных строк в столбцы
С определенными условиями. Шрифт разный. Словами не могу объяснить.) Пример в прикрепленном файле.


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
8
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru