Форум программистов, компьютерный форум, киберфорум
Наши страницы
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.50/4: Рейтинг темы: голосов - 4, средняя оценка - 4.50
dasfsf
0 / 0 / 0
Регистрация: 03.02.2017
Сообщений: 1
1

Отсортировать одинаковые значение в разных столбцах

03.02.2017, 14:45. Просмотров 656. Ответов 1
Метки нет (Все метки)

Пример:
1) Иван 25 петро 58
2) Петро 90 Иванка 44
3) Катя 41 Иван 31
4) Маша 85 Катя 90
5) Иванка 47 Маша 87

нужно сделать:
1) Иван 25 Иван 31
2) Петро 90 петро 58
3) Катя 41 Катя 90
4) Маша 85 Маша 87
5) Иванка 47 Иванка 44

Вот пример файла:
Кликните здесь для просмотра всего текста
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
03.02.2017, 14:45
Ответы с готовыми решениями:

Вычисление среднего числа в разных диапазонах и столбцах
Здравствуйте дорогие! С наступающим вас! нужно посчитать среднее число файл с примером...

Суммирование минимальных значений ячеек в разных столбцах по условию
Здравствуйте! Помогите решить проблему! Файл прикладываю. Суть проблемы в следующем: ...

3 разных поля, находим одинаковые значения?
Всем привет, ситуация такая: 1. СТолбец ID поля которые могут повторяться 2. Столбец состоит из...

Суммировать построчно одинаковые листы в разных таблицах
Добрый день! Имеется 365 файлов с одинаковыми таблицами, но с разными показателями в строках...

Перенос данных из разных таблиц, содержащих одинаковые условия
нужна помощь. есть 2 файла содержащие исходные данные: состоят из 2-х столбцов столбец А - это...

1
AlexM
2096 / 1518 / 613
Регистрация: 04.09.2015
Сообщений: 3,054
03.02.2017, 15:03 2
Так нужно? Две формулы
Код
=ЕСЛИ(СЧЁТЕСЛИ($K$1:$K1;K1)=1;ВПР(K1;$D$1:$E$5;1;);"")
=ЕСЛИ(СЧЁТЕСЛИ($K$1:$K1;K1)=1;ВПР(K1;$D$1:$E$5;2;);"")
Если третий аргумент у ВПР() написать не 1, а СТОЛБЕЦ(A1), то формулу можно протягивать не только вниз, но и вправо.
1
Вложения
Тип файла: xls Книга1_01.xls (28.5 Кб, 7 просмотров)
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
03.02.2017, 15:03

В матрице выбрать n элементов, стоящих в разных строках и разных столбцах, чтобы их сумма была минимальной
Примерный алгоритм как можно реализовать это

В матрице выбрать n элементов в разных строках и разных столбцах так, чтобы их сумма была минимальной
Помогите,пожалуйста Добавлено через 2 часа 23 минуты примерный алгоритм как это можно сделать

Одинаковые имена в столбцах 2 таблиц
$qSearch = mysql_query("SELECT * FROM data, categories WHERE data.cat = categories.id",$db); ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.