С наступающим Новым годом! Форум программистов, компьютерный форум, киберфорум
Наши страницы
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/6: Рейтинг темы: голосов - 6, средняя оценка - 4.67
Aleks 1978
5 / 5 / 0
Регистрация: 02.01.2017
Сообщений: 158
1

Формула с несколькими условиями

09.05.2017, 14:21. Просмотров 1099. Ответов 5
Метки нет (Все метки)

Уважаемые форумчане,подскажите с формулой,нужно в ячейке D1 функцию =ЕСЛИ(И( которая может выполнить сравнение с несколькими условиями,что если значение в ячейке A1 больше на 2 или меньше на 2 значения в ячейке B1,(вообщем нужно чтобы значение ячейки A1 было в пределах от плюс 2 до минус 2 от значения ячейки B1),то тогда первое условие выполнено,и ещё условия в этой же формуле если F1 > G1 и ещё что H1 > S1...
0
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
09.05.2017, 14:21
Ответы с готовыми решениями:

СЧЕТЕСЛИ с несколькими условиями
В прилагаемом примере табеля у слесаря и мастера учет рабочих дней ведется...

Функция с несколькими условиями
=ЕСЛИ(A1<(-1);(-2*x*sin(A1));.... Как мне правильно записать данную...

СЧЁТЕСЛИ с несколькими условиями.
Добрый день. Имеется таблица вида ...... Ячйки ...... ...

Логическая функция с несколькими условиями
Здарвствуйте! Помогите записать формулу с логической функцией, учитывая...

Функция ЕСЛИ с несколькими условиями
Здравствуйте!Задали решить задачу через ЕСЛИ Помогите пожалуйста

5
Fairuza
Модератор
5208 / 2636 / 471
Регистрация: 23.11.2010
Сообщений: 8,690
09.05.2017, 14:41 2
Aleks 1978, лучше приложить файл-пример с разъяснениями
0
OLEGOFF
977 / 443 / 111
Регистрация: 27.02.2013
Сообщений: 1,278
09.05.2017, 14:42 3
Цитата Сообщение от Aleks 1978 Посмотреть сообщение
и ещё условия в этой же формуле
и еще,и еще....
А еще файл прикрепите и что сделано? и условия полностью
0
Aleks 1978
5 / 5 / 0
Регистрация: 02.01.2017
Сообщений: 158
09.05.2017, 17:16  [ТС] 4
Код
=ЕСЛИ(И(ИЛИ(A1=B1;A1=B1+1;A1=B1+2;A1=B1-1;A1=B1-2);F1>G1;H1>S1);1;0)
Вот эта примитивная формула которая у меня получилась и которая условия выполняет,но если кто изменит на более компактное её написание буду благодарен.
0
OLEGOFF
977 / 443 / 111
Регистрация: 27.02.2013
Сообщений: 1,278
09.05.2017, 17:53 5
Лучший ответ Сообщение было отмечено Aleks 1978 как решение

Решение

Aleks 1978, вы хоть условия сформулируйте правильно.У меня получилось так
Visual Basic
1
=ЕСЛИ(И(ABS(A1-B1)>2;F1>G1;H1>S1);"да";"нет")
1
Vlad999
2860 / 1761 / 527
Регистрация: 02.11.2012
Сообщений: 4,406
10.05.2017, 13:50 6
OLEGOFF, скорее ABS(A1-B1) <=2 раз в пределах от плюс 2 до минус 2
1
10.05.2017, 13:50
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
10.05.2017, 13:50

Условное форматирование с несколькими условиями
Всем привет. Я не могу сделать условное форматирование столбца с несколькими...

Подсчет количества с несколькими условиями
Необходимо рассчитать: Количество сотрудников, заработная плата которых...

Подсчет строк с несколькими условиями
необходимо подсчитать количество строк с определенными параметрами и...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru