Форум программистов, компьютерный форум, киберфорум
Наши страницы

MS Office Excel

Войти
Регистрация
Восстановить пароль
 
Geedron
-1 / 0 / 0
Регистрация: 19.03.2018
Сообщений: 23
#1

Высчитывание суммы всех чисел, входящих в строку - MS Excel

16.04.2018, 14:16. Просмотров 115. Ответов 2
Метки нет (Все метки)

Книга7.xlsx
Начал делать, но не понимаю, как собрать число вместе( чтобы 23 было написано слитно).
Строка может быть любой, не только которая написана. (по типу "56 олыод 57 ыо")
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
16.04.2018, 14:16
Я подобрал для вас темы с готовыми решениями и ответами на вопрос Высчитывание суммы всех чисел, входящих в строку (MS Excel):

вычисление остатка от деления суммы чисел одного диапазона на сумму чисел другого - MS Excel
Необходимо записать формулу или функцию для вычисления остатка от деления суммы чисел диапазона А11:Е15 на сумму чисел диапазона A1:E5

Сумма всех чисел, входящих в строку - Ruby
Очень прошу помочь написать на Ruby программу, которая в .txt - файле находит числа и печатает сумму всех чисел данной строки.

Найти сумму всех чисел, входящих в строку - Turbo Pascal
Помогите написать программу, которая высчитывает сумму всех чисел входящих в строку.

Вывести строку, составленную из всех гласных букв, входящих в данную строку - Pascal ABC
1.Дана строка, напечатанная русскими буквами. Вывести строку, составленную из всех гласных букв, входящих в данную строку.

Сформировать строку, состоящую из всех строчных букв, входящих в заданную строку, без повторов - C (СИ)
14 . Сформировать строку, состоящую из всех строчных букв, входящих в заданную строку, без повторов. одна тема - одна задача, читайте...

Найти сумму всех четных цифр, входящих в строку - VB
дан текст содержащий буквы и цифры. Найти сумму всех четных цифр входящих в этот массив!

2
AlexM
1721 / 1305 / 524
Регистрация: 04.09.2015
Сообщений: 2,564
16.04.2018, 18:43 #2
Формула массива
Код
=СУММ(ЕСЛИ(ЕЧИСЛО(-ПСТР(ПОДСТАВИТЬ(A1;" ";ПОВТОР(" ";99));99*СТРОКА($1:$87)-98;99));--ПСТР(ПОДСТАВИТЬ(A1;" ";ПОВТОР(" ";99));99*СТРОКА($1:$87)-98;99)))
0
Вложения
Тип файла: xlsx Книга7_01.xlsx (7.8 Кб, 0 просмотров)
AlexM
1721 / 1305 / 524
Регистрация: 04.09.2015
Сообщений: 2,564
16.04.2018, 23:42 #3
Вариант покороче и не массивный
Код
=СУММПРОИЗВ(--(0&ТЕКСТ(ПСТР(ПОДСТАВИТЬ(A1;" ";ПОВТОР(" ";99));99*СТРОКА($1:$99)-98;99);"0;-0;;")))
2
Вложения
Тип файла: xlsx Книга7_02.xlsx (7.9 Кб, 6 просмотров)
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
16.04.2018, 23:42
Привет! Вот еще темы с ответами:

Напечатать множество всех строчных латинских согласных букв, входящих в строку - Turbo Pascal
Дана строка. В алфавитном порядке напечатайте (по разу) все строчные латинские согласные буквы, входящие в эту строку. Указание: гласные...

Найти сумму всех цифр, входящих в строку и удалить эти цифры. - Delphi
Дана строка, состоящая из букв и цифр. Найти сумму всех цифр, входящих в эту строку и получить новую строку путём удаления из исходной...

Напечатать позиции всех входящих в строку символов в алфавитном порядке: проверка кода - Free Pascal
Для введенной пользователем строки напечатать позиции всех входящих в неё символов (кроме пробелов) в алфавитном порядке. Для символов,...

Дана строка. Подсчитать процентное содержание всех символов входящих в данную строку. C++ - C++
Дана строка. Подсчитать процентное содержание всех символов входящих в данную строку. Для подсчета использовать массив структур, где...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru