Форум программистов, компьютерный форум, киберфорум
Наши страницы
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Geedron
-1 / 0 / 0
Регистрация: 19.03.2018
Сообщений: 23
#1

Высчитывание суммы всех чисел, входящих в строку

16.04.2018, 14:16. Просмотров 131. Ответов 2
Метки нет (Все метки)

Книга7.xlsx
Начал делать, но не понимаю, как собрать число вместе( чтобы 23 было написано слитно).
Строка может быть любой, не только которая написана. (по типу "56 олыод 57 ыо")
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
16.04.2018, 14:16
Ответы с готовыми решениями:

вычисление остатка от деления суммы чисел одного диапазона на сумму чисел другого
Необходимо записать формулу или функцию для вычисления остатка от деления суммы...

Сумма всех чисел, входящих в строку
Очень прошу помочь написать на Ruby программу, которая в .txt - файле находит...

Найти сумму всех чисел, входящих в строку
Помогите написать программу, которая высчитывает сумму всех чисел входящих в...

Вывести строку, составленную из всех гласных букв, входящих в данную строку
1.Дана строка, напечатанная русскими буквами. Вывести строку, составленную из...

Сформировать строку, состоящую из всех строчных букв, входящих в заданную строку, без повторов
14 . Сформировать строку, состоящую из всех строчных букв, входящих в заданную...

2
AlexM
1756 / 1335 / 535
Регистрация: 04.09.2015
Сообщений: 2,629
16.04.2018, 18:43 #2
Формула массива
Код
=СУММ(ЕСЛИ(ЕЧИСЛО(-ПСТР(ПОДСТАВИТЬ(A1;" ";ПОВТОР(" ";99));99*СТРОКА($1:$87)-98;99));--ПСТР(ПОДСТАВИТЬ(A1;" ";ПОВТОР(" ";99));99*СТРОКА($1:$87)-98;99)))
0
Вложения
Тип файла: xlsx Книга7_01.xlsx (7.8 Кб, 0 просмотров)
AlexM
1756 / 1335 / 535
Регистрация: 04.09.2015
Сообщений: 2,629
16.04.2018, 23:42 #3
Вариант покороче и не массивный
Код
=СУММПРОИЗВ(--(0&ТЕКСТ(ПСТР(ПОДСТАВИТЬ(A1;" ";ПОВТОР(" ";99));99*СТРОКА($1:$99)-98;99);"0;-0;;")))
2
Вложения
Тип файла: xlsx Книга7_02.xlsx (7.9 Кб, 6 просмотров)
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
16.04.2018, 23:42

Найти сумму всех четных цифр, входящих в строку
дан текст содержащий буквы и цифры. Найти сумму всех четных цифр входящих в...

Напечатать множество всех строчных латинских согласных букв, входящих в строку
Дана строка. В алфавитном порядке напечатайте (по разу) все строчные латинские...

Найти сумму всех цифр, входящих в строку и удалить эти цифры.
Дана строка, состоящая из букв и цифр. Найти сумму всех цифр, входящих в эту...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru