Форум программистов, компьютерный форум, киберфорум
Наши страницы
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/4: Рейтинг темы: голосов - 4, средняя оценка - 5.00
Geedron
-1 / 0 / 0
Регистрация: 19.03.2018
Сообщений: 23
1

Массив: Упорядочить по возрастанию ту часть последовательности, которая находится до максимального элемента...

20.05.2018, 23:10. Просмотров 764. Ответов 2
Метки нет (Все метки)

упорядочить по возрастанию ту часть последовательности, которая находится до максимального элемента этой последовательности.
не vba. Что-то вроде начал, но вот как упорядочить именно до максимального элемента. Книга5.xlsx
(смотреть лист 3)
0
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
20.05.2018, 23:10
Ответы с готовыми решениями:

Упорядочить по возрастанию ту часть последовательности, которая находится до максимального элемента этой последовательности
написать программу, которая упорядочивает по возрастанию ту часть...

Ввести одномерный массив X(N) (N<=90). Упорядочить в нем по возрастанию значений все элементы, стоящие после максимального элемента.
Помогите решить пожалуйста, целый день бьюсь никак не получается. Ввести...

Отсортировать часть массива до максимального элемента по возрастанию, а оставшуюся часть по убыванию
Дан одномерный массив, элементы которого различны. Отсортировать часть массива...

Упорядочить по возрастанию часть последовательности
Написать программу,которая упорядочивает по возрастанию ту часть...

Упорядочить по возрастанию часть последовательности
Написать программу, которая упорядочивает по возрастанию ту часть...

2
Казанский
14154 / 5853 / 1535
Регистрация: 24.09.2011
Сообщений: 9,195
21.05.2018, 00:59 2
Geedron,
поиск строки макс. элемента, Н1
Код
=ПОИСКПОЗ(МАКС(A:A);A:A;)
упорядочение в ст. I
Код
=ЕСЛИ(СТРОКА()>$H$1;A1;НАИМЕНЬШИЙ(СМЕЩ($A$1;;;$H$1);СТРОКА()))
1
Вложения
Тип файла: xlsx Книга5 (1).xlsx (15.0 Кб, 3 просмотров)
AleksSid
618 / 505 / 244
Регистрация: 05.01.2014
Сообщений: 1,111
21.05.2018, 08:44 3
Лучший ответ Сообщение было отмечено Geedron как решение

Решение

Вариант.
Код
1. =НАИМЕНЬШИЙ(ДВССЫЛ("A1:A"&ПОИСКПОЗ(МАКС($A$1:$A$25);$A$1:$A$25;0));СТРОКА())
Код
2. =НАИМЕНЬШИЙ($A$1:ИНДЕКС($A$1:$A$25;ПОИСКПОЗ(МАКС($A$1:$A$25);$A$1:$A$25;0));СТРОКА())
1
Вложения
Тип файла: xlsx сортир_до_макс.xlsx (14.8 Кб, 1 просмотров)
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
21.05.2018, 08:44

Упорядочить по возрастанию часть последовательности
Написать программу,которая упорядочивает по возрастанию ту часть...

Все элементы массива, стоящие до максимального элемента, упорядочить по возрастанию
Дан линейный массив из n элементов. Все элементы, стоящие до максимального...

Упорядочить в нем по возрастанию значений все элементы, стоящие после максимального элемента
Ввести одномерный массивX(N). Упорядочить в нем по возрастанию значений все...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru