Форум программистов, компьютерный форум, киберфорум
Наши страницы
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/4: Рейтинг темы: голосов - 4, средняя оценка - 5.00
Shevalieruss
0 / 0 / 0
Регистрация: 18.09.2015
Сообщений: 12
1

Применение нескольких условий к ячейке

01.06.2018, 14:39. Просмотров 748. Ответов 5
Метки нет (Все метки)

Доброго всем дня!
Понадобилось создать таблицу анализа и расчета коэффициента выгодности. Первая часть удалась, а со второй возникли трудности. При расчете этого коэффициента необходимо применять к ячейке несколько вариативных условий. По типу: если значение в ячейке А=абвг, то в ячейке В пишется "1", а если А=дежз, то В="2" и т.д.
Т.е.: Ячейка В должна выводить число из промежутка (1-6) в зависимости от значения ячейки А.

Как это реализовать?

Есть сложный вариант через =ЕСЛИ(А=1;абвг;0) и так еще пять ячеек, а потом еще ячейка с вычислением мне кажется это нагромождением ненужных формул.

Заранее благодарю за помощь)
0
Миниатюры
Применение нескольких условий к ячейке   Применение нескольких условий к ячейке  
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
01.06.2018, 14:39
Ответы с готовыми решениями:

Значение в ячейке в зависимости от двух условий
Всем привет! Нужно сделать так, чтоб значение в ячейку подставлялось в...

Проверка нескольких условий одновременно
Необходимо, что бы в ячейке M18 была формула, в которой при наличии хотя бы...

Выполнение сразу нескольких условий
Добрый день! Нужна помощь. Подведение итогов на соревнованиях проводится по...

Проверка нескольких условий для ячейки
Помогите, пожалуйста, написать, такие условия. В некоторых ячейках есть...

Составить одну формулу из нескольких условий
Eменя не получается сделать одну большую формулу с ЕСЛИ, чтобы было несколько...

5
Vlad999
2813 / 1728 / 516
Регистрация: 02.11.2012
Сообщений: 4,316
01.06.2018, 15:43 2
файл пример прикладываем.
0
Shevalieruss
0 / 0 / 0
Регистрация: 18.09.2015
Сообщений: 12
01.06.2018, 15:56  [ТС] 3
Прошу прощения. Забыл.
Лист1 - основная таблица. Значения раскиданы случайно
Лист2 - мои тщетные попытки

Сейчас попытался сделать через выпадающий список (тема ниже про них) и...#Н/Д
0
Вложения
Тип файла: xlsx анализ.xlsx (23.9 Кб, 2 просмотров)
AleksSid
616 / 504 / 243
Регистрация: 05.01.2014
Сообщений: 1,110
01.06.2018, 16:16 4
Лучший ответ Сообщение было отмечено Shevalieruss как решение

Решение

Если правильно понял.
Код
=ЕСЛИОШИБКА(ИНДЕКС(D4:I4;;ПОИСКПОЗ(H9;D3:I3;0));"")
1
Вложения
Тип файла: xlsx анализ_1.xlsx (23.1 Кб, 1 просмотров)
Shevalieruss
0 / 0 / 0
Регистрация: 18.09.2015
Сообщений: 12
01.06.2018, 17:14  [ТС] 5
Да, оно самое. Большое благодарю

Добавлено через 42 минуты
А как реализовать тоже самое для столбца с ценой? где "меньше или равно среднему"=1 и "больше среднего"=2
Вывод средней суммы в самой правой колонке
0
AleksSid
616 / 504 / 243
Регистрация: 05.01.2014
Сообщений: 1,110
01.06.2018, 17:39 6
Если цену проставляете руками тогда так.
Код
ЕСЛИ(цена<=AO5;1;2)
И еще, формула для столбца средняя цена
Код
=СРЗНАЧЕСЛИ($B$4:$AM$5;$AM$4;B5:AM5)
1
01.06.2018, 17:39
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
01.06.2018, 17:39

Расчет значения в зависимости от нескольких условий
Определить сумму «к выплате», которая получена в результате расчетов заработной...

Нужна определить значения ячейки исходя из нескольких условий
Друзья добрый день.Нужна помощь.В общем есть такая задача Нужно получить...

Выбор значения ячейки при совпадении нескольких условий
Есть программа, поддерживающая импорт\экспорт данных. Данные следующего вида:...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru