Форум программистов, компьютерный форум, киберфорум
Наши страницы
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.50/8: Рейтинг темы: голосов - 8, средняя оценка - 4.50
mol2751
8 / 8 / 2
Регистрация: 08.07.2015
Сообщений: 151
1

Как проигнорировать ячейку если она уже проанализирована формулой?

11.09.2018, 12:25. Просмотров 1488. Ответов 5
Метки нет (Все метки)

Есть таблица где в одном столбце текстовые даннные во втором и третьем числовые. Надо проанализировать текст в 1ом столбце если находится слово содержащее "бабу" или "деду", то далее смотрим на другие столбцы и вытаскиваем нужные числа. Все работает, через формулу =СУММЕСЛИМН(B2:B7;A2:A7;"*бабу*";C2:C7;"=200")+СУММЕСЛИМН(B2:B7;A2:A7;"*деду*";C2:C7;"=200"), однако если в столбце с текстом в одной ячейке есть слова содержащие и "бабу" и "деду", то это ячейка два раза анализируется и суммируется. Как это исключить. Типа если в ячейке нашлось "бабу", выцепили нужное числовое значение согласно формуле, то далее мы эту ячейку не просматриваем когда ищем "деду"...

может сумбурно написал, файл во вложении.
Ответ вышел что очков для бабушек и дедушек по цене 200 48 штук, а на самом деле 28.
0
Вложения
Тип файла: xlsx Книга99.xlsx (9.5 Кб, 2 просмотров)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
11.09.2018, 12:25
Ответы с готовыми решениями:

Как вставить в ячейку с формулой цифры?
пример: A1=A1-B1 как создать такую формулу помогите

КАк разобраться с формулой, уже голову сломал
Добрый день, помогите решить задачку: Как с помощью экселя сделать следущее, есть число А1= 2,90,...

Подскажите по добавлению в ячейку таблицы если она пуста и если есть чтото
Задача добавлять значения в ячейку group с разделителем ", ", если делать так update users set...

Как программно удалить кнопку которую программно создал но только если она уже существует
Есть ScrollView в котором много компонентов,чтоб не выводить сразу все решил выводить по 10 штук и...

Запретить открытие формы если она уже открыта
Из главной формы открываю еще одну форму кнопкой. При повторном нажатии вызывается повторно...

5
Казанский
14895 / 6300 / 1717
Регистрация: 24.09.2011
Сообщений: 9,977
11.09.2018, 12:38 2
Лучший ответ Сообщение было отмечено mol2751 как решение

Решение

mol2751, формула массива
Код
=СУММПРОИЗВ(ЕСЛИ(ЕЧИСЛО(ПОИСК("бабу";A2:A7));1;ЕСЛИ(ЕЧИСЛО(ПОИСК("деду";A2:A7));1;))*(C2:C7=200)*B2:B7)
1
Вложения
Тип файла: xlsx Книга99.xlsx (9.3 Кб, 4 просмотров)
mol2751
8 / 8 / 2
Регистрация: 08.07.2015
Сообщений: 151
11.09.2018, 12:52  [ТС] 3
Спасибо

Добавлено через 4 минуты
Только один вопрос, как в форуме эти фигурные скобки ставить {}
0
Казанский
14895 / 6300 / 1717
Регистрация: 24.09.2011
Сообщений: 9,977
11.09.2018, 12:55 4
Лучший ответ Сообщение было отмечено mol2751 как решение

Решение

mol2751, формула массива вводится нажатием Ctrl+Shift+Enter. Подробнее F1 - Обзор формул - Использование формул массива и констант массива
Можно такой формулой без массива, в нее проще добавлять несколько условий
Код
=СУММПРОИЗВ(ЗНАК(МУМНОЖ(--ЕЧИСЛО(ПОИСК({"бабу";"деду"};A2:A7));{1:1}))*(C2:C7=200)*B2:B7)
1
mol2751
8 / 8 / 2
Регистрация: 08.07.2015
Сообщений: 151
11.09.2018, 15:36  [ТС] 5
Все разобрался как масив вводить. спасибо.

Добавлено через 2 часа 40 минут
=СУММПРОИЗВ(ЗНАК(МУМНОЖ(--ЕЧИСЛО(ПОИСК({"бабу";"деду"};A2:A7));{1:1}))*(C2:C7=200)*B2:B7)

эта формула стала вызвать дикое подвисание Excel, файл открывается около минуты. И если ее протянуть и потом менять значения Excel виснет и закрывается. Если просто копировать и вставлять и сразу там в формуле менять, то норм. Но зависание при открытии файла осталось. В чем тут дело?
0
Казанский
14895 / 6300 / 1717
Регистрация: 24.09.2011
Сообщений: 9,977
11.09.2018, 16:18 6
mol2751, насколько я понимаю, речь не об именно этой формуле, а той, которую Вы составили для своих реальных данных. Насколько большие диапазоны используются? Если тысячи строк исходных данных, да формулу протянуть на несколько тысяч строк, то объем вычислений действительно получается большой. В формуле из #2 вычислений гораздо меньше.
Возможно, Вам более подойдет решение на VBA.
0
11.09.2018, 16:18
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
11.09.2018, 16:18

Не создавать запись в БД если она уже существует а просто обновить
Доброго всем дня. Ситуация такая, есть БД MSSQL и php скрипт добавления данных Задача в...

задача на множества, если она уже решена то прошу ссылку
. Напечатать текст, за которым следует точка. В алфавитном порядке напечатать все строчные русские...

Запретить открывать форму с данными, если она уже открыта другими
Добрый день. Есть список с данными, нажимая 2 раза, открывается форма с этими детальными данными....


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru