Форум программистов, компьютерный форум, киберфорум
Наши страницы
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.71/7: Рейтинг темы: голосов - 7, средняя оценка - 4.71
d7d1cd
210 / 141 / 51
Регистрация: 30.06.2011
Сообщений: 1,351
Завершенные тесты: 1
1

Ошибка #ЗНАЧ при подсчете значения

24.11.2018, 22:15. Просмотров 1297. Ответов 2
Метки нет (Все метки)

Приветствую всех. В ячейке A2 есть формула: =ЕСЛИ(A1=1;100;""). В ячейке A3 другая формула =A2+100. Если в ячейку A1 ввести 1, то все хорошо. Если же там будет что-то кроме 1, то формула в ячейке A3 не работает (ошибка #ЗНАЧ). Можно это как-то обойти, ведь если формула ссылается на пустую ячейку, то расчет проходит (считается, что там 0)?
0
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
24.11.2018, 22:15
Ответы с готовыми решениями:

МАКС знач ячейки 9999 и пересчет с 1 при превышении значения
Здравствуйте помогите разобраться. Нужно сделать так чтобы ячейке не превышала значение 9999 а если...

Ошибка ЗНАЧ при вычислении формулы
Добрый день! Возникает ошибка ЗНАЧ при использовании формулы ПОИСКПОЗ Прилагаю пример, в чем...

Ошибка #ЗНАЧ!
=ЕСЛИ(И(C6>=0;C6<=1);SIN(C6)*EXP(C6));ЕСЛИ(C6>1;2*COS(C6)*COS(C6);C6+КОРЕНЬ(1+C6*C6))

Ошибка Знач в функции
=ЕСЛИ(И(ИНДЕКС('1738'!$F$8:$AS$371;(ПОИСКПОЗ(C2;'1738'!$F:$F;0));'1738'!P$1)<>0;ИНДЕКС('Sheet1'!$C:$...

Выдается ошибка Знач
Не могу понять где ошибка.... На листе "командное" почему - не хочет считать ячейку С16

2
Narimanych
422 / 338 / 172
Регистрация: 23.03.2015
Сообщений: 1,132
24.11.2018, 22:47 2
d7d1cd,
Попробуйте в А3 формулу ЕСЛИОШИБКА...
0
pashulka
2753 / 1425 / 589
Регистрация: 01.12.2010
Сообщений: 2,813
25.11.2018, 07:32 3
Лучший ответ Сообщение было отмечено d7d1cd как решение

Решение

Ячейка, содержащая формулу, в принципе не может быть пустой. Тем более, когда эта формула возвращает текст, в т.ч. и ""

Так что, если нельзя заменить "" на 0 (и скрыть его с помощью форматирования), то на выбор ещё несколько вариантов :

Код
=Ч(A2)+100
Код
=СУММ(A2;100)
1
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
25.11.2018, 07:32

Умножение матриц - ошибка #ЗНАЧ
Происходит ошибка умножения матриц. Не пойму в чем проблема. Все поля заполняются #ЗНАЧ. Кто-то...

Ошибка в *ЗНАЧ причина не могу найти
Господа, помогите решить проблему. При импорте данных из интернета вставляются цифры и текст...

Ошибка #ЗНАЧ! подскажите можно ли исправить в моей работе
Откуда и почему берется - происходит данная ошибка - читала, но как ее исправить, чтоб у меня...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru