Форум программистов, компьютерный форум, киберфорум
Наши страницы
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
pilgrim56
0 / 0 / 0
Регистрация: 05.06.2014
Сообщений: 18
1

Как найти количество совпадений в таблице (массиве) excel по строкам?

06.12.2018, 00:34. Просмотров 116. Ответов 4
Метки нет (Все метки)

Здравствуйте! Как найти совпадения по строкам в таблице (массиве) в Excel и вывести их в отдельную таблицу. Совпадение по строкам не точное, а например по 8 данным при 10 столбцах в строке? Эти 8 данных не известны.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
06.12.2018, 00:34
Ответы с готовыми решениями:

Найти количество совпадений
Вопрос такой - в какое количество магазинов была отправлена продукция 20.03.2013 . Я упростил...

Как добавить строку в таблице Excel
Как в таблице Ексель добавить строку в конце таблицы Сразу после 24 строки мне нужно добавить еще...

Как в таблице Excel сделать фильтр?
Появилась необходимость из большой таблицы, чтобы показывались только те строчки, которые имеют...

Как в таблице Excel сделать печатающийся фон
Народ, я Basic не знаю, но нужна помощь, как в таблице Excel сделать печатающийся фон, то есть что...

Сравнить два бинарных файла и вывести в label количество не совпадений, или что нет не совпадений
Добрый день ! Прошу помощи в реализации задачи. В программе нужно сравнить два файла (разной...

4
Vlad999
2860 / 1761 / 527
Регистрация: 02.11.2012
Сообщений: 4,406
06.12.2018, 08:40 2
файл пример прикладываем.
0
pilgrim56
0 / 0 / 0
Регистрация: 05.06.2014
Сообщений: 18
06.12.2018, 18:57  [ТС] 3
Добрый вечер! Прикладываю пример.
0
Вложения
Тип файла: xlsx Пример1.xlsx (10.6 Кб, 4 просмотров)
AlexM
1923 / 1404 / 571
Регистрация: 04.09.2015
Сообщений: 2,772
06.12.2018, 23:35 4
Количество совпадений можно найти по формуле (формула массива)
Код
=СУММ(--(МУМНОЖ(ТРАНСП(СЧЁТЕСЛИ(СМЕЩ(B2:M2;ТРАНСП(СТРОКА(1:19)-1););O1:O8));СТРОКА(O1:O8)^0)=8))
0
Вложения
Тип файла: xlsx Пример1_01.xlsx (11.4 Кб, 4 просмотров)
pilgrim56
0 / 0 / 0
Регистрация: 05.06.2014
Сообщений: 18
07.12.2018, 00:33  [ТС] 5
Доброй ночи!
Вы меня не поняли, 5;8;14;51;69;73;84;90 не известны. Задано только количество совпадений по которым производится поиск, но без конкретных данных. В данном случае их 8, но может быть задано и 9.
Спасибо за внимание и за ответ.
0
07.12.2018, 00:33
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
07.12.2018, 00:33

Найти в массиве совпадающие числа, напечатать их в порядке убывания количества совпадений
Помогите найти ошибку. Дан массив целых чисел. Составить программу нахождения совпадающих...

Массивы, найти большее количество совпадений
Дан массив А размером , заполненный рандомно от А до C. Нужной вывести на экран, ту букву которая...

Найти количество совпадений одинаковых цифр
Напишите пожалуйста кто-нибудь свой вариант программы решения задания : Я пробовал делать ,...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru