Форум программистов, компьютерный форум, киберфорум
Наши страницы
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.80/5: Рейтинг темы: голосов - 5, средняя оценка - 4.80
tna111
1 / 1 / 0
Регистрация: 10.01.2017
Сообщений: 21
1

Создать таблицу из списка

18.04.2019, 14:27. Просмотров 862. Ответов 4

Задача следующая.
1. Есть таблица 2
2. Нужно сделать из нее таблицу 1 (по 1 и 2 столбцам второй таблицы) и записать значение из 2 столбца второй.

Пример прилагаю.

По формуле что сейчас у меня пробита работает только для первого вхождения столбца 1.
0
Вложения
Тип файла: xlsx Слияни табл.xlsx (10.3 Кб, 7 просмотров)
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
18.04.2019, 14:27
Ответы с готовыми решениями:

из списка в таблицу
Здравствуйте! Есть список покупок по нескольким людям в разные дни, можно ли как-то их забить в...

Не получается создать таблицу (отсутствует пункт "Создать таблицу")
Здравствуйте. Пытаюсь создать базу данных и сталкиваюсь с наиглупейшей проблемой - в контекстном...

создать таблицу базы данных в Accesse.Определить связи между табл.один ко многим.Создать форму.Создать 3 запроса и не менее двух отчётов.
Исходные данные:ЖЭК:ФИО слесаря,адрес слесаря, перечень выполняемых работ,перечень обслуживаемых...

Создать два списка, поместив в первый отрицательные, а во второй – положительные элементы исходного списка
Помогите пожалуйста решить следующие задачи: 1. Задан список чисел. Создать два списка, поместив...

Создать процедуру для добавления элемента в заданную позицию списка и вывода списка на экран
Вот у меня есть готовая программа.Объясните мне пожалуйста каждую строчку чтоб я понял.Желательно...

4
tna111
1 / 1 / 0
Регистрация: 10.01.2017
Сообщений: 21
18.04.2019, 14:49  [ТС] 2
2. Нужно сделать из нее таблицу 1 (по 1 и 2 столбцам второй таблицы) и записать значение из 3 столбца второй.
0
AlexM
2053 / 1483 / 603
Регистрация: 04.09.2015
Сообщений: 2,987
18.04.2019, 17:02 3
Формула массива
Код
=ЕСЛИ(ЕНД(ВПР($B5&"|"&C$4;$I$5:$I$10&"|"&$J$5:$J$10;;));"";ВПР($B5&"|"&C$4;ЕСЛИ({1;0};$I$5:$I$10&"|"&$J$5:$J$10;$K$5:$K$10);2;))
1
Вложения
Тип файла: xlsx Слияни табл_01.xlsx (9.9 Кб, 3 просмотров)
Czeslav
729 / 408 / 122
Регистрация: 30.03.2013
Сообщений: 832
18.04.2019, 17:23 4
Лучший ответ Сообщение было отмечено tna111 как решение

Решение

Предлагаю формулу
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/($I$5:$I$8=$B5)/($J$5:$J$8=C$4);$K$5:$K$8);"")
1
Вложения
Тип файла: xlsx Слияни табл.xlsx (10.2 Кб, 5 просмотров)
tna111
1 / 1 / 0
Регистрация: 10.01.2017
Сообщений: 21
18.04.2019, 22:45  [ТС] 5
Всем спасибо. Подошел последний вариант.
Нашел к нему описание если кому нужно:

мы ищем значение 2, которого нет в массиве поиска, то будет найдена последняя единица и подставлено соответствующее значение из столбца таким образом, если нужно сделать несколько условий то применяется конструкция:
=ПРОСМОТР(2;1/(диапазон1=значение1)/(диапазон2=значение2)/(диапазон3=значение3);что_возвращаем).
0
18.04.2019, 22:45
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
18.04.2019, 22:45

1) Создать Базу данных (Имя , Фамилия, Отчество) 2) Создать таблицу в Базе данных (состоящия из 3 столбцов(а,б,с) и 3 строк int) 3)Создать пользовате
Задача помогите незнаю ваще как даже сделать. Заранее спасибо большое: 1) Создать Базу данных (Имя...

Создать форму, которая позволяла бы выбирать блюда не из общего списка, а из списка блюд последнего созданного дня
У меня есть общий список блюд, из которого формируется меню на день. Помогите, пожалуйста,...

Создать файл который сможет создать таблицу в базе данных
У меня есть код он создает таблицу когда я нахожусь в phpmyadmin и делаю SQL-запрос, вопрос такой-...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru