Форум программистов, компьютерный форум, киберфорум
Наши страницы
Другие языки программирования
Войти
Регистрация
Восстановить пароль
 
ВаЛерика
121 / 26 / 27
Регистрация: 17.04.2013
Сообщений: 106
1

[КуМир] Ввод и вывод массива в столбик

18.02.2015, 19:35. Просмотров 1673. Ответов 0
Метки нет (Все метки)

Добавить программу так, чтобы вводился массив слов, очищался экран и печатался введенный массив в столбик с общим концом в конце соответствующей строки;

Не могу понять фабулу задания. Помогите понять что от меня требуется.
Сначала мне показалось что должно быть что-то в виде:
ввожу:
мама мыла Петю в ванной
получаю на выходе:
мама
мыла

но реализовать не смогла.
вот есть процедуры и функции которыми нужно пользоваться при выполнении данной задачи
Pascal
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
алг lab1000
нач лит с,с1, цел к,т,л, лит таб х[1:15]
ввод с
слова(с,к,х)
вывод нс
печать(к,х)
кон
 
алг печать(арг цел к, лит таб а[1:15])
нач цел i
нц для i от 1 до к
вывод а[i], нс
кц
кон
 
алг цел количество(лит s1,s2)
нач цел k,i
|s1 в s2
k:=0
нц для i от 1 до длин(s2)-длин(s1)+1 
если s2[i:i+длин(s1)-1]=s1
то k:=k+1
все
кц
знач:=k
кон
 
алг цел позиция(лит s1,s2)
нач цел k,i
|номер первого вхождения s1 в s2
k:=0
i:=1
нц пока k=0 и i<= длин(s2)-длин(s1)+1 
если s2[i:i+длин(s1)-1]=s1
то k:=i
все
i:=i+1
кц
знач:=k
кон
 
алг лог поиск(лит s1,s2)
нач цел i, лог л
|s1 в s2
л:= нет
нц для i от 1 до длин(s2)-длин(s1)+1 
если s2[i:i+длин(s1)-1]=s1
то л:=да
все
кц
знач:=л
кон
алг обращение( арг  рез лит s)
нач цел i, лит s1
s1:= ''
нц для i от 1 до длин(s) 
s1:=s[i]+s1
кц
s:=s1
кон
алг удвоение( арг  рез лит s)
нач цел i, лит s1
s1:= ''
нц для i от 1 до длин(s) 
s1:=s1+s[i]+s[i]
кц
s:=s1
кон
алг замена(арг рез  лит s1, арг лит s2,s3)
нач цел i, лит л
|замена сочетания s2 на s3 в слове s1
нц 
если s1=s2
то s1:=''
i:=0
иначе i:=позиция(s2,s1)
если i<>0
то если i=1
то s1:=s3+s1[длин(s2)+1:длин(s1)]
иначе если i+длин(s2)-1=длин(s1)
то s1:=s1[1:i-1]+s3
иначе s1:=s1[1:i-1]+s3+s1[i+длин(s2):длин(s1)]
все
все
все
все
кц_при i=0 
 
кон
алг удаление(арг рез  лит s1, арг лит s2)
нач цел i, лит л
|удаление сочетания s2 в слове s1
замена(s1,s2,"")
кон
алг слова(арг рез лит s, рез цел n, рез лит таб a[1:15])
нач цел i,л
|разбиение предложения на слова
нц 
замена(s,"  "," ")
кц_при не поиск("  ",s)
вывод s
если s[длин(s)]=" "
то s:=s[1:длин(s)-1]
все
n:=0;
нц 
л:=позиция(" ",s)
n:=n+1
a[n]:=s[1:л-1]
s:=s[л+1:длин(s)]
кц_при не поиск(" ",s)
n:=n+1
a[n]:=s
кон
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
18.02.2015, 19:35
Ответы с готовыми решениями:

[КуМир] Возвести в квадрат все элементы массива A
Задание. Возвести в квадрат все элементы массива A. алг Возвести в квадрат (цел N, аргрез целтаб...

[КуМир] Вычислить сумму отрицательных элементов массива A
алг цел Сумма отрицательных (цел N, аргрез целтаб A) дано | Целочисленный массив A надо | Найти...

[КуМир] Составить программу нахождения суммы элементов массива
Здравствуйте! Мне нужно составить программу нахождения суммы элементов массива на языке КуМир. ...

[КуМир] Найти номера минимального и максимального элементов массива
алг Номера минимума максимума (цел N, целтаб A, рез цел nMin, nMax) дано | Целочисленный массив A...

[КуМир] Найти среди четных элементов наибольший для каждого массива и сравнить их
Даны два одномерных массива целых чисел размерностью(15) и (25) заполненных случайным образом...

0
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
18.02.2015, 19:35

[Кумир]Создайте два литерных массива «существительное», «глагол», заполнив, используя команды присваивани
Добрый день, подскажите, пожалуйста в структуре программы: Создайте два литерных массива...

[КуМир] Найти количество элементов массива, в десятичной записи которых последняя и предпоследняя цифры одинаковые
Найти количество элементов массива, в десятичной записи которых последняя и предпоследняя цифры...

Вывод строк из массива по букве в столбик
Помогите, пожалуйста, написать программу для вывода строк из массива строк по букве в столбик. То...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
1
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.