Форум программистов, компьютерный форум, киберфорум
Наши страницы
Другие языки программирования
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/6: Рейтинг темы: голосов - 6, средняя оценка - 4.67
Михаил8888
0 / 0 / 0
Регистрация: 04.05.2017
Сообщений: 44
1

[КуМир] Возвести в квадрат все элементы массива A

08.11.2017, 15:27. Просмотров 1044. Ответов 3
Метки нет (Все метки)

Задание. Возвести в квадрат все элементы массива A.

Код
алг Возвести в квадрат (цел N, аргрез целтаб A[1:N])
дано | Целочисленный массив A[1:N]
надо | Возвести все элементы массива в квадрат.
нач

кон
Помогите решить в кумире, пожалуйста!
0
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
08.11.2017, 15:27
Ответы с готовыми решениями:

[КуМир] В матрице заменить на нули все симметричные элементы
Помогите пожалуйста с задачей. В матрице.Заменить на нули все симметричные...

[КуМир]Заполните массив целыми числами, так чтобы средний элемент массива был равен X, слева от него элементы стоят по в
Заполните массив целыми числами, так чтобы средний элемент массива был равен X,...

[КуМир] Найти все простые трехзначные числа
Я новичок здесь, не нашел подходящей темы для программы KUMIR. Решил сюда...

[КуМир] Заполнить массив случайными числами и определить, есть ли в нем одинаковые соседние элементы
Заполнить массив из 10 элементов случайными числами в интервале и определить,...

[КуМир] Вычислить сумму отрицательных элементов массива A
алг цел Сумма отрицательных (цел N, аргрез целтаб A) дано | Целочисленный...

3
Михаил8888
0 / 0 / 0
Регистрация: 04.05.2017
Сообщений: 44
22.11.2017, 12:27  [ТС] 2
Задание -возвести в квадрат все элементы массива А.

Код
алг Возвести в квадрат (цел N, аргрез целтаб A[1:N])
дано | Целочисленный массив A[1:N]
надо | Возвести все элементы массива в квадрат.
нач
цел i
нц для i от 1 до N
ввод A [i] 
кц
вывод A [i]
нц для i от 1 до N 
вывод A [i]**2
вывод нс
кц
кон

Не возводит и даже не выводит массив.
0
volvo
Супер-модератор
Эксперт Pascal/DelphiАвтор FAQ
26149 / 17526 / 6950
Регистрация: 22.10.2011
Сообщений: 30,864
Записей в блоге: 6
22.11.2017, 12:54 3
Лучший ответ Сообщение было отмечено Михаил8888 как решение

Решение

Код
алг Возвести в квадрат (цел N, аргрез целтаб A[1:N])
дано | Целочисленный массив A[1:N]
надо | Возвести все элементы массива в квадрат.
нач
  цел i
  нц для i от 1 до N 
    A[i] := A[i]**2
  кц
кон
, если я правильно помню.
1
Михаил8888
0 / 0 / 0
Регистрация: 04.05.2017
Сообщений: 44
22.11.2017, 13:12  [ТС] 4
огромное спасибо!
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
22.11.2017, 13:12

[КуМир] Найти номера минимального и максимального элементов массива
алг Номера минимума максимума (цел N, целтаб A, рез цел nMin, nMax) дано |...

[КуМир] Составить программу нахождения суммы элементов массива
Здравствуйте! Мне нужно составить программу нахождения суммы элементов массива...

[КуМир] Напишите программу, которая выводит на экран в строку все двузначные положительные числа
Спасибо очень помогли. Решите пожалуйста ещё 2 задачи. 1. Напишите программу,...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru