Форум программистов, компьютерный форум, киберфорум
Наши страницы
Другие языки программирования
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.60/5: Рейтинг темы: голосов - 5, средняя оценка - 4.60
Михаил8888
0 / 0 / 0
Регистрация: 04.05.2017
Сообщений: 41
1

[КуМир] Найти номера минимального и максимального элементов массива

22.11.2017, 19:21. Просмотров 977. Ответов 1
Метки нет (Все метки)

Код
алг Номера минимума максимума (цел N, целтаб A[1:N], рез цел nMin, nMax)
дано | Целочисленный массив A[1:N]
надо | Найти номер минимального элемента массива и 
       | записать его в переменную nMin.
       | Найти максимального элемента массива и 
       | записать его в переменную nMax.
       | Переменные nMin и nMax объявлять не нужно.        
нач
цел т
нц для т от 1 до N
ввод A [т]
кц
nMax := A [1]
нц для т от 2 до N 
если A[т] > nMax то nMax := A[т]
все
кц
вывод "Номер максимального элемента: ",A[т] 
кон
Помогите разобраться, снова не выводит массив даже...
0
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
22.11.2017, 19:21
Ответы с готовыми решениями:

[КуМир] Найти количество элементов массива, в десятичной записи которых последняя и предпоследняя цифры одинаковые
Найти количество элементов массива, в десятичной записи которых последняя и...

[КуМир] Вычислить сумму отрицательных элементов массива A
алг цел Сумма отрицательных (цел N, аргрез целтаб A) дано | Целочисленный...

[КуМир] Составить программу нахождения суммы элементов массива
Здравствуйте! Мне нужно составить программу нахождения суммы элементов массива...

[КуМир] Возвести в квадрат все элементы массива A
Задание. Возвести в квадрат все элементы массива A. алг Возвести в квадрат...

[КуМир] Найти все простые трехзначные числа
Я новичок здесь, не нашел подходящей темы для программы KUMIR. Решил сюда...

1
volvo
Супер-модератор
Эксперт Pascal/DelphiАвтор FAQ
26101 / 17501 / 6943
Регистрация: 22.10.2011
Сообщений: 30,823
Записей в блоге: 6
23.11.2017, 00:25 2
Лучший ответ Сообщение было отмечено Михаил8888 как решение

Решение

Код
алг Номера минимума максимума (цел N, целтаб A[1:N], рез цел nMin, nMax)
дано | Целочисленный массив A[1:N]
надо | Найти номер минимального элемента массива и 
     | записать его в переменную nMin.
     | Найти максимального элемента массива и 
     | записать его в переменную nMax.
     | Переменные nMin и nMax объявлять не нужно.        
нач
  цел т
  nMax := 1
  nMin := 1
  нц для т от 2 до N 
    если A[т] > A[nMax] то nMax := т
    все
    если A[т] < A[nMin] то nMin := т
    все
  кц
кон
1
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
23.11.2017, 00:25

[КуМир] Найти сумму всех положительных чисел
Здравствуйте, помогите решить задачу. Последовательно вводятся N целых чисел....

[Кумир] Найти в массиве 2 максимальных элемента и их индексы
Ввести с клавиатуры массив из 5 элементов, найти в нем 2 максимальных элемента...

[КуМир] Найти в каждой столбце матрице наибольший элемент
Здравствуйте, помогите пожалуйста с этим заданием. Найти в каждой столбце...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru