Форум программистов, компьютерный форум, киберфорум
Наши страницы
Pascal (Паскаль)
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/4: Рейтинг темы: голосов - 4, средняя оценка - 5.00
mixon
0 / 0 / 0
Регистрация: 01.06.2010
Сообщений: 6
1

Вставка столбцов в матрице

02.06.2010, 08:28. Просмотров 711. Ответов 3
Метки нет (Все метки)

Дан двумерный массив. Вставить в него 2 столбца из чисел единиц:один после к1-го столбца, второй перед к1-м столбцом.Массив заполнять случайными числами.Помогите, зарываюсь...
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
02.06.2010, 08:28
Ответы с готовыми решениями:

Обмен столбцов в матрице
В матрице A поменять столбцы, содержащие соответственно максимальный и...

Перестановка столбцов в Матрице
Помогите кто сможет! Мне нужно объяснить на словах как в программе...

Перестановка столбцов в матрице.
Матрица G заполнена случайными целыми числами в диапазоне . Нужно обозначить...

Перестановка рядков и столбцов в матрице
Помогите пожалуйста решить задачку Дана квадратная матрица В. Получить новую...

Процедура сложения строк или столбцов в матрице
Пожалусто помогите с процедурой сложения строк в матрице.Пол гугла облазил...

3
Puporev
Модератор
54734 / 42134 / 29092
Регистрация: 18.05.2008
Сообщений: 99,455
02.06.2010, 09:05 2
Pascal
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
uses crt;
const nmax=20;
var a:array[1..nmax,1..nmax+2] of byte;
    n,m,i,j,k1,p:byte;
    x:integer;
begin
clrscr;
randomize;
repeat
write('Количество строк до ',nmax,' n=');
readln(n);
until n in [1..nmax];
repeat
write('Количество столбцов до ',nmax,' m=');
readln(m);
until m in [1..nmax];
writeln('Исходная матрица:');
for i:=1 to n do
 begin
   for j:=1 to m do
    begin
     a[i,j]:=random(40)+10;
     write(a[i,j]:4);
    end;
   writeln;
 end;
writeln;
repeat
write('Номер столбца для вставок от 1 до ',m,' k1=');
readln(k1);
until k1 in [1..m];
{сначала вставка после, чтобы не изменился индекс к1}
m:=m+1;
if k1=m-1 then{если это последний столбец}
for i:=1 to n do
a[i,m]:=1 {просто добавляем еще один из 1}
else {иначе}
 begin
  for i:=1 to n do{елементы всех строк}
  for j:=m downto k1+2 do {начиная от следующего за к1}
  a[i,j]:=a[i,j-1];{сдвигаем на 1 вправо}
  for i:=1 to n do
  a[i,k1+1]:=1; {на свободное место пишем 1}
 end;
{вставка перед}
m:=m+1;
for i:=1 to n do{елементы всех строк}
for j:=m downto k1+1 do{начиная от  к1}
a[i,j]:=a[i,j-1];{сдвигаем на 1 вправо}
for i:=1 to n do
a[i,k1]:=1;{на свободное место пишем 1}
writeln('Вставка столбцов:');
for i:=1 to n do
 begin
  for j:=1 to m do
  write(a[i,j]:4);
  writeln;
 end;
readln
end.
1
mixon
0 / 0 / 0
Регистрация: 01.06.2010
Сообщений: 6
02.06.2010, 11:47  [ТС] 3
есть программа на алгоритмическом языке.Она все вставляет кроме перед и после 1 и 2 столбцом.
Код
алг мас(цел n,m)
  нач цел i,j,k1, цел  таб a[1:n,1:m+2]
  нц для i от 1 до n
       нц для j от 1 до m
        a[i,j]:=rnd(5)
       вывод a[i,j]
       кц
  вывод нс
  кц
  ввод k1
  нц для j от m+1 до k1 шаг -1
       нц для i от 1 до n
       a[i,j]:=a[i,j-1]
       кц
  кц 
  нц для i от 1 до n
   a[i,k1-1]:=1 
  кц
  нц для j от m+2 до k1+1 шаг -1
       нц для i от 1 до n
       a[i,j]:=a[i,j-1]
       кц
  кц 
  нц для i от 1 до n
   a[i,k1+1]:=1 
  кц
  вывод 'получили массив', нс
  нц для i от 1 до n
      нц для j от 1 до m+2 
      вывод a[i,j]
      кц
  кц
  кон
КАК МОЖНО ПЕРЕДЕЛАТЬ, ЧТОБЫ ОНА ПОСЛЕ И ПЕРЕД ВСЕМИ СТОЛБЦАМИ ВСТАВЛЯЛА.

[
0
Puporev
Модератор
54734 / 42134 / 29092
Регистрация: 18.05.2008
Сообщений: 99,455
02.06.2010, 12:14 4
mixon, Так мой код посмотри, там все вставляет и свой псевдокод переделай.
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
02.06.2010, 12:14

Нахождение суммы минимальных элементов столбцов в матрице
Дан целочисленный квадратный массив 10 х 10. Данная программа вычисляет сумму...

Найти в матрице сумму максимальных значений эллементов ее столбцов
Вот мой листинг: Program mtr; uses crt; const max=10; var matrix:array ...

В матрице nxm упорядочить по возрастанию элементы четных столбцов
В матрице nxm упорядочить по возрастанию элементы четных столбцов.


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru