Форум программистов, компьютерный форум, киберфорум
Наши страницы
PHP для начинающих
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.60/5: Рейтинг темы: голосов - 5, средняя оценка - 4.60
ironheaddd
1 / 1 / 1
Регистрация: 18.01.2013
Сообщений: 78
1

Математические функции PHP

18.01.2013, 08:23. Просмотров 985. Ответов 2

Есть некий текстовый файл с числовыми значениями в формате хххх.уу (хххх - рубли, количество не ограничено; уу - коп.). записаны в столбик, по одной записи в строке:
150.56
32.48
89.90
и т.п.
необходимо написать РНР-скрипт, который считывает все значения и суммирует их и выводит на кнопки на страницу (описано ниже).
0
Лучшие ответы (1)
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
18.01.2013, 08:23
Ответы с готовыми решениями:

Математические операции в php
Добрый вечер, программисты. В общем, у меня задание, в котором необходимо написать математические...

Математические функции
Добрый день! Подскажите, как мне реализовать следующую задачу: 1) Создать массив с какими-то...

Использование php функции из другого файла php
Добрый день. Я только начинаю изучать PHP, поэтому буду рад любой информации. У меня есть reg.php в...

Вызов js функции в php функции что в js
В общем имеем такое извращение <script> ... document.write("<?php echo...

Математические вычисления PHP
Всем привет. Мне необходим пример самого простого скрипта с суммой, и разностью тоесть для...

2
alpex
602 / 577 / 103
Регистрация: 16.07.2012
Сообщений: 1,761
18.01.2013, 09:27 2
Лучший ответ Сообщение было отмечено ironheaddd как решение

Решение

PHP
1
2
3
4
$arr = file('file.txt', FILE_IGNORE_NEW_LINES);
$arr = array_map('floatval', $arr);
$sum = array_sum($arr);
echo $sum;
1
ironheaddd
1 / 1 / 1
Регистрация: 18.01.2013
Сообщений: 78
18.01.2013, 10:36  [ТС] 3
держи плюсик, помогло )) а по второму вопросу есть варианты реализации?
0
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
18.01.2013, 10:36

Используя логическую функцию ЕСЛИ и встроенные математические функции, построить таблицу и график значений функции на от
=ЕСЛИ((A2<0,5;SIN(A2)*COS(A2);ЕСЛИ(A2>=0,8;A2-(LN(A2+1)/2)));exp(A2^2)+ABS(TAN(A2))) Говорит что...

Математические функции
Скажите пожалуйста правильно ли я написал формулу на Си? f =...

Математические функции
надо было написать математические функции проверьте, пожалуйста: #include <stdio.h> #include...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.