Форум программистов, компьютерный форум, киберфорум
Наши страницы
PHP
Войти
Регистрация
Восстановить пароль
 
uraabk
0 / 0 / 0
Регистрация: 14.12.2015
Сообщений: 6
#1

Версия PHP и её обновление - PHP

20.06.2018, 13:29. Просмотров 157. Ответов 7
Метки нет (Все метки)

Здравствуйте.
У меня на сайте в разных местах разная версия php. В phpMyAdmin стоит версия 5.6, в cPanel установлена 7.0, woocommerce видит 7.0.

Такой вопрос, это нормально, что в phpMyAdmin версия 5.6, как её обновить и нужно ли это вообще делать?
В идеале хотелось бы перейти на 7.2, но если менять в cPanel, то сайт перестает работать...

Версия PHP и её обновление
0
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
20.06.2018, 13:29
Я подобрал для вас темы с готовыми решениями и ответами на вопрос Версия PHP и её обновление (PHP):

Версия PHP
Какая есть мажорная стабильная версия PHP

Не ставиться нужная версия php
Добрый вечер! Нужна помощь. Решил перейти на php 7.2. Все поставил , прописал...

Обновление php 5.2 до 5.3
Добрый день. Могу повторяться, за что сразу же прошу прощения. Возникла...

Обновление PHP скрипта
Существует такой код. Можно ли сделать так чтобы при подключении его в другой...

Обновление сайтов на PHP
Не знал в каком разделе это написать, поэтому пишу здесь. Занимаюсь нескольких...

Обновление версии php в denwer
Здравствуйте. Скачал с оф. сайта denwer, но там, как оказалось, стоит версия...

7
Зверушь
398 / 317 / 80
Регистрация: 01.05.2010
Сообщений: 1,578
20.06.2018, 15:16 #2
Лучший ответ Сообщение было отмечено uraabk как решение

Решение

Так phpMyAdmin то не твой, а хостера, работает в своем окружении на php 5.6.
А уже для своего хоста ты выбираешь себе версию php. Скачай phpmyAdmin, залей себе не хостинг и ты увидишь версию 7. Но зачем оно тебе надо? Это просто клиент БД, работу твоего сайта это не ускорит, он вообще с ним никак не связан Так что не парься)
1
Fart83
52 / 56 / 32
Регистрация: 04.10.2016
Сообщений: 264
20.06.2018, 18:14 #3
если сайт изначально был заточен под 7+, то все таки стоит переключиться на эту версию, так как есть изменения, которые на 5.6 не пойдут либо придется руками исправлять, что будет в определенный момент нецелесообразно.
0
uraabk
0 / 0 / 0
Регистрация: 14.12.2015
Сообщений: 6
20.06.2018, 18:30  [ТС] #4
Цитата Сообщение от Зверушь Посмотреть сообщение
Так phpMyAdmin то не твой, а хостера, работает в своем окружении на php 5.6.
А уже для своего хоста ты выбираешь себе версию php. Скачай phpmyAdmin, залей себе не хостинг и ты увидишь версию 7. Но зачем оно тебе надо? Это просто клиент БД, работу твоего сайта это не ускорит, он вообще с ним никак не связан Так что не парься
Спасибо за разъяснение. А не подскажите, почему я тогда не могу перейти на версию 7.2?
В cPanel изменил - все нормально, все работает. Но woocommerce пишет старую версию. Если меняю в файле .htaccess строчку
JSON
1
 AddType application/x-httpd-ea-php70___lsphp .php .php7 .phtml
"php70" на "php72", то сайт перестает работать полностью. (плагины все отключал, тема поддерживает версию PHP v7 or greater/MySQL v5.6)

Цитата Сообщение от Fart83 Посмотреть сообщение
если сайт изначально был заточен под 7+
А как это узнать? Сайт на WordPress, тема поддерживает "PHP v7 or greater".
0
Fart83
52 / 56 / 32
Регистрация: 04.10.2016
Сообщений: 264
20.06.2018, 18:48 #5
Цитата Сообщение от uraabk Посмотреть сообщение
А как это узнать? Сайт на WordPress, тема поддерживает "PHP v7 or greater".
WP идет от PHP 5.6 (криво косо, но ставим на WSR), хотя рекомендуется на PHP7.2. phpMyAdmin отношения к этому не имеет. woocommerce должен интегрироваться с WP От версии WP 4.4.
0
Зверушь
398 / 317 / 80
Регистрация: 01.05.2010
Сообщений: 1,578
20.06.2018, 19:09 #6
Fart83, у него сайт на 7, в cpanel же на писано. На 5,6 работает пхпмайадмин хостера, ничего никуда переключать не надо)
uraabk, почему на 7,2 не переключается - ну может в wp это где=то закешировалось, хз. В .htaccess ты этого не сделаешь.
1
uraabk
0 / 0 / 0
Регистрация: 14.12.2015
Сообщений: 6
20.06.2018, 22:29  [ТС] #7
Зверушь, то есть, если я снесу сайт и его базу данных, в cPanel выставлю php 7.2, создам свежую базу данных и новый WordPress - то все будет работать? (И потом уже установлю тему и плагины.)
А если нет или должно на чистеньком работать как часы?

Добавлено через 3 часа 9 минут
Все получилось. Всем спасибо.
0
Зверушь
398 / 317 / 80
Регистрация: 01.05.2010
Сообщений: 1,578
21.06.2018, 10:09 #8
Зачем сносить все? Все должно и так работать, ну закешировалась строчка, очистится скоро.
0
21.06.2018, 10:09
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
21.06.2018, 10:09
Привет! Вот еще темы с решениями:

Обновление PHP 5.2 до более новой версии
Доброго времени суток! На хостинг пролезла масса вирусов из=за старой версии...

версия php
есть ли разница между php5 и остальными версиями php. Бо собираюсь купить книгу...

Обновление php на Denwer (php startup unable to load dynamic library)
После замены файлов php на актуальную версию при запуске Denwera выскакивает...

Обновление программы, версия
Ребят как можно реализовать так, чтобы рядом не было файлика типа ver.txt, а...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
8
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru