Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
Другие темы раздела
1С 1С 8.3. Использование табличной части обработки в запросе http://www.cyberforum.ru/1c-custom/thread1906317.html
Дано: Обработка с табличной частью, причём последняя - реквизит формы. Табличная часть имеет следующую структуру: Адрес, ФИАС, Код. Все - текстовые поля. Количество строк от 1 до 4000... Требуется...
Посоветуйте хорошую литературу или видеоуроки именно для программирования на 1С без воды 1С
Здравствуйте, посоветуйте хорошую литературу или видеоуроки именно для программирования на 1С без воды
1С 8.3 Подбор цен из регистра сведений Цены 1С
Здравствуйте, нужна ваша помощь. Имеется регистр сведений Цены и документ Установка цен, при помощи которого делаются записи в регистр. Но в документе Оказание услуг при реализации берутся цены не те...
1С Мобильная платформа.Сборка под iOS Вот такая ошибка вылазит при сборке ipa.Пробовал скинуть проект на Мак, там всё норм собирается и загружается в телефон.Мак пингуется по сети.xCode судя по журналу находит.Сертификат указал в самом... http://www.cyberforum.ru/1c-custom/thread1905476.html
1С Вывод на печать табличной части http://www.cyberforum.ru/1c-custom/thread1905033.html
Здравствуйте! В документе Док есть табл. часть Работник, которая содержит поля Фамилия, Возраст. Есть общий макет. Как из ТЧ вывести на печать данные в макет? Возможно ли сделать так, что если...
1С Скопировать заголовок формы
Доброго времени суток. Пытаюсь скопировать заголовок формы следующим кодом РедЗагол = ЭтаФорма.Заголовок; Но он мне возвращает пустую строку. Но в заголовке написано "Заказ-наряд 3 от 18.01.2017"...
1С В контексте чего исполняются веб-сервисы?
в каком контексте выполняются веб сервисы в 1с, я имею ввиду - переменные и процедуры из каких областей видимости доступны непосредственного вызова в теле веб сервиса? если с процедурами и функциями...
1С Фомирование заблокированного файла word из 1с Добрый день! Задача следующая: необходимо из 1с формировать файл в формате word ( договор ), формирование и заполнение выполнил с помощью макетов и доп. печатных форм. Но, по требованиям файл должен... http://www.cyberforum.ru/1c-custom/thread1904006.html
1С Объект "VBScript.RegExp" http://www.cyberforum.ru/1c-custom/thread1903965.html
в каком случае не может быть создан экземпляр объекта "VBScript.RegExp"? - если данный компонент не зарегистрирован в системе? - бывают ли такие виндовс в которых он не зарегистрирован по умолчанию?
1С Веб-сервисы для передачи двоичных данных Здравствуйте, уважаемые форумчане. у меня есть две базы, и происходит обмен файлами между ними. сейчас это планируется перевести на веб сервис, как сделать так, чтобы вебсервис возвращал двоичные... http://www.cyberforum.ru/1c-custom/thread1903388.html
Godunov
3 / 3 / 6
Регистрация: 29.03.2016
Сообщений: 116
0

Сохранение файлов, после перехода 8.2 на 8.3

24.01.2017, 11:17. Просмотров 1125. Ответов 4
Метки (Все метки)

Приветствую всех, недавно у нас обновили платформу с 8.2 на 8.3, но включили поддержку совместимости с 8.2 и возник косяк с обработкой по сохранению сертификатов (картинка.jpg).

Вот код который работал в 8.2:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.ВыборКаталога);
 
    Каталог = ВосстановитьЗначение("нс_СписокСертификатов_КаталогДляСохранения");
    
    Если ЗначениеЗаполнено(Каталог) Тогда
        Диалог.Каталог = Каталог;
    Иначе
        Диалог.Каталог = "w:";
    КонецЕсли;
    
    Если Диалог.Выбрать() Тогда
        
        СохранитьЗначение("нс_СписокСертификатов_КаталогДляСохранения", Диалог.Каталог);
        
        Для каждого СтрокаТабличнойЧасти Из Сертификаты Цикл
            Если СтрокаТабличнойЧасти.Пометка Тогда
                Если СтрокаТабличнойЧасти.Сертификат <> Неопределено тогда
                    СсылкаХранилище = СтрокаТабличнойЧасти.Сертификат.Изображение.Хранилище;
                    Данные = СсылкаХранилище.Получить();
                    Диалог.ПолноеИмяФайла = СтрокаТабличнойЧасти.Сертификат;
                    Диалог.Расширение = ".jpg";
                    //Диалог.Фильтр = "(*.jpg)|*.jpg";
                    ИмяФайла = Диалог.ПолноеИмяФайла + Диалог.Расширение;
                    Попытка
                        Данные.Записать(ИмяФайла);
                    Исключение                
                ****    Сообщить(ОписаниеОшибки());               
                    КонецПопытки;
                КонецЕсли; 
            КонецЕсли;
        КонецЦикла;
 
    КонецЕсли;
Но после перехода на 8.3 получаю ошибку:
{Обработка.нс_СписокСертификатов.Форма.Форма.Форма(247)}: Ошибка при вызове метода контекста (Записать): Ошибка файловой системы: : Ошибка доступа к файлу 'Отказное Крепеж1.jpg'

P.S.: папка создана для сохранения и права даны.

Можете подсказать, что необходимо исправить?

Вернуться к обсуждению:
Сохранение файлов, после перехода 8.2 на 8.3
0
Лучшие ответы (1)
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
24.01.2017, 11:17
Готовые ответы и решения:

Сохранение значения editText после перехода обратно в Activity
Есть два активити. В первом активити есть editText поле, в котором есть значение, далее идет...

Сохранение файлов с данными после удаления
Всем привет! Я написал 2 метода в которых сохраняется и загружается текст в файл xml: ...

Теряется ссылка на объект после после перехода в другую сцену
И снова здравствуйте На сей раз проблема такова: У меня есть скрипт, позволяющий поднимать...

Русские символы стали отображаться ? после после перехода на mysqli
Русские символы стали отображаться ? после после перехода на mysqli. При создании БД была...

Сохранение различных файлов в теле програмы (в создаваемой нами) и извлечение их(файлов) на локальный диск
Кароч тута такие дела: есть куча разных файликов которые пользователь проги недолжен видеть.При...

4
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.