Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
Другие темы раздела
1С ЭтоГруппа в динамическом списке http://www.cyberforum.ru/1c-custom/thread1906704.html
создан динамический список, в нем есть поле "это группа" у него стоит пометка - использовать всегда. на моем компе проблем нет, поле доступно. запускаю на другом - при попытке обращения к этому...
1С Передать результат запроса в процедуру Всем добрый день! Такая проблемка. Хочу вытащить список клиентов и передать в процедуру для дальнейшей обработки. Но падает с ошибкой {Обработка.Занятие.Форма.Форма.Форма(26)}: Ошибка при вызове... http://www.cyberforum.ru/1c-custom/thread1906497.html
Сохранение файлов, после перехода 8.2 на 8.3 1С
Приветствую всех, недавно у нас обновили платформу с 8.2 на 8.3, но включили поддержку совместимости с 8.2 и возник косяк с обработкой по сохранению сертификатов (картинка.jpg). Вот код который...
1С 8.3. Использование табличной части обработки в запросе 1С
Дано: Обработка с табличной частью, причём последняя - реквизит формы. Табличная часть имеет следующую структуру: Адрес, ФИАС, Код. Все - текстовые поля. Количество строк от 1 до 4000... Требуется...
1С Посоветуйте хорошую литературу или видеоуроки именно для программирования на 1С без воды http://www.cyberforum.ru/1c-custom/thread1906159.html
Здравствуйте, посоветуйте хорошую литературу или видеоуроки именно для программирования на 1С без воды
1С 1С 8.3 Подбор цен из регистра сведений Цены Здравствуйте, нужна ваша помощь. Имеется регистр сведений Цены и документ Установка цен, при помощи которого делаются записи в регистр. Но в документе Оказание услуг при реализации берутся цены не те... подробнее
NeSpecz
0 / 0 / 0
Регистрация: 25.01.2017
Сообщений: 1
0

Исключить строки при печати документа 1с 8.1

25.01.2017, 09:00. Просмотров 256. Ответов 0
Метки (Все метки)

Добрый день!
Имеется справочник "АналогиНоменклатура", который содержит Эталон и Аналоги(элементы которые, аналогичны Эталону, содержатся в табличной части). Пытаюсь реализовать возможность, чтобы при выводе на печать табличнй части "ИсходныеКомплектующие" справочника "СпецификацииНоменклатуры", исключались аналоги, если они есть.
Написал часть кода, проверки только на Эталон, выдает на печать пустой документ.

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
Функция ПроверкаНаЭталон(Эталон)
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ТекущийЭлемент", ЭтотОбъект.Ссылка);
    Запрос.Текст = "ВЫБРАТЬ
                   |    АналогиНоменклатура.Эталон,
                   |    СпецификацииНоменклатурыИсходныеКомплектующие.Номенклатура
                   |ИЗ
                   |    Справочник.СпецификацииНоменклатуры.ИсходныеКомплектующие КАК СпецификацииНоменклатурыИсходныеКомплектующие,
                   |    Справочник.АналогиНоменклатура КАК АналогиНоменклатура
                   |ГДЕ
                   |    СпецификацииНоменклатурыИсходныеКомплектующие.Номенклатура = АналогиНоменклатура.Эталон
                   | ИЛИ СпецификацииНоменклатурыИсходныеКомплектующие.Номенклатура = АналогиНоменклатура.Аналоги.Аналог";
     
       Выборка = Запрос.Выполнить().Выбрать();
     Пока Выборка.Следующий() = Истина Цикл
        Эталон =  Выборка.Эталон;
        Прервать;
    КонецЦикла;
    Возврат Эталон
    
    КонецФункции
 
 
Функция ПечатьБезАналогов()
    
    ТабДокумент = Новый ТабличныйДокумент;
    ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_БезАналогов";
 
    Макет = ПолучитьМакет("БезАналогов");
    ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
    ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаб");
    ОбластьСтрокаТаблицы = Макет.ПолучитьОбласть("СтрокаТаб");
    
    ОбластьШапка.Параметры.НаименованиеСпецификации = Наименование;
    ОбластьШапка.Параметры.КодСпецификации = Код;
    ТабДокумент.Вывести(ОбластьШапка);
    
    ТабДокумент.Вывести(ОбластьШапкаТаблицы);
       
    Для Каждого СтрокаИсходныеКомпл Из ИсходныеКомплектующие Цикл
        
        Если  ПроверкаНаЭталон(СтрокаИсходныеКомпл.Номенклатура)= Истина Тогда
           
            ОбластьСтрокаТаблицы.Параметры.Номенклатура = СтрокаИсходныеКомпл.Номенклатура;
            ОбластьСтрокаТаблицы.Параметры.Код = СтрокаИсходныеКомпл.Номенклатура.Артикул;
            ОбластьСтрокаТаблицы.Параметры.Наименование = СтрокаИсходныеКомпл.Номенклатура.Наименование;
            ОбластьСтрокаТаблицы.Параметры.КолВИзд = СтрокаИсходныеКомпл.Количество;
            ОбластьСтрокаТаблицы.Параметры.ПоНорме = СтрокаИсходныеКомпл.Норма;
            ОбластьСтрокаТаблицы.Параметры.ЕдИзм = СтрокаИсходныеКомпл.ЕдиницаИзмерения.ЕдиницаПоКлассификатору.Наименование;
            ТабДокумент.Вывести(ОбластьСтрокаТаблицы);      
        Иначе           
        КонецЕсли;
    КонецЦикла;
    Возврат ТабДокумент;
КонецФункции


Вернуться к обсуждению:
Исключить строки при печати документа 1с 8.1
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
25.01.2017, 09:00
Готовые ответы и решения:

Адрес при печати документа
Здравствуйте. Имеется процедура печати в которой адрес собирается в одну строку Процедура...

Группировка в запросе при печати документа.
Приветствую профи 1С, сам новичок в 1С, хотел бы узнать, как можно получить такой результат, как...

Ошибка 0x80020005 при печати двоичного документа
Добрый день, вообщем при печати двоичного документа выскакивает такая ошибка на этой строке ...

Ошиба при печати Lotus документа: #oc:e9
В доке поле rich text из-за него проблемы. Что это вообще за ошибка?

Отсутствие пробелов при печати документа
Добрый день. Столкнулся с такой проблемой - при печати *.docx документа, в некоторых его частях,...

0
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru