Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
Показать сообщение отдельно
GreenkA
(◉‿◉)
Эксперт 1С
1965 / 1513 / 474
Регистрация: 25.06.2009
Сообщений: 5,426
20.09.2017, 14:40

Передача значение констант в строку табличной части документа

20.09.2017, 14:40. Просмотров 816. Ответов 13
Метки (Все метки)

Лучший ответ Сообщение было отмечено GreenkA как решение

Решение

Цитата Сообщение от frodoirbit Посмотреть сообщение
При выборе Грузополучателя
зачем? может все-таки ПриНачалеРедактирования() табличной части? Или тогда при изменении грузополучателя сделайте сохранение этих значений в переменные, чтобы потом их всегда и использовать:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
&НаКлиенте
Процедура ТоварПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
    Если НоваяСтрока Тогда
        Элемент.ТекущиеДанные.Грузополучатель = Объект.Грузополучатель;
        ЗначенияРесурсов = ПолучитьЗначенияРесурсовНаСервере(Объект.Дата, Объект.Грузополучатель);
        ЗаполнитьЗначенияСвойств(Элемент.ТекущиеДанные, ЗначенияРесурсов);
    КонецЕсли;
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ПолучитьЗначенияРесурсовНаСервере(ДатаОтбора, Грузополучатель)
    Возврат РегистрыСведений.БелокЖирПоМолокозаводу.ПолучитьПоследнее(ДатаОтбора, Новый Структура("Грузополучатель", Грузополучатель)); 
КонецФункции


Вернуться к обсуждению:
Передача значение констант в строку табличной части документа
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
20.09.2017, 14:40

Заполнение Табличной части документа
Здравствуйте! Заполняю табличную часть документа из справочника Номенклатура....

Запрос к табличной части документа
Здравствуйте, есть запрос: "ВЫБРАТЬ | Док.Работники.( | Работник,...

Автозаполнение табличной части документа
Есть форма, в нем есть поле со списком где можно выбрать группу, при выборе...

0
Другие темы раздела
1С Чтение Excel файла http://www.cyberforum.ru/1c-custom/thread2041691.html
Добрый день, начинаю изучать 1С , и не могу ничего найти по данной теме. Есть файл Excel , с двумя столбцами , необходимо считать его и записать все строки и столбцы в документ. Какой-то цикл ,...
1С 1C 8.3 Перенос строки из первой таблице значений в другую таблицу значений Добрый день! Нужно написать обработчик, который переносил бы строку таблицы значений в другую таблицу значений. Помогите пожалуйста! http://www.cyberforum.ru/1c-custom/thread2041625.html
1C 8.3 Удаление строк в таблице значений в которых нет значений 1С
Добрый день! Нужно написать обработчик, которые удаляет все строки в которых нет значений из таблицы значений на 1С.8,3. Помогите пожалуйста!
1С Получить иерархию табличной части справочника
Есть справочник с табличной частью ПодразделенияОрганизации. Нужной получить все записи ТЧ с подчиненными подразделениями. Если брать из справочника ПодразделенияОрганизации, то ка получить ссылку на...
1С Завязать ИмяПользователя и Справочники.Сотрудники http://www.cyberforum.ru/1c-custom/thread2041396.html
Ребят подскажите, а то весь мозг себе сломал. Требуется получить склад с которым будем работать, он является реквизитом Сотрудника. Требуется каким-то образом связать сотрудника с именем...
1С Создание справочника недвижимости Здравствуйте! Помогите с задачей, пожалуйста. Надо создать Базу Недвижимости в которое входит: 1. База Аренды. Сюда входит Аренда вторичек,новостроек, объектов, вилл и частных домов; 2. База... подробнее
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru