Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
Другие темы раздела
1С НДС за 2 квартал http://www.cyberforum.ru/1c/thread2067331.html
В комплекте регламентированной отчетности для 1С:Бухгалтерии по НДС за II квартал от 21.06.10 есть Приложения 1 и 2 к разделу 3. Данные приложения для моей организации заполнять не надо. Но при...
1С Еще раз о Точке Актуальности
Нашел в коде такую строку РассчитатьРегистрыПо(ПолучитьДокументТА()); Пришел к выводу что она не имеет смысла так как всегда будет вызывать ошибку расчета итогов посте ТА Но все же сомневаюсь...
Помогите очень нужно ТТН, путевые листы 1С
Очень нужно добавить в 1с ТТН и путевые листы. 1С 7.7.027 Конфигурация Бух.учет для Украины 7.70.277. Не принципиально важно если будет отдельная доработка. Помогите кто чем может.
1С Календарь Есть ли возможность работать с календарем, узнать, является ли данный день выходным или нет, ско-ко дней в данном месяце и тд.тп. БЕЗ КОМПОНЕНТЫ РАСЧЕТ. Может каким-нибудь образом с помощью SPL или... http://www.cyberforum.ru/1c/thread2067328.html
1С 1c: Предприятие 8.2 http://www.cyberforum.ru/1c/thread2067327.html
Здравствуйте уважаемые программисты! Очень прошу помочь! Я новичок в программировании на 1С и поэтому не могу исправить несложную ошибку. Постараюсь кратко описать суть проблемы... Есть документ...
1С Помогите с Отчетом о розничных продажах
Помогите пожалуйста советом, с восьмеркой никогда не работал и тут сунули базу восьмерки с такой траблой в Отчете о розничных продажах (Документы->Розница->Отчеты о розничных продажах) когда в...
Проблема с начислением отпуска 1С
Обновил ЗиК, теперь появились глюки с начислением отпуска. Часть документов нормально проводит, а часть отказывается проводить, мотивируя это тем, что сотрудник не работал в период времени,...
1С Запросы в 1С 8.1 Всем привет, есть небольшая проблемка с запросом, суть запроса, есть справочник контрагенты, в нём есть поле контактов, телефон и тому подобное, вообщем надо сформировать отчёт так что бы напротив... http://www.cyberforum.ru/1c/thread2067324.html
1С Автонумерация в справочнике http://www.cyberforum.ru/1c/thread2067323.html
Уважаемые, форумчане, прошу Вашего совета! Установлена на компьютере учебная версия 1С Предприятие 8.2. При добавлении Элемента в Справочник вылезает окно Элемента. В нем по умолчанию стоит код...
1С Преобразование из строки в поле агрегатного объекта Вот такой вопрос возник - можно ли из списка значений вытягивать выборочные реквизиты агрегатного объекта Например СЗ.ДобавитьЗначение(Строка(Событие)+Строка(Тема)); При выборе из списка... http://www.cyberforum.ru/1c/thread2067322.html
ytty
0 / 0 / 0
Регистрация: 09.08.2008
Сообщений: 42
0

Права доступа к документам

15.07.2010, 12:05. Просмотров 12783. Ответов 7
Метки (Все метки)

Хм, нужно такую штуку написать, типа справочника прав, где прописуеться пользователь - он же например руководитель подразделения и подчиненные к нему сотрудники, и так далее руководитель- сотрудники. Для того, чтобы при работе в 1с руководитель мог видеть только документы своих подчиненных, типа, в глобальном модуле процедурку написать, вот в чем вопрос.
Сделала так: Справочник Пользователи добавила ТЗ и соответственно кнопки добавит, изменить, справочник Сотрудники сделала подчиненным. Вот что мне не нравится и вообще неправильно!!!

Код
Процедура кнДобавить()
Перем ФормаЗаписи;
ОткрытьФормуМодально("Елемент.Сотрудники",Контекст,,,ТекущийЭлемент());
КонецПроцедуры //кнДобавить
При нажатии на кнопку открывается форма создания нового сотрудника, а мне нужно, чтобы просто можно было выбрать из существующих сотрудников в форме списка

Код
Процедура кнУдалить()
Перем Поз, Эл;
Поз=тбсотр.ТекущаяСтрока();
Если Поз = 0 Тогда
// не выбрана строка таблицы
Возврат;
КонецЕсли;
Эл=тбсотр.ПолучитьЗначение(Поз,"Значение");
Спр=СоздатьОбъект("Справочник.Сотрудники");
Спр.ИспользоватьВладельца(ТекущийЭлемент());
Если Спр.НайтиЭлемент(Эл)=1 Тогда
Спр.Удалить(0);
тбсотр.УдалитьСтроку(Поз);
тбсотр.ТекущаяСтрока(?(Поз>1,Поз-1,1));
Форма.Обновить();
КонецЕсли;
КонецПроцедуры //кнУдалить
Эта кнопка вообще не только удаляет из ТЗ сотрудника, но и удаляет в справочнике сотрудники, а мне просто нужно из ТЗ удалить.
И такой еще вопрос, обязательно справочник в таком случае подчиненным делать?

Вернуться к обсуждению:
Права доступа к документам
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
15.07.2010, 12:05
Готовые ответы и решения:

Права доступа в 1С 8.2
Подскадите, пожалуйста, как можно ограничить права доступа на справочник "Сотрудники", чтобы из...

Права доступа к 1С
Доброго вечера уважаемые форумчане. Имеем 2003 сервер терминала, юзеры подключаются по удалённому...

Права доступа в 1С УТ
Добрый день! 1С УТ 10.3, Существует ли возможность закрыть возможность редактирования каких-то...

Права доступа!
Как пользователям запретить изменять, перемещать, помечать на удаление элемент справочника...

Права доступа
Можно ли запретить пользователю изменять документы, созданные другим пользователем? и в документе...

7
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru