Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
Другие темы раздела
1С Язык запросов в 7.7 http://www.cyberforum.ru/1c/thread2067896.html
Добрый день, программисты! Столкнулся вот с какой проблемой. Есть запрос: |Период с ДатаНач" + ПериодПо + "; | |ВидМПЗ = Регистр.Партии.ВидМПЗ; |СчетУчета = Регистр.Партии.МПЗ; |МПЗ =...
Открытие нескольких экземпляров одной формы 1С
Необходимо на основании счета-заказа открыть несколько форм наряда одного типа. Возможно ли это в 7-ке?
1С Проводки документов
Добрый день! Поставили задачу но так глубоко с 1С еще незнаком. Стандартная Конфигурация Бухгалтерия 7.7 редакция 4.5 Документ "Услуги сторонних организаций" требуеться чтобы при Субконто1 =...
1С Вопрос по перечислению ЗП Добрый день! Подскажите, пожалуйста, ситуация такая^ Организация большая, часть сотрудников получают ЗП на карточки одного банка, часть - на карты другого. Как сделать, чтобы формировалось два... http://www.cyberforum.ru/1c/thread2067893.html
1С Тема ддля УИР http://www.cyberforum.ru/1c/thread2067892.html
Доброго времени суток. Хотелось бы узнать ваше мнение вот по какому вопросу: Я студент, сейчас начинается учебно-исследовательская работа, которую было решено связать с 1С. Изначально проблема...
документ в журнале проводки не отображаеться 1С
Здраствуйте! Я к вам обращаюсь за помощью! Создовая новый документ для авто сервисса "заказНарядыАкты" в конфигурации 1с 7,7 редакции 4,5(7.70.483). Я придусмотрел как я думал всё! Но послего...
1С Не обновляется элемент "Таблица Значений"
1С 8, учебная На произвольной форме справочника размещаю "Таблица Значений", в момент выполнения по нажатию кнопки добавляю в него 2 поля (колонки): ТаблицаЗначений.Колонки.Добавить("F1"); ...
1С Простой запрос с условием Подскажите как исправить этот запрос: Запрос = Новый Запрос(); Запрос.УстановитьПараметр("ШтрихКод", ШК); Запрос.Текст = " |ВЫБРАТЬ | ШтрихКоды.Ссылка |ИЗ | Справочник.ШтрихКоды КАК... http://www.cyberforum.ru/1c/thread2067889.html
1С Связывание реализации товаров и услуг с получением товаров в НТТ http://www.cyberforum.ru/1c/thread2067888.html
Здравствуйте, тут проблемка возникла. Суть вопроса вот в чем - у нас в одной базе 1с два отдела организации - один оптовый, другой розничный. С оптового отдела через документы реализации товаров и...
1С Пробдемы с автозаполнением бух справки Доброго времени суток! Ситуация такая... нужно из внешней обработки заполнить бух справку в 7-ке. Счета, количество и сумма встают нормально, а вот субконто - ни в какую не хотят :( Может кто... http://www.cyberforum.ru/1c/thread2067887.html
ytyysh747
0 / 0 / 0
Регистрация: 24.09.2009
Сообщений: 6
28.09.2009, 13:03 0

Помогите новичку!

28.09.2009, 13:03. Просмотров 12286. Ответов 4
Метки (Все метки)

Ответ

Выкладываю текст процедуры "ПриВыбореВариантаРасчетаНалогов()" из модуля формы документа, которая вызывается при раскрытии списка "Вариант расчета налогов". Идентификатор этого поля "ВариантРасчетаНалогов".

// ПриВыбореВариантаРасчетаНалогов()
//
// Вызывается из формул элементов диалога:
// Поле ввода "ВариантРасчетаНалогов".
//
// Описание:
// Пересчитывает суммы в документе при смене варианта расчета налогов.
//
Процедура ПриВыбореВариантаРасчетаНалогов()

Если ВариантРасчетаНалогов = ТекущийВариантРасчетаНалогов Тогда
Возврат
КонецЕсли;

Если КоличествоСтрок() > 0 Тогда
Ответ = Вопрос("Пересчитать суммы налогов в существующих строках
|табличной части (суммы налогов будут
|обновлены в соответствии с выбранным вариантом)?", "Да+Нет+Отмена");
Если Ответ = "Да" Тогда

ОбщееКоличество = КоличествоСтрок();
ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
РассчитатьНалоги();
Состояние("Обработано: " + Окр(НомерСтроки/ОбщееКоличество*100, 0, 1) + "%");
КонецЦикла;

ИначеЕсли Ответ = "Отмена" Тогда
ВариантРасчетаНалогов = ТекущийВариантРасчетаНалогов;
КонецЕсли;

КонецЕсли;
УчитыватьНП = глПризнакУчетаНалога(Контекст, "НП");
УчитыватьНДС = глПризнакУчетаНалога(Контекст, "НДС");
ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
НДС = ?(УчитыватьНДС = 0, 0, НДС);
НП = ?(УчитыватьНП = 0, 0, НП);
КонецЦикла;
Форма.НДС.Видимость(УчитыватьНДС);
Форма.НП.Видимость(УчитыватьНП);

КонецПроцедуры // ПриВыбореВариантаРасчетаНалогов()

Также в модуле формы есть процедура "ВариантРасчетаНалогов()", название которой совпадает с идентификатором.

Выкладываю текст этой процедуры:

// ВариантРасчетаНалогов()
//
// Вызывается из формул элементов диалога:
// Нет.
//
// Описание:
// Подбирает вариант расчета налогов.
//
Процедура ВариантРасчетаНалогов(ВРН)
Если (ВРН.СтавкаНП.Ставка = 0) и
(ВРН.СтавкаНДС.Ставка = 0) Тогда
ВариантРасчетаНалогов = ВРН;

Иначе // попробуем найти подходящий из существующих вариантов расчета налогов

СпрВариант = СоздатьОбъект("Справочник.ВариантыРасчетаНалогов");
СпрВариант.ВыбратьЭлементы();
Пока СпрВариант.ПолучитьЭлемент() = 1 Цикл

Если ((ВРН.СтавкаНДС.Ставка = 0)
и (СпрВариант.СтавкаНДС = ВРН.СтавкаНДС)
и (СпрВариант.СуммаВключаетНДС = ВРН.СуммаВключаетНДС))

или ((ВРН.СтавкаНДС.Ставка <> 0)
и (СпрВариант.СтавкаНДС.Выбран() = 0)
и (СпрВариант.СуммаВключаетНДС = ВРН.СуммаВключаетНДС)) Тогда

Если ((ВРН.СтавкаНП.Ставка = 0)
и (СпрВариант.СтавкаНП = ВРН.СтавкаНП)
и (СпрВариант.СуммаВключаетНП = ВРН.СуммаВключаетНП))

или ((ВРН.СтавкаНП.Ставка <> 0)
и (СпрВариант.СтавкаНП.Выбран() = 0)
и (СпрВариант.СуммаВключаетНП = ВРН.СуммаВключаетНП)) Тогда

ВариантРасчетаНалогов = СпрВариант.ТекущийЭлемент();
Прервать;
КонецЕсли;
КонецЕсли;

КонецЦикла;

КонецЕсли;
// Форма.НДС.Видимость(УчитыватьНДС);
// Форма.НП.Видимость(УчитыватьНП);
КонецПроцедуры // ВариантРасчетаНалогов()

Други!!!!!!!!!!!!!
ПОДСКАЖИТЕ ГДЕ КОПАТЬ!!!

Вернуться к обсуждению:
Помогите новичку!
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
28.09.2009, 13:03
Готовые ответы и решения:

Помогите новичку!
1. Где в 1с бухгалтерия выставляются ставки по налогам? 2. Что делать если в 1с бухгалтерия не...

Помогите новичку
Добрый день всем! При попытке создать новый документ или отчет, не хочет записывать конфигурацию -...

Помогите новичку
Встал вопрос об автоматизации заполнения ТТН. Так как я столкнулся с программированием 1с впервые и...

Помогите новичку
Всем привет!! я только проштудировал два самоучителя =) нехотелось бы на етом останавливаться взял...

помогите новичку
1с Производство 7.7 Надо сделать заполнение документа методом подбора, написал следующий код....

4
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru