Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
Другие темы раздела
1С 1C Предприятие: Создание в документе кнопки Подбор http://www.cyberforum.ru/1c-custom/thread2357533.html
1C Предприятие: Создание в документе кнопки Подбор для подбора товара в табличную часть документа. Очень нужно сделать но не знаю сам как сделать. На обучение времени нет. Кто может помочь? Буду...
Как включить и отключить отображение ячеек в макете печати таблицы? 1С
На форму документа поместил реквизит со значением булево. Создал макет печати документа. Но при печати несколько ячеек макета будут нужны не всегда. При отправке документа на печать надо чтобы...
Заполнение письма в цикле 1С
Здравствуйте. Есть обработка в собственной конфигурации, назначение которой получить перечень событий(Заданий) по графикам работ и отправить этот перечень ответственному сотруднику по электронной...
1С Как выполнить такой расчет? Имеется справочник ЙЙЙЙ с двумя реквизитами: - наименование; - числовое значение УУУУ. Имеется документ в котором имеется числовое значение ЦЦЦЦ вычисляемое как Значение.Итог(Сумма) в таблице... http://www.cyberforum.ru/1c-custom/thread2356920.html
1С Необходимо получить некоторые данные http://www.cyberforum.ru/1c-custom/thread2356880.html
Приветствую! Помогите пожалуйста получить следующие данные: 1. Телефон Контактного лица. Мне нужно использовать его в Реализации товаров и услуг. Какой код в модуль прописать? 2. В Заказе...
Не получается сделать продажу товара по характеристикам 1С
В регистр сведений "Остатки товаров" с помощью документа "ПриходнаяНакладная" добавляется товар с определенными свойствами (свойство и вид свойства, например: товар - Бумага. свойство - цвет. Вид...
1С Запрос суммыдт из проводок. Нужен совет
Нужно выбрать из проводки документа сумму (CуммаНУОборотДТ) для каждой номенклатуры она должна быть своя т.е. в доке допустим 4 строки и по каждой своя сумма. Запрос который ниже выдает суммарно по...
1С Создание выпадающего списка на форме обработки Здравствуйте. Есть обработка в собственной конфигурации, на форме которой необходимо сделать выпадающий список для выбора нужного значения. Добавил реквизит формы "ОтветственныеЛица" -... http://www.cyberforum.ru/1c-custom/thread2355522.html
1С Редактирование файла file.htm лежащего на диске, добавление одной строки http://www.cyberforum.ru/1c-custom/thread2354989.html
Добрый день уважаемые форумчане !!! Прошу помощи у гуру ... не нашел примера в интернете ... :cry: Допустим есть файл file.htm который лежит локально на диске на машине. Этот файл я с помощью...
1С Запись табличного документа в *.xls Добрый день. Выгружаю некую ТЗ вот так &НаСервере Процедура СохранитьТаблицуВЭксель(ИмяФайла) ТабДок = Новый ТабличныйДокумент; ТЗ = ТаблицаЗначенийОтчет.Выгрузить(); Построитель = Новый... http://www.cyberforum.ru/1c-custom/thread2354842.html
Nutur
0 / 0 / 0
Регистрация: 25.11.2018
Сообщений: 4
0

Внешняя обработка для создания документа

25.11.2018, 19:48. Просмотров 2402. Ответов 6
Метки (Все метки)

Нужно создать внешнюю обработку для созданию общего заказа поставщику из остальных заказов с выбором периода(Документ Заказ поставщику). Помоги пожалуйста, как нужно правильно создать и заполнить документ.
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
&НаКлиенте
Процедура КнопкаВыбораПериода(Команда)
    
  Диалог = Новый ДиалогРедактированияСтандартногоПериода();                                 
    Диалог.Период = Новый СтандартныйПериод(НачПериода, КонПериода);        
    ОписаниеОповещенияОЗакрытии = Новый ОписаниеОповещения("РезультатВыбораПериода",ЭтотОбъект);
    Диалог.Показать(ОписаниеОповещенияОЗакрытии);   
 
КонецПроцедуры
&НаКлиенте
Процедура РезультатВыбораПериода(Результат, ДополнительныеПараметры) Экспорт
 
         Если Результат <> Неопределено Тогда
       НачПериода = Результат.ДатаНачала;
       КонПериода = Результат.ДатаОкончания; 
         КонецЕсли;
 
     КонецПроцедуры
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
 
&НаСервере
Процедура ОбщийЗаказНаСервере()
    
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |   ЗаказПоставщикуТовары.Ссылка,
        |   ЗаказПоставщикуТовары.Номенклатура,
        |   ЗаказПоставщикуТовары.Характеристика,
        |   ЗаказПоставщикуТовары.Упаковка,
        |   ЗаказПоставщикуТовары.НоменклатураПоставщика,
        |   ЗаказПоставщикуТовары.КоличествоУпаковок,
        |   ЗаказПоставщикуТовары.Количество,
        |   ЗаказПоставщикуТовары.ВидЦеныПоставщика,
        |   ЗаказПоставщикуТовары.Цена,
        |   ЗаказПоставщикуТовары.Сумма,
        |   ЗаказПоставщикуТовары.ПроцентРучнойСкидки,
        |   ЗаказПоставщикуТовары.СуммаРучнойСкидки,
        |   ЗаказПоставщикуТовары.СтавкаНДС,
        |   ЗаказПоставщикуТовары.СуммаНДС,
        |   ЗаказПоставщикуТовары.СуммаСНДС,
        |   ЗаказПоставщикуТовары.КодСтроки,
        |   ЗаказПоставщикуТовары.Отменено,
        |   ЗаказПоставщикуТовары.СтатьяРасходов,
        |   ЗаказПоставщикуТовары.АналитикаРасходов,
        |   ЗаказПоставщикуТовары.ПричинаОтмены,
        |   ЗаказПоставщикуТовары.Склад,
        |   ЗаказПоставщикуТовары.Назначение,
        |   ЗаказПоставщикуТовары.Подразделение,
        |   ЗаказПоставщикуТовары.СписатьНаРасходы,
        |   ЗаказПоставщикуТовары.Менеджер,
        |   ЗаказПоставщикуТовары.Ссылка.Контрагент,
        |   ЗаказПоставщикуТовары.Ссылка.Соглашение,
        |   ЗаказПоставщикуТовары.Ссылка.Договор
        |ИЗ
        |   Документ.ЗаказПоставщику.Товары КАК ЗаказПоставщикуТовары
        |ГДЕ
        |   ЗаказПоставщикуТовары.Ссылка.Дата МЕЖДУ &ДатаНач И &ДатаКон
        |   И ЗаказПоставщикуТовары.Ссылка.Партнер = &Партнер
        |   И ЗаказПоставщикуТовары.Ссылка.Организация = &Организация
        |   И ЗаказПоставщикуТовары.Ссылка.ХозяйственнаяОперация = &ХозяйственнаяОперация";
    
    Запрос.УстановитьПараметр("ДатаКон", КонецДня(КонПериода));
    Запрос.УстановитьПараметр("ДатаНач", НачалоДня(НачПериода));
    Запрос.УстановитьПараметр("Организация", Организация);
    Запрос.УстановитьПараметр("Партнер", Поставщик);
    Запрос.УстановитьПараметр("ХозяйственнаяОперация", Перечисления.ХозяйственныеОперации.ЗакупкаУПоставщика);
    
    РезультатЗапроса = Запрос.Выполнить().Выгрузить();
    Для каждого рез из РезультатЗапроса Цикл
    НовыйДокумент = Документы.ЗаказПоставщику.СоздатьДокумент();
        НовыйДокумент.Дата = ТекущаяДата();
        НовыйДокумент.Партнер = Поставщик;
        НовыйДокумент.Организация = Организация;
        НовыйДокумент.Контрагент = рез.Контрагент;
        НовыйДокумент.Соглашение = рез.Соглашение;
        НовыйДокумент.Договор = рез.Договор;
        НовыйДокумент.ОбщийЗаказ = Истина;
        
        НовыйДокумент.Записать();
КонецЦикла; 
    
КонецПроцедуры
 
 
&НаКлиенте
     Процедура ОбщийЗаказ(Команда)
         ОбщийЗаказНаСервере();
     КонецПроцедуры


Вернуться к обсуждению:
Внешняя обработка для создания документа
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
25.11.2018, 19:48
Готовые ответы и решения:

Внешняя обработка. Загрузка данных для создания заказов из CSV в 1С 8.3
Здравствуйте. Я новичок в 1С. Нужно создать обработку, которая будет формировать заказы клиента из...

Внешняя обработка, создание документа Заказ Поставщику
Здравствуйте, подскажите, пожалуйста! Во внешней обработке создаю Заказ поставщику на основании...

Внешняя обработка заполнения документа "Заказ покупателя"
Всем опять здравствуйте! Я опять вернулась к этой проблеме, потому что она так и не решилась. ...

Внешняя обработка для копирования документов
Здраствуйте, создаю внешнюю обработку для копирования документов. Не могу понять как застить ее...

Внешняя обработка, не получается загрузить данные в табличную часть документа
Здравствуйте!

6
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru