Форум программистов, компьютерный форум CyberForum.ru

Рекурсивное разбиение прямоугольной области правильным n-угольником - C++

Восстановить пароль Регистрация
Другие темы раздела
C++ Залить два файла в один http://www.cyberforum.ru/cpp-beginners/thread251896.html
пока такое вот написал, не знаю как зделать так штоб елементы которые есть в первом и втором файле не записывались по два раза, тоесть если "1" есть в первом файле, то штоб с второго файла "1" еще раз не записывалось. #include <iostream> using namespace std; int main() { FILE *f1, *f2;
C++ 20 строк ввели меня в ступор Вообщем я не могу найти ошибку. #include <iostream> #include <stdio.h> using namespace std; struct test { char szTest; int year; http://www.cyberforum.ru/cpp-beginners/thread251894.html
Построить описание класса, содержащего информацию о почтовом адресе организации C++
помогите=) Построить описание класса, содержащего информацию о почтовом адресе организации. предусмотреть возможность раздельного изменения составных частей адреса, создания и уничтожения объектов этого класса. заранее спасибо=)
Дан двумерный массив размерностью Н. сформировать одномерный массив из элементов заданного массива расположенных над главной диагональю. C++
помогите решить=)Дан двумерный массив размерностью Н. сформировать одномерный массив из элементов заданного массива расположенных над главной диагональю.
C++ Дана строка содержащая текст. Найти длину самого короткого и самого длинного слова. http://www.cyberforum.ru/cpp-beginners/thread251867.html
помогите написать программу =) очень нужно=) Дана строка содержащая текст. Найти длину самого короткого и самого длинного слова.
C++ Возведение в степень. C++ можно ли написать программу для возведения в вводимую степень вводимого числа с помощью рекурсивной функции подробнее

Показать сообщение отдельно
stimsa
 Аватар для stimsa
0 / 0 / 0
Регистрация: 13.02.2010
Сообщений: 30
03.03.2011, 23:32     Рекурсивное разбиение прямоугольной области правильным n-угольником
Имеется алгоритмический язык.Помогите реализовать на паскале.
алг RectangleDraw(арг цел Current_It,int Count_It, арг вещ Radius, Xc, Yc, арг цел n)
нач
цел i;
если Current_It = Count_It то
Count1:= Count1+1;
если (Xc - Radius >= Xm и Xc + Radius <= XM и Yc - Radius >= Ym и Yc + Radius <=YM ) то
нц для i от 0 до n
Coord[i].x:=IX(Xc + Radius*cos(i*2*M_PI/n))
Coord[i].y:=IY(Yc + Radius*sin(i*2*M_PI/n))
кц
Coord[n]:=Coord[0]
Polygon(Coord,n+1)
все
иначе
нц для i от 0 до n
RectangleDraw (Current_It+1, Count_It, Radius/2., Xc+Radius/2. *cos(i*2*M_PI/n),Yc +Radius/2.*sin(i*2*M_PI/n),n)

RectangleDraw (Current_It+1,Count_It, Radius/2.,Xc, Yc, n)
кц
все
кон

алг RunProcess
нач
цел j, NumberG, IterNo, Xm, Ym, XM, YM;

вещ Radius, Xc, Yc;
Radius:= sqrt(pow(XM - Xm,2)+pow(YM - Ym,2))/2.;
Xc = Xm+(XM - Xm)/2.
Yc = Ym+(YM - Ym)/2.;

нц для j от 1 до IterNo
RectangleDraw(1,j,Radius,Xc,Yc, NumberG)
кц
кон
Iax=(double)(right - top -10)/(MaxX - MinX);
Ibx=(double)(right -5 - Iax*MaxX);
Iay=(double)(bottom - top -10)/(MinY - MaxY);
Iby=(double)(bottom -5 - Iay*MinY);


IX(double x) Iax*x+Ibx+0.5;
IY(double y) Iay*y+Iby+0.5
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
 
Текущее время: 14:59. Часовой пояс GMT +3.
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Рейтинг@Mail.ru