Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
Другие темы раздела
1С Внешняя печатная форма http://www.cyberforum.ru/1c/thread348197.html
Подскажите пожалуйста,как привязать внешнюю печатную форму к документу в 1с 8.2
1С Помогите начинающему Я программист и системный администратор. Знаю много различных программных продуктов и даже умею сам их делать, но продукцией 1С никогда не работал. Товарищ предлагает устроиться к себе на работу и... http://www.cyberforum.ru/1c/thread348071.html
1С Как сделать НаименованиеПолное = Наименование???
У меня 1С 8.2 Конфигурация УТ 11.0.4.6 Задача: надо во всех товарах справочника Номенклатура назначить Объект.НаименованиеПолное = Объект.Наименование. В ФормеЭлемента вставляю код: &НаСервере...
Полученик значений из справочника 1С
Подскажите пытаюсь разобраться с тем где, что использовать: 1С8.2 УТ В номенклатуре создали дополнительное поле с выбором Производитель: Запрос ведется в справочник производителей, в котором есть...
1С Переход на след.запись http://www.cyberforum.ru/1c/thread347808.html
Вечер добрый уважаемые! Подскажите, как мне реализовать такую тему: Мне нужно чтобы при щелчке на кнопке Следующий вопрос произошел переход на следующую запись в таблице с вопросами? версия...
1С Процедуры и функции Всем доброго времени суток! Люди выложите если не сложно ссылки у кого какие есть по описанию функциональности: процедур и функций. думаю данная инвормация где, что ставить заинтересует любого... подробнее
temi4444
0 / 0 / 0
Регистрация: 17.05.2011
Сообщений: 27
0

Ошибка при вызове метода контекста (ПолучитьОбъект)

05.09.2011, 12:53. Просмотров 9051. Ответов 6
Метки (Все метки)

Привет народ Программа ругается что:
{Форма.Форма.Форма(7)}: Ошибка при вызове метода контекста (ПолучитьОбъект)
лОбъект = ДокументПересчета.ПолучитьОбъект();

не пойму почему ошибка при вызове

вот код
XML
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
Процедура КнопкаВыполнитьНажатие(Кнопка)
    
 
    лОбъект = ДокументПересчета.ПолучитьОбъект("VM-00000002");   
    Для Каждого СтрТабл Из лОбъект.Товары Цикл
        Если СтрТабл.Количество > 0 Тогда
            СтрТабл.КоличествоФакт = СтрТабл.Количество;
            СтрТабл.Количество = 0;
        КонецЕсли;
        Если СтрТабл.Количество < 0 Тогда 
            СтрТабл.Количество = СтрТабл.Количество*(-1);
            //СтрТабл.Количество = 0;
        КонецЕсли;
    КонецЦикла;
    лОбъект.Записать(РежимЗаписиДокумента.Запись);      
КонецПроцедуры
1с запущена в режиме совместимости с 8.1

Просветите пожалуйста как победить эту ошибку

Вернуться к обсуждению:
Ошибка при вызове метода контекста (ПолучитьОбъект)
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
05.09.2011, 12:53
Готовые ответы и решения:

Ошибка при вызове метода контекста
Задача сделать автоподбор. Но вот при выполнении выдает...

Ошибка при вызове метода контекста
есть ссылка &quot;e79ba7ae-0747-11db-9244-0011955c22cb&quot;... как присвоить ее новому элементу справочника...

Ошибка при вызове метода контекста (ВыбратьИзСписка)
Люди срочно помогите что не так???? В программе не лазили возникла ошибка: При выборе...

Ошибка при чтении изменений при обмене РИБ: Ошибка при вызове метода контекста (ПрочитатьИзменения): Ошибка записи!
Доброго всем времени суток! подскажи пожалуйста как исправить ошибку: Ошибка при чтении изменений...

Ошибка при вызове метода контекста (МоментВремени): Элемент не выбран
В УТ 8.2 скопировал печатную форму &quot;Сравнительная накладная &quot; из РеализацияТоваровУслуг в Заказ...

6
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru