Форум программистов, компьютерный форум CyberForum.ru

Вывести все простые числа от 0 до 100 (цикл while) - C++

Войти
Регистрация
Восстановить пароль
Другие темы раздела
C++ Вычисление интеграла http://www.cyberforum.ru/cpp-beginners/thread55251.html
Считаю интеграл на промедутке от -1 до 3... Интеграл a*a*a*a. Точность вычисления 0.00001... Код выполняется 10-12 секунд. Это нормально или можно оптимизировать? Метод вычисления прямоугольники или трапеции ( в принципе без разницы.. И там и там где-то 10 сек. ) На других функциях ( y = sin x, y = x) менее чем за 150 миллисекунд. Что можете сказать? Приложу код на С++, но это не важно, важен...
C++ Простая задача. Пожалуйста помогите кто может, очень нужно Даны натуральное число n, действительные числа a1,...,an (1 и n это нижние индексы). Выяснить образуют ли возрастающую последовательность числа: a1,...,an, 2a1, 3a2,...,(n+1)an (опять же 1, n, 2 нижние индексы). заранее огромное спасибо. http://www.cyberforum.ru/cpp-beginners/thread55246.html
C++ Связь С++ с программой на ассемблере
Помогите пожалуйста! Не удается создать связь Borland C++ v5.02 с программой на ассемблере через стек. при удалении строк с вызовом внешней функции и компилированием всё работает. при компилировании с ключом -S вызов функции в Pfar идет near.. программа на С++ файл zad77.cpp /* Главная программа на языке Си для сопряжения с подпрограммой на Ассемблере.
C++ Метод сортировки выбором!!!
ВАРИАНТ 21 Написать программу, которая методом сортировки выбором сортирует введенный пользователем массив слов. Также найти количество операций сравнения и перестановок (присвоений) необходимых для сортировки исходного массива.
C++ Проверка символа на принадлежность к буквам русского алфавита http://www.cyberforum.ru/cpp-beginners/thread55178.html
Дан символ. Проверить: является ли данный символ гласной буквой русского алфавита(независимо от регистра). Объясните, пожалуйста, как решить задачу, еще только познаю азы программирования :)
C++ Результат запуска ракеты в зависимости от скорости Народ помогите пожалуста решить практическую работу, то я многого еще не понимаю. 1. Построить блок-схему, алгоритм и проверить правильность выполнения алгоритма: Составьте алгоритм вычисления суммы цифр введенного с клавиатуры натурального числа от 100 до 999. Например, для числа 128 сумма цифр 11, а для числа 34 сумма цифр 7. 2. Построить блок-схему, алгоритм и проверить правильность... подробнее

Показать сообщение отдельно
minitup
1 / 1 / 0
Регистрация: 27.09.2009
Сообщений: 8
08.10.2009, 22:31     Вывести все простые числа от 0 до 100 (цикл while)
Так-то наоборот вариант, сразу и оцените падение скорости грубого алгоритма при увеличении сложности.

Вот на 1С кусок с алгоритмом(не решето):

МассивПростыхЧисел = Новый Массив;
СуммаПростых = 0;
Для Счетчик = 1 По ВерхняяГраница Цикл
Простое = Истина;

Если Счетчик = 1 Тогда
Продолжить;
КонецЕсли;

МаксЦелДелитель = Цел(Pow(Счетчик, 0.5));
Если МаксЦелДелитель = 1 Тогда //числа 2 и 3
Иначе
Для СчетчикПростых = 1 По МассивПростыхЧисел.Количество() Цикл
ТекЧислоМассива = МассивПростыхЧисел.Получить(СчетчикПростых - 1);
Если ТекЧислоМассива > МаксЦелДелитель Тогда
Прервать;
КонецЕсли;

Если Счетчик/ТекЧислоМассива = Цел(Счетчик/ТекЧислоМассива) Тогда
Простое = Ложь;
Прервать;
КонецЕсли;

КонецЦикла;

КонецЕсли;

Если Простое Тогда
МассивПростыхЧисел.Добавить(Счетчик);
СуммаПростых = СуммаПростых + Счетчик;


Для Си++ тут вроде есть http://forum.codenet.ru/showthread.p...F7%E8%F1%EB%E0
 
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru