Форум программистов, компьютерный форум CyberForum.ru

числовая последовательность - C++

Восстановить пароль Регистрация
Другие темы раздела
C++ Как записать данные в файл русским языком? [VS2008] http://www.cyberforum.ru/cpp-beginners/thread773943.html
я использовал в предыдущей теме вот такие методы: SetConsoleCP(1251); SetConsoleOutputCP(1251); Я не очень правильно понял, как использовать. Но я поэкспериментировал и у меня получилось так, что вот я записываю файл, записывается русским языком а выводится в консоль в каракулями и или наоборот. Я вот лично запутался, может кто поможет как правильно использовать? Скажу так. если...
C++ Собственная реализация стека. Критика Покритикуйте пожалуйста реализацию. Самому мне не очень нравится момент с завершением работы программы в catch блоке, но не знаю как обойти возврат мусора в функции, возвращающей T&. Ведь данные могут быть и обработаны какой-нибудь другой функцией, принимающей результат работы в качестве аргумента. Но если этого нет, то, в принципе, программа остается дееспособной. Stack.h #ifndef _STACK_H_... http://www.cyberforum.ru/cpp-beginners/thread773933.html
C++ Посоветуйте компилятор для C++
Пользуюсь VS 2008 express,но с ним возникли проблемы при использовании чтении данных из файлов,может руки кривые и не знаю,как кодировку настроить правильно,если объясните,то буду благодарен,ну а так качаю eclipse,может с ним такой беды не будет,ну или посоветуйте чего ещё,у меня XP
C++ Ввод/вывод баг или нет?
#include <iostream> #include <iterator> #include <string> using namespace std; ostream_iterator<string> oo(cout); istream_iterator<string> ii(cin); int main() {
C++ Кривое считывание с файла http://www.cyberforum.ru/cpp-beginners/thread773881.html
#include <iostream> #include <fstream> #include <string> #include <locale.h> using namespace std; #include <windows.h> int main() { setlocale(LC_ALL,"Russian"); string str="Vremya-velikiy ychitel,no,yvi, ono ybivaet svoih ychenikov. Berlioz";
C++ Коменты Может кто написать коменты на каждую строку? #include <iostream> #include <vector> using namespace std; void printy (int a,int b) { for (int i=0; i<b+1; i++) { cout << a << ' '; подробнее

Показать сообщение отдельно
Oleg5
0 / 0 / 0
Регистрация: 05.10.2012
Сообщений: 16
28.01.2013, 23:16     числовая последовательность
Помогите пожалуйста хотя бы с первым заданием, потом может сам дотукаю плизззз!!!!!!
Условия задания 1:
Найти среднее арифметическое положительных элементов данной последовательности.
Условия задания 2:
В выходную последовательность записать только те числа, которые меньше суммы своих соседей (если первое число меньше второго, записываем первое число; если второе число меньше суммы первого и третьего числа, записываем второе число, если последнее меньше предпоследнего, записываем последнее число)
Условия задания 3:
Найти максимальное чётное число и его порядковый номер, при отсутствии чётных чисел сообщить об этом

Задание 1. Длина последовательности целых чисел – случайное число от 10 до 30. Последовательность генерируется случайным образом или вводится с клавиатуры по желанию пользователя. Обработать эту последовательность без использования массива в соответствии с номером варианта. При вводе или генерации последовательность записать в файл Input.txt (первая компонента файла – количество элементов последовательности, остальные компоненты представляют собой элементы последовательности).
Задание 2. Из файла Input.txt, подготовленного в процессе выполнения Задания 1, вводится последовательность целых чисел известной длины (эта длина записана на первом месте в файле). Обработать эту последовательность без использования массива в соответствии с номером варианта. В процессе обработки записать результаты в файл Output.txt (все компоненты представляют собой элементы вновь получаемой последовательности).
Задание 3. Из файла Output.txt, подготовленного в процессе выполнения Задания 2, вводится последовательность целых чисел. Обработать эту последовательность без использования массива в соответствии с номером варианта. Результаты обработки вывести на экран.

если вам поможет то я набросал как в кумире но мне надо в С++:
C++
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
использовать Файлы 
алг 
нач цел d, N, i, a, b, q, j, r, Мах, мах, f, S
если не существует файл ("Imput.txt")
то создать файл ("Imput.txt")
 
все
 
N:=int(rnd(30-10)+10)
вывод "длина последовательность", нс
вывод N
вывод "генерация  чисел- 1,ввод чисел - 2"
ввод i
если i=1
то
вывод "последовательность генерирует случайные числа", нс
вывод "Введите диапазон:", нс
вывод "a="
ввод a
вывод "b="
ввод b
если a>b
то j:=a
a:=b
b:=j
все
 
 
запись элементов (N, a, b)
иначе
вводэлементов (N)
все
вещ к;
 
к:=задание1 
вывод "среднего значение ", к, нс
S:=задание 3 ( i)
 
вывод "максимальное чётное число",S," и его порядковый номер =",i, нс
задание 2 
кон 
 
алг запись элементов (цел N, a, b)
нач цел r, i
открыть на запись ("Imput.txt", r)
нц N раз
i:= int(rnd(b-a)+a)
ф_вывод r, i, " "
кц
 
закрыть(r)
кон
 
 
алг вводэлементов ( цел N)
нач
цел r, i
открыть на запись ("Imput.txt", r)
нц N раз
вывод "введите число"
ввод i
ф_вывод r, i, " "
кц
 
закрыть(r)
кон
 
 
 
 
алг вещ задание1 
нач 
цел slag, i, d, f
вещ к=0
открыть на чтение ("Imput.txt", f)
i:=0
slag:=0
нц пока не конец файла (f)
ф_ввод f,d
если d>0
то i:= i+1
slag:= slag+d
 
все
кц
закрыть (f) 
если i>0
то 
к:= slag/i
иначе
вывод " нет положительных элементов " , нс
все
знач:=к
кон
 
алг задание 2 
нач
цел r, i, а1, а2, а3, х, ж, в,  с
если не существует файл ("Output.txt")
то создать файл("Output.txt")
все
открыть на чтение ("Imput.txt", r)
открыть на запись  ("Output.txt")
ф_ввод r, а2
ф_ввод r, а1
 
если а1<а2
то ф_вывод ж, а1, " "
все
 
нц пока не конец файла (r)
 
ф_ввод r,а3
 
 
если а2<а1+а3
то ф_вывод ж, а2, " "
все
а1:=а2
а2:=а3
кц
если а1>а2
то ф_вывод ж, а2, " " 
 
все
 
закрыть (r)
закрыть (ж)
 
кон
 
алг цел задание 3 (рез цел мах)
нач 
цел slag, i, d, S, а
вещ л=0
цел Мах
Мах:=-1
открыть на чтение ("Output.txt",S)
i:=0
нц пока не конец файла (S) и Мах=-1
ф_ввод  S, а
i:=i+1
если mod(а, 2)= 0
то 
Мах:=а
мах:=i
все
кц
нц пока не конец файла (S)
i:= i+1
ф_ввод S, а
если а>Мах и mod(а, 2)= 0
то
Мах:=а
мах:=i
 
все
кц
закрыть (S)
 
 
кон

а вот начало С++

C++
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
#include <fstream>
#include <iostream>
#include <ctime>            
using namespace std;
int main()
{    
     srand((unsigned)time(NULL));   
     ofstream strm;                             
     strm.open("c:/oonumber.txt");              
     if (strm.is_open())                        
     { 
         for(int i = 0; i < 10; i++) strm << rand()%10 << endl;
         strm.close();                      
      
      ifstream strm("c:/oonumber.txt");
      if (strm)                        
      { int number, summa = 0, count = 0;
        
        while(strm >> number)            
        { ++count;                       
          summa+=number;                 
        }
        cout << summa << "; " << count;  
        strm.close();                  
      }
    }
     system("pause");
    return 0;
}
мне надо в с++ плиззззз!!!!!
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
 
Текущее время: 01:41. Часовой пояс GMT +3.
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Рейтинг@Mail.ru