Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
Другие темы раздела
1С Ошибка: переменная не определена http://www.cyberforum.ru/1c/thread928188.html
Перечитала все советы, все перепробовала. Никакого толка. Версия 8.2. Пожалуйста :( Скрин во вложении
Доработка типового отчета Ведомость товаров на складах, УТ 10.3 1С
Здравствуйте, у меня проблема - клиент захотел доработать данный отчет. Суть такая, чтобы все оставалось как есть, но добавилась расшифровка по регистратору, но не простая, а в колонке приход. Т.е....
1С Подключение к базе
Всем привет! Долго думал как назвать тему, так и не придумал информативное название... В общем дело такое: реализую соединение с другой базой из внешней обработки, через COMОбъект, причем к...
1С УТ11 ошибка в отчете Движение товаров на складе В отчете Движение товаров на складе при выборе склада из списка складов выдается ошибка «Выбранные данные содержат элементы. Допустим только выбор групп». Ребят, кто-нибудь сталкивался с такой... http://www.cyberforum.ru/1c/thread928066.html
1С Как узнать количество номенклатуры? http://www.cyberforum.ru/1c/thread928011.html
Как в УТ 11 узнать количество номенклатуры? Где оно хранится?
1С 1с 8.2 предприятие виснет, когда добавляешь конфигурацию УПП
Ничего не понимею почему когда я добавляю конфигурацию УПП , нажимаю готово, винда виснет жутко. проверял ms server 2012 и на 7-ке тут когда нажимаешь готово, именно с этой конфигурацией идет...
Можно ли смоделировать нажатие на кнопку выбора поля ввода? 1С
Форумчане! можно ли? Задача: нажал на одну кнопку, под этой кнопкой код который Имитирует нажатие на поле ввода с типом список - в итоге открывается форма редактирования списка.
1С Глобальные переменные Доброго дня всем! Помогите плиз разобраться:-Перем глТекущийПользователь Экспорт; Мне необходимо получить ее значение в модуле объекта управляемой формы. Разъясните почему при работе в файловом... http://www.cyberforum.ru/1c/thread927622.html
1С Вызвать форму редактирования списка (8.2 не управляемые формы) http://www.cyberforum.ru/1c/thread927615.html
Доброго времени суток! Я тут думаю как реализовать: есть кнопка, по нажатию на нее открывается форма (форма в которой формируем список документов) нажимаем ок и возвращаем в программу список...
1С Подставить значение переменной Для элементов формы документа: ИмяПункта1, ИмяПункта2...ИмяПункта5, нужно поставить свойство видимость в значении ложь. Подскажите, как это сделать с помощью цикла? Следующие коды не работают, т.к.... http://www.cyberforum.ru/1c/thread927552.html
daslex
1292 / 536 / 177
Регистрация: 02.08.2011
Сообщений: 2,756
0

Ошибка разбора XML/ Ошибка при вызове метода контекста (Прочитать)

25.07.2013, 00:53. Просмотров 11035. Ответов 8
Метки (Все метки)

1C 8.2 Документооборот КОРП 1.2

Текст ошибки
{ОбщийМодуль.АвтозаполнениеШаблоновФайловКлиентСервер.Модуль(616)}: Ошибка при вызове метода контекста (Прочитать)
Пока ЧтениеXML.Прочитать() Цикл
по причине:
Ошибка разбора XML: - [2,191623]
Ошибка:
Namespace prefix r for id on headerReference is not defined
SystemId: file://E:/TMP/v8_AF95_52/word/document.xml

Код метода, вызывающий ошибку
Кликните здесь для просмотра всего текста

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
Процедура ВыполнитьЗаменуПолейИСтрокВДокументеMSOfficeOpenXML(ЧтениеXML,ЗаписьXML,МассивДанныхДляАвтоЗамен) Экспорт
    
    ФлагНайденоПоле = Ложь;
    ФлагНайденаСтрока = Ложь;   
    СтрЗамены = "";
    СтрПоиска = "";
    ТекстБылЗаписан = Ложь;         
    
        Пока ЧтениеXML.Прочитать() Цикл     
            
            
        
    ////////////////////////////////////////////////////////////////    
        Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда  //Если ТипУзла = НачалоЭлемента
            Если ЧтениеXML.Имя = "w:bookmarkStart" Тогда
                ФлагНайденоПоле = Истина; 
            КонецЕсли;
 
            Если ЧтениеXML.Имя = "w:t"  Тогда
                ФлагНайденаСтрока = Истина;
        КонецЕсли;
 
            ЗаписьXML.ЗаписатьНачалоЭлемента(ЧтениеXML.Имя);
 
            Если ЧтениеXML.КоличествоАтрибутов() > 0 Тогда
                Пока ЧтениеXML.ПрочитатьАтрибут() Цикл
                    Если ФлагНайденоПоле И ЧтениеXML.Имя = "w:name" Тогда
                        СтрПоиска = ЧтениеXML.Значение;
                    КонецЕсли;
                    ЗаписьXML.ЗаписатьАтрибут(ЧтениеXML.Имя,ЧтениеXML.Значение); 
                КонецЦикла
            КонецЕсли;
    //////////////////////////////////////////////////////////////////      
    //////////////////////////////////////////////////////////////////      
            
            
        ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда      //Если ТипУзла = Текст
            Если ФлагНайденоПоле И ФлагНайденаСтрока Тогда
                Для Каждого НастройкаЗамены Из МассивДанныхДляАвтоЗамен Цикл
                    Если НастройкаЗамены.ТермДляЗамены = СтрПоиска Тогда
                        СтрЗамены = НастройкаЗамены.ЗначениеЗамены;
                    КонецЕсли;
                КонецЦикла;
                
                Если НЕ ПустаяСтрока(СтрЗамены) Тогда
                    ЗаписьXML.ЗаписатьТекст(СтрЗамены);
                    ФлагНайденоПоле = Ложь;
                    СтрЗамены = "";
                Иначе
                    ЗаписьXML.ЗаписатьТекст(ЧтениеXML.Значение);
                    ФлагНайденоПоле = Ложь;
                КонецЕсли;
            ИначеЕсли ФлагНайденаСтрока Тогда
                СтрЗамены = ЧтениеXML.Значение;
                Для Каждого НастройкаЗамены Из МассивДанныхДляАвтоЗамен Цикл
                    СтрЗамены = СтрЗаменить(СтрЗамены, НастройкаЗамены.ЗаменяемаяСтрока, НастройкаЗамены.ЗначениеЗамены);
                КонецЦикла;
                Если Найти(СтрЗамены, Символы.ПС) Тогда
                    СтрЗамены = СтрЗаменить(СтрЗамены, Символы.ПС, "</w:t></w:r></w:p><w:p><w:r><w:t>");
                    Если СтрЗамены <> ЧтениеXML.Значение Тогда
                        ЗаписьXML.ЗаписатьБезОбработки(СтрЗамены);
                    Иначе
                        ЗаписьXML.ЗаписатьТекст(СтрЗамены);
                    КонецЕсли;
                Иначе
                    ЗаписьXML.ЗаписатьТекст(СтрЗамены);
                КонецЕсли;
                
            Иначе
                ЗаписьXML.ЗаписатьТекст(ЧтениеXML.Значение);
            КонецЕсли;  
            
            
        //////////////////////////////////////////////////////////////////  
        //////////////////////////////////////////////////////////////////              
        ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.КонецЭлемента Тогда    //Если тип узла = КонецЭлемента
            ЗаписьXML.ЗаписатьКонецЭлемента();
            Если ФлагНайденоПоле И ЧтениеXML.Имя = "w:bookmarkEnd" Тогда
                ФлагНайденоПоле = Ложь;
                СтрЗамены = "";
            КонецЕсли;
            Если ФлагНайденаСтрока Тогда
                ФлагНайденаСтрока = Ложь;
                СтрЗамены = "";
            КонецЕсли;
            
        ///////////////////////////////////////////////////////////////////
        ///////////////////////////////////////////////////////////////////
        
        КонецЕсли;                                                     //КонецЕсли ТипУзла =
    КонецЦикла;
    
КонецПроцедуры

Конкретное место, где останавливается
Пока ЧтениеXML.Прочитать() Цикл


Файл XML прикрепляю.

Прошу помощи.

Вернуться к обсуждению:
Ошибка разбора XML/ Ошибка при вызове метода контекста (Прочитать)
0
Вложения
Тип файла: rar document.rar (20.4 Кб, 26 просмотров)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
25.07.2013, 00:53
Готовые ответы и решения:

Ошибка при чтении изменений при обмене РИБ: Ошибка при вызове метода контекста (ПрочитатьИзменения): Ошибка записи!
Доброго всем времени суток! подскажи пожалуйста как исправить ошибку: Ошибка при чтении изменений...

Ошибка при вызове метода контекста
есть ссылка &quot;e79ba7ae-0747-11db-9244-0011955c22cb&quot;... как присвоить ее новому элементу справочника...

Ошибка при вызове метода контекста
Задача сделать автоподбор. Но вот при выполнении выдает...

Ошибка при вызове метода контекста (ПолучитьОбъект)
Привет народ Программа ругается что: {Форма.Форма.Форма(7)}: Ошибка при вызове метода контекста...

Ошибка при вызове метода контекста (ВыбратьИзСписка)
Люди срочно помогите что не так???? В программе не лазили возникла ошибка: При выборе...

8
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru