С Новым годом! Форум программистов, компьютерный форум, киберфорум
Наши страницы

Вычисление математической функции exp(x) - C++

Войти
Регистрация
Восстановить пароль
Другие темы раздела
C++ объявления друг в друге http://www.cyberforum.ru/cpp-beginners/thread937781.html
как это переделать чтобы работало typedef struct _Info { _proc CallBack; }*_pInfo; typedef _pInfo(*_proc)(); не строится так как с++ однопроходный
C++ error C2105: для "++" требуется левостороннее значение Как правильно записать инкремент для указателя на void? Все варианты перепробовал и ничего не помогает int arr = {1, 2, 3, 4, 5}; void *p = (int *)arr; for (int i=0; i<5; ++i) { std::cout... http://www.cyberforum.ru/cpp-beginners/thread937772.html
C++ массив, текст, русские буквы
Добрый день! Возник такой вопрос. Нужен массив с русскоязычным текстом, например: в первой ячейке будет слово "арбуз", во второй "банановый банан", и т.д. Как такое сделать? Какой...
Рекурсия, нужно объяснение работы кода C++
Объясните пожалуйста как работает здесь рекурсия: #include <iostream> void func(int num); int main(void) { func(5); return 0; } void func(int num)
C++ Ориентир в мире программирования http://www.cyberforum.ru/cpp-beginners/thread937716.html
Всем привет! Дело обстоит так: мне 17 лет, перехожу в 11 класс, хочу работать в сфере IT, а точнее программировать. После 9 класса, летом, решил поучить С++ по книге братьев Дейтел, прогнал...
C++ Задача из "ООП в C++" Р. Лафоре Глава 3. Задача 11 (стр. 141 - 4-е издание, СПб, Питер, 2012). Не слишком ли громоздкая конструкция у меня получилась для решения такой задачи? Есть ли ошибки? Как вам оформление и комментарии?... подробнее

Показать сообщение отдельно
Hugra
48 / 48 / 1
Регистрация: 18.07.2013
Сообщений: 138
Записей в блоге: 1
14.08.2013, 11:31
Цитата Сообщение от nikitosina Посмотреть сообщение
составил алгоритмы:
алг Общ (арг вещ Х, арг цел N, рез вещ S)
нач
| если N = 0
| | то S:=1
| | иначе S:=Общ(X, N-1)*X/N
| все
кон

алг Эксп (арг вещ Х, арг цел N, рез вещ F)
нач
| если N = 0
| | то F:=Общ(X, N)
| | иначе F:=Эксп(X, N-1) + Общ(X, N)
| все
кон

алг
нач
| А:=Эксп(0.5, 16)
| вывод А
кон

....
по этим алгоритмам надо код составить, но у меня в свете плохого владения C++ это не получается (точнее очень и очень тяжко получается, поэтому за помощью и обращаюсь). Задание само такое: составить алгоритм вычисления exp(x) действительного аргумента X с точностью эпсилон и использованием рекурсии. Я знаю, что должно быть три части кода: подсчет факториала, подсчет экспоненты и помимо всего сам Main. И я понимаю, что должно идти разложение через ряд Тэйлора (а точнее Маклорена, но не суть). Помогите, пожалуйста.
Что такое "рез вещ"?
0
 
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.