Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
Другие темы раздела
1С Отправка письма на запланированную дату http://www.cyberforum.ru/1c/thread937959.html
Стоит такая задача-для контроля сроков -предупреждать пользователем письмом на ящик на запланированные даты. Т.Е один раз ввел-например в обработке дату-привязав к сотруднику. и КОГДА наступит ЭТА...
Операции с массивом 1С
Добрый день всем! Есть такая ситуация: // =================================== Процедура ЧтотоТут() МассивСчет = Новый массив;
1С Подготовка к специалисту по конфигурированию БП
Подскажите, пожалуйста, вышел ли сборник задач для 3.0? И ссылочку, если можно. Заранее, спасибо!
1С Установка определенного периода даты Подскажите пожалуйста, как для реквизита справочника с типом "Дата" программно установить интервал в течении месяца. Есть реквизит "ДатаПоставки", надо, чтобы в поле выставлялась дата (дни)... http://www.cyberforum.ru/1c/thread937859.html
1С Выгрузка по рассписанию http://www.cyberforum.ru/1c/thread937840.html
Доброго времени суток. Написал батник set FileArchiv="D:\1C\Base.dt" start """" /wait C:\"Program Files"\1cv8\8.3.2.163\bin\1cv8.exe DESIGNER /Slocalhost\777 /N"Admin" /P777 Батник...
1С БП2.0 Заполнение полей ТЧ "на лету"
День добрый! есть регистр накопления "тз, ширина, длина", заполняющийся из прих.накл. хочу, чтоб при списании( др. док. ) , когда вводил бы № ТЗ - оно бы писало в полях ширина и длина значения из...
1С как заполнить "инвентаризацию" товарами с нулевыми остатками ?
конфа стандартная ТиС 7.7. нужно временно отключить в инвентаризации проверку остатков, чтобы при её автоматическом заполнении, в неё попадали все товары из справочника, а не только НЕнулевые (кроме...
1С Узнать дату отгрузки, если в субконто номенклатура и места хранения Добрый вечер. Делаю ведомость по датам и количеству отгрузки продукции, не знаю как вычислить дату отгрузки. Запрос такой:БИ = СоздатьОбъект("БухгалтерскиеИтоги");... http://www.cyberforum.ru/1c/thread937610.html
1С КЛАДР в БСП ? http://www.cyberforum.ru/1c/thread937562.html
Загрузил КЛАДР с сайта 1С в БСП Может туплю, но никак не пойму где конкретно хранятся названия улиц ? Номера домов есть в регистре сведений, но с улицами не понятно - там какие-то цифровые коды...
1С Скд двигать колонки и расшифровка Всем привет. Сделал в скд свой макет без оформления, но проблема в том что при наведении курсора на границу колонки двигать границу не получается, но без макета двигать можно. Второй вопрос. Как... http://www.cyberforum.ru/1c/thread937404.html
Roman2408
4 / 4 / 1
Регистрация: 04.04.2013
Сообщений: 117
15.08.2013, 09:13  [ТС] 0

Таблица значений

15.08.2013, 09:13. Просмотров 1235. Ответов 10
Метки (Все метки)

Ответ

ПредставлениеКорСчета - тип Строка. Туда грузится КоррСчет из запроса методом
1C
1
СтрокиДокумента.Загрузить(РезультатыТаб);
1C
1
РезультатыТаб = СверткаТаблицы(ЗапросОбороты.Выполнить().Выгрузить());
СверткаТаблицы - та функция, в которой как раз и меняется Счет с правильного на 000. Из нее вызывается функция НД_ПолучитьПредставлениеСчета, которая его и меняет
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
Функция НД_ПолучитьПредставлениеСчета(знач Счет1, знач Счет2 = Неопределено, КВД) Экспорт
    
    Если Не ЗначениеЗаполнено(Счет1) Тогда
        Возврат "";
    КонецЕсли;  
    
    Если ТипЗнч(Счет1) = Тип("Строка") Тогда
        КодСч = Сред(Счет1, 3);                      
        //Если Прав(КодСч, 3) = ".00" Тогда
        //  КодСч = Лев(КодСч, СтрДлина(КодСч)-3);
        //КонецЕсли;     
        ПервыйСчет = ПланыСчетов.ЕПСБУ.НайтиПоКоду(КодСч).Ссылка;
        Если не ЗначениеЗаполнено(ПервыйСчет) тогда
            Счет1 = ПланыСчетов.ЕПСБУ.НайтиПоКоду(Счет1).Ссылка;
        Иначе
            Счет1 = ПервыйСчет;
        КонецЕсли;  
    КонецЕсли;  
    
    Если ЗначениеЗаполнено(Счет2) Тогда
    
        Пока (Счет1 <> Счет2) Цикл
            
            Если Счет1.Уровень() < Счет2.Уровень() Тогда
                Счет2 = Счет2.Родитель;
            ИначеЕсли Счет1.Уровень() > Счет2.Уровень() Тогда
                Счет1 = Счет1.Родитель;
            Иначе                                     // на одном уровне иерархии
                Если Счет1.Уровень() <> 0 Тогда
                    Счет1 = Счет1.Родитель;
                    Счет2 = Счет2.Родитель;
                Иначе                           
                    Счет1 = "000.00";
                    Счет2 = "000.00";
                КонецЕсли;   
            КонецЕсли;
            
        КонецЦикла;
        
    КонецЕсли;  
    
    ПредставлениеКВД = ?(НЕ ЗначениеЗаполнено(КВД), "", "" + КВД + ".");
    
    Если ТипЗнч(Счет1) = Тип("Строка") Тогда
        ПредставлениеСчета = ПредставлениеКВД + Счет1;
    Иначе
        ПредставлениеСчета = ПредставлениеКВД + СокрЛП(Строка(Счет1));
    КонецЕсли;  
        
    Возврат ПредставлениеСчета;
    
КонецФункции


Вернуться к обсуждению:
Таблица значений
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
15.08.2013, 09:13
Готовые ответы и решения:

Таблица значений
Здравствуйте. Подскажите пожалуйста метод, который открывает таблицу значений после нажатия на...

Таблица Значений
У меня есть таблица значений которая выводит оценки студента в три колонки но первую строчку в...

таблица значений 7--> 8
хэлпаните. Как перенести таблицу значений (все колонки там строковые) из 7 в 8. ? Ну неполучается...

Таблица значений
Недавно начал изучать 1С, до этого учил C++ builder, если там двумерный массив так по сути...

Таблица Значений
Не могли бы вы мне помочь, мне нужно в отчете создать Таблица Значений которая будет считывать...

10
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru