Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
Другие темы раздела
1С Отправка письма на запланированную дату http://www.cyberforum.ru/1c/thread937959.html
Стоит такая задача-для контроля сроков -предупреждать пользователем письмом на ящик на запланированные даты. Т.Е один раз ввел-например в обработке дату-привязав к сотруднику. и КОГДА наступит ЭТА...
Операции с массивом 1С
Добрый день всем! Есть такая ситуация: // =================================== Процедура ЧтотоТут() МассивСчет = Новый массив;
1С Подготовка к специалисту по конфигурированию БП
Подскажите, пожалуйста, вышел ли сборник задач для 3.0? И ссылочку, если можно. Заранее, спасибо!
1С Установка определенного периода даты Подскажите пожалуйста, как для реквизита справочника с типом "Дата" программно установить интервал в течении месяца. Есть реквизит "ДатаПоставки", надо, чтобы в поле выставлялась дата (дни)... http://www.cyberforum.ru/1c/thread937859.html
1С Выгрузка по рассписанию http://www.cyberforum.ru/1c/thread937840.html
Доброго времени суток. Написал батник set FileArchiv="D:\1C\Base.dt" start """" /wait C:\"Program Files"\1cv8\8.3.2.163\bin\1cv8.exe DESIGNER /Slocalhost\777 /N"Admin" /P777 Батник...
1С БП2.0 Заполнение полей ТЧ "на лету"
День добрый! есть регистр накопления "тз, ширина, длина", заполняющийся из прих.накл. хочу, чтоб при списании( др. док. ) , когда вводил бы № ТЗ - оно бы писало в полях ширина и длина значения из...
1С как заполнить "инвентаризацию" товарами с нулевыми остатками ?
конфа стандартная ТиС 7.7. нужно временно отключить в инвентаризации проверку остатков, чтобы при её автоматическом заполнении, в неё попадали все товары из справочника, а не только НЕнулевые (кроме...
1С Узнать дату отгрузки, если в субконто номенклатура и места хранения Добрый вечер. Делаю ведомость по датам и количеству отгрузки продукции, не знаю как вычислить дату отгрузки. Запрос такой:БИ = СоздатьОбъект("БухгалтерскиеИтоги");... http://www.cyberforum.ru/1c/thread937610.html
1С КЛАДР в БСП ? http://www.cyberforum.ru/1c/thread937562.html
Загрузил КЛАДР с сайта 1С в БСП Может туплю, но никак не пойму где конкретно хранятся названия улиц ? Номера домов есть в регистре сведений, но с улицами не понятно - там какие-то цифровые коды...
1С Скд двигать колонки и расшифровка Всем привет. Сделал в скд свой макет без оформления, но проблема в том что при наведении курсора на границу колонки двигать границу не получается, но без макета двигать можно. Второй вопрос. Как... http://www.cyberforum.ru/1c/thread937404.html
Roman2408
4 / 4 / 1
Регистрация: 04.04.2013
Сообщений: 117
15.08.2013, 15:21  [ТС] 0

Таблица значений

15.08.2013, 15:21. Просмотров 1235. Ответов 10
Метки (Все метки)

Ответ

Представление состоит из КФО, затем ставится ".", затем код счета. В итоге получается такая вот петрушка: 1.000.00, холя должно быть 1.302.21
Вот сам запрос:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
ЗапросОстНач         = Новый Запрос;
    ЗапросОстНач.Текст   = 
    
    " ВЫБРАТЬ                                                             
     |      Остатки.КВД                     КАК КВД,
     |      Остатки.СуммаОстаток            КАК СальдоНач
     |ИЗ
     |      РегистрБухгалтерии.ЕПСБУ.Остатки(
     |                                       &Момент,
     |                                       Счет В (&СчетКассы),
     |                                       ,
     |                                       " + ФильтрПоОрганизациям + ")
     |                                      КАК Остатки
     |";
     
    //Санарт
    СчетаКассы=Новый СписокЗначений;
    СчетаКассы.Добавить(ПланыСчетов.ЕПСБУ.НайтиПоКоду("201.35"));
    СчетаКассы.Добавить(ПланыСчетов.ЕПСБУ.НайтиПоКоду("02.3"));
    ЗапросОстНач.УстановитьПараметр("Момент",      НачалоДня(Дата));
    //ЗапросОстНач.УстановитьПараметр("СчетКассы",   ПолучениеНСИ.ПолучитьСчетПоКоду("201.35"));
    ЗапросОстНач.УстановитьПараметр("СчетКассы",   СчетаКассы);
    ЗапросОстНач.УстановитьПараметр("Организация", Учреждение);
            
    Результат  = ЗапросОстНач.Выполнить().Выбрать();
    Пока Результат.Следующий() Цикл
         
         Если Результат.КВД            = Перечисления.КВД.Бюджет Тогда
              ПоБюджетуНачалоДня       = ПоБюджетуНачалоДня       + Результат.СальдоНач;
         Иначе   
              ПоВнебюджетуНачалоДня    = ПоВнебюджетуНачалоДня    + Результат.СальдоНач;
         КонецЕсли;  
         
    КонецЦикла;
     
     // Изменение запроса в случае детализации по записям
     Если РазвернутьАналитику Тогда
          КорСубконтоДляДетализации = "Обороты.КорСубконто2     КАК КоррСубконто,";
          Периодичность             = "Запись";
     Иначе   
          КорСубконтоДляДетализации = "";
          Периодичность             = "Регистратор"; 
     КонецЕсли;  
     //----------------------------
     
     // Заполнение строк документа
     ТаблСтрокиДок       = СтрокиДокумента.Выгрузить();
     
     ТекстЗапроса = "
     |ВЫБРАТЬ
     | ВЫБОР КОГДА СЧЕТ=&счет02 
     |тогда
     |    &Счет02
     | иначе 
     |  Обороты.КорСчет
     |Конец КАК КоррСчет " + КорСубконтоДляДетализации + ",
     |       Обороты.СуммаОборотДт          КАК ДО,
     |       Обороты.СуммаОборотКт          КАК КО,
     |       Обороты.КВД                    КАК КВД,
     |       Обороты.Регистратор            КАК ДокументКО,
     |       Обороты.Период                 КАК Период,";
 
     Если Периодичность = "Регистратор" Тогда
         ТекстЗапроса = ТекстЗапроса + "
     |      ВложенныйЗапрос.КоличествоКВД   КАК КоличествоКВД";
     Иначе
             ТекстЗапроса = ТекстЗапроса + "
     |      1                               КАК КоличествоКВД";
     КонецЕсли;
     ТекстЗапроса = ТекстЗапроса + "
     |ИЗ 
     |       РегистрБухгалтерии.ЕПСБУ.Обороты(
     |                              &НачПериода,
     |                              &КонПериода,
     |                              " + Периодичность + ",
     |                              Счет В (&СчетКассы),
     |                              ,
     |                             " + ФильтрПоОрганизациям + ",
     |                              ,         )
     |                              КАК Обороты
     |";
 
     
     Если Периодичность = "Регистратор" Тогда
         ТекстЗапроса = ТекстЗапроса + "
         |  ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
         |      КОЛИЧЕСТВО(РАЗЛИЧНЫЕ ЕПСБУОбороты.КВД) КАК КоличествоКВД,
         |      ЕПСБУОбороты.Регистратор КАК Регистратор
         |  ИЗ
         |      РегистрБухгалтерии.ЕПСБУ.Обороты(&НачПериода,
         |                                       &КонПериода, 
         |                                       Регистратор, 
         |                                       Счет В (&СчетКассы),
         |                                       , 
         |                                       " + ФильтрПоОрганизациям  + ",
         |                                       , ) КАК ЕПСБУОбороты
         |  
         |  СГРУППИРОВАТЬ ПО
         |      ЕПСБУОбороты.Регистратор) КАК ВложенныйЗапрос
         |  ПО Обороты.Регистратор = ВложенныйЗапрос.Регистратор 
         |";
     КонецЕсли; 
     ТекстЗапроса = ТекстЗапроса + "
     
     |УПОРЯДОЧИТЬ ПО
     |      Обороты.Период
     |";
     
     ЗапросОбороты       = Новый Запрос(ТекстЗапроса);
     ЗапросОбороты.УстановитьПараметр("НачПериода",  НачалоДня(Дата));
     ЗапросОбороты.УстановитьПараметр("КонПериода",  КонецДня(Дата));
     СчетаКассы=Новый СписокЗначений;
     СчетаКассы.Добавить(ПланыСчетов.ЕПСБУ.НайтиПоКоду("201.35"));
     СчетаКассы.Добавить(ПланыСчетов.ЕПСБУ.НайтиПоКоду("02.3"));
     ЗапросОбороты.УстановитьПараметр("счет02",ПланыСчетов.ЕПСБУ.НайтиПоКоду("02.3"));
     ЗапросОбороты.УстановитьПараметр("СчетКассы",   СчетаКассы);
     ЗапросОбороты.УстановитьПараметр("Организация", Учреждение);


Вернуться к обсуждению:
Таблица значений
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
15.08.2013, 15:21
Готовые ответы и решения:

Таблица значений
Здравствуйте. Подскажите пожалуйста метод, который открывает таблицу значений после нажатия на...

Таблица Значений
У меня есть таблица значений которая выводит оценки студента в три колонки но первую строчку в...

таблица значений 7--> 8
хэлпаните. Как перенести таблицу значений (все колонки там строковые) из 7 в 8. ? Ну неполучается...

Таблица значений
Недавно начал изучать 1С, до этого учил C++ builder, если там двумерный массив так по сути...

Таблица Значений
Не могли бы вы мне помочь, мне нужно в отчете создать Таблица Значений которая будет считывать...

10
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru