Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
Другие темы раздела
1С ВПФ для ПТУ http://www.cyberforum.ru/1c/thread943355.html
Здравствуйте, уважаемые форумчане. Такой вопрос - надо сделать доп форму в 11 УТ, чтобы там были и розничные цены и цены поступления, да еще и наценка... Сделал розничные цены, не знаю как вытащить...
1С Написать функцию не могу понять этот язык! Задание такое : ФАМИЛИЯ ИМЯ ОТЧЕСТВО написано в верхнем регистре. Написать функцию, которая будет приводить к виду Фамилия И. О. используя функции ПОКА, ЕСЛИ, ПодСтрока, ВНИЗ . Решить надо циклом... http://www.cyberforum.ru/1c/thread943191.html
Внешняя печатная форма на несколько страниц 1С
Здравствуйте, есть такая задача. Документ ОтпускаОрганизации, там шапка и табличная часть в которой список сотрудников. Вот для каждого сотрудника нужно вывести печатную форму, похожую на заявление....
Где искать загруженную в 1с розница (ут) ред. 1 (2) обработку? 1С
Друзья, был бы очень благодарен за помощь. Работаю с 1с, но не плавают в нем как рыба в воде. Решаю проблему с работой термопринтера mercury r58. Проблема в том, что он не печатает цифры, после...
1С Невозможно добавить реквизиты! http://www.cyberforum.ru/1c/thread942786.html
Здравствуйте! У меня появился такой глюк в 8.2 версии: Поставил 10.77. Сначала всё нормально работало. После 2 месяцев работы после инсталляции сегодня при попытке добавить новый реквизит в документ...
1С Заполнение ТЧ Документа из Реквизитов справочника нужно заполнить ТЧ документа из Реквизита справочника. &НаКлиенте Процедура КлиентПриИзменении(Элемент) Объект.Телефоны = ПолучитьТелефоны(Объект.Клиент); ЗаполнениеТабЧасти(); КонецПроцедуры... подробнее
arukus
0 / 0 / 0
Регистрация: 22.08.2013
Сообщений: 1
0

От начинающего(совсем чайника)

25.08.2013, 15:16. Просмотров 356. Ответов 1
Метки (Все метки)

Создаю внешнюю обработку. Два поля ввода. На выходе должен быть результат, записанный в три переменные. Я понимаю, что написал неграмотно. Прошу указать, как правильно и компактно?

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
&НаКлиенте
Процедура AПриИзменении(Элемент)
    а = А;
    Б = B;
    С = SQRT(а*а+б*б);
    alf = atan(а/б);
    bet = atan(б/а);
    Сообщить("С = " + С);
    Сообщить("Угол альфа = "+alf+ "|Уголь бета = " + bet);
КонецПроцедуры
 
&НаКлиенте
Процедура BПриИзменении(Элемент)
    а = Элементы.A;
    Б = Элементы.B;
    С = SQRT(POW(а,2)+POW(б,2) );
    alf = atan(а/б);
    bet = atan(б/а);
    Сообщить("С = " + С);
    Сообщить("Угол альфа = "+alf+ "|Уголь бета = " + bet);
КонецПроцедуры


Вернуться к обсуждению:
От начинающего(совсем чайника)
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
25.08.2013, 15:16
Готовые ответы и решения:

вопрос от чайника
Как выгрузить запрос в Excel? Т.е. у меня на форме DBGrid и др. соответ. компоны ADO. При...

Вопрос от чайника
Здравствуйте! Помогите пожалуйста... Добавила URL сайта в Гугл и Яндекс. Все нормально, все...

От чайника вопрос
если можно - помогите -- на картинке (это от игры) предлагаются четыре варианта IP-соединения....

От чайника до специалиста
Здравствуйте. Прошу людей, кто сертифицировался уже на данный момент или это у него в планах,...

паскаль от чайника
пожалуйста проверьте на ошибки . надо что бы программа тру или фалс . в зависимости от того...

1
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru