Форум программистов, компьютерный форум, киберфорум
Наши страницы

Сторонникам самообучения - C++

Войти
Регистрация
Восстановить пароль
Другие темы раздела
C++ Создание класса с конструкторами и деструктором http://www.cyberforum.ru/cpp-beginners/thread950967.html
Доброго времени суток, камрады! Прошу помощи в задании: Требуется создать класс студент, включающий surname, semester, 4 marks, конструкторы и деструктор. Так же функцию вывода информации по...
C++ Создайте имитацию входа в систему! Создайте имитацию входа в систему, которая будет запрашивать пароль и выводить приглашение только в случае совпадения введенного пароля с заранее определенным в программе, а в случае ошибки выводить... http://www.cyberforum.ru/cpp-beginners/thread950959.html
Эмуляция клика по окну C++
Доброго времени суток. Недавно задался вопросом написать автокликер. Добился клика в заданных координатах но вот тут и встала проблема. После нажатия на кнопку (Button1) происходит клик либо по...
Вывод результата C++
Прошу совета. Сперва думал, что где-то в коде ошибка, но потом создал элементарную программу, типа 2+3 и вывел ответ на экран. Естественно ответ должен быть 5, но вместо этого получаются числа от 2...
C++ Метод сортировки: простыми включениями http://www.cyberforum.ru/cpp-beginners/thread950935.html
Добрый день.Возникла проблема.Сделал сортировку для структуры по первому полю (там тип int ),не могу сделать для второго поля методом сортировки простыми включениями.Помогите пжл. #include...
C++ Передача по ссылке С помощью функции rand() округлить значение double и передать его по ссылке. подробнее

Показать сообщение отдельно
elivin
65 / 65 / 1
Регистрация: 04.01.2012
Сообщений: 231
Записей в блоге: 1
11.09.2013, 20:16
ValeryS, ну, извиняюсь. Я вообще изначально хотел показать только то, что в паскале, в отличие от C/C++, блок после if перед else не закрывается (точка с запятой не ставиться), но в последний момент перед отправкой вдруг вспомнил про ещё одно отличие: равенство проверяется разными операторами. Первое, что пришло в голову - сравнить с true (чтобы не ломать голову). Если интересно, можете посмотреть мои сообщения на форуме - я всегда (за исключением данного случая) использую вариант
C++
1
if (a)
Кстати, вдруг вспомнил, как спорил с преподом, который заставлял записывать эквиваленцию в excel (таблицы истинности) в виде =ЕСЛИ(A1=B1, ИСТИНА, ЛОЖЬ)
1
 
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru