Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
Другие темы раздела
1С Условие иерархии в запросе http://www.cyberforum.ru/1c/thread1011784.html
Здравствуйте. Делаю обработку, для показа списка номенклатуры по группам. Появилась проблема. задаю условие но оно не срабатывает либо срабатывает неправильно. Запрос.Текст = "ВЫБРАТЬ...
1С 1С Предприятие Доработка внешней печатной формф УТ 10.3 Доброй ночи, Форумчане! Делаю внешнюю печатную форму для УТ 10.3, которая бы выводилась из документа "РеализацияТоваровИУслуг" и отображала бы цену покупки, цену продажи, количество товара, сумму... http://www.cyberforum.ru/1c/thread1011527.html
Документы Приходная и Расходная накладная 1С
Всем доброго времени суток, очень нужна помощь, я новичок и не догоняю, ситуация такая: Есть 2 документа - приходная и расходная накладная, по 2 ресурса - наименование товара, номер ячейки....
1С Важно! Указание количества КАЖДОЙ партии в таблице значений
Всем привет! Исходя из задания мне нужно вывести список каждой партии по выбранному товару (у меня есть поле для выбора товара и кнопка что бы сформировать список) Я с помощью следующего...
1С пересечение дат http://www.cyberforum.ru/1c/thread1011008.html
требуется написать функцию которая бы проверяла пересекаются ли интервалы заданные в виде дата1-дата2 и дата3-дата4 дата1<дата2, а дата3<дата4 я написал вот так вот: функция...
1С Сообщение при вводе в поле ввода Добрый день. Появился такой вопрос, в просторах интернета чтот не нашел решения. Вообщем при вводе в поле ввода, у которого путь данных к реквезиту "Контрагент" - Справочник Контрагенты, когда... подробнее
shiro93
1 / 1 / 0
Регистрация: 09.11.2011
Сообщений: 199
0

Программное создание документа в цикле по строкам ТЗ

19.11.2013, 11:32. Просмотров 2669. Ответов 22
Метки (Все метки)

Помогите пожалуйста...делаю создание документов таким образом:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
Процедура ОткрытьЗадание()
    Воп = Вопрос("Вы точно хотите создать задание?", "Да+Нет");
    Если Воп = "Да" Тогда
 ТЗРешили.ВыбратьСтроки();
        Пока ТЗРешили.ПолучитьСтроку() = 1 Цикл
           Задан = СоздатьОбъект("Документ.Задание");
           Задан.Новый();
           Задан.Номер = "Пл-"+СокрЛП(НомерДок);
           Задан.Подразделение = СокрЛП(Подразделение);
           Задан.Записать();
        КонецЦикла;
    Иначе
        Возврат;
    КонецЕсли;
КонецПроцедуры // ОткрытьЗадание
подскажите как сделать так чтобы если в ТЗРЕШИЛИ есть одинаковые Значения по определенной колонке, то не создавалось новый документ, а до записывалась в один из них...т.е. есть колонка ТекстРаздела иИсполнитель, нужно чтобы если встречаются строки с одним Исполнителем, то это все в одном документе, а так все разные документы!

Вернуться к обсуждению:
Программное создание документа в цикле по строкам ТЗ
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
19.11.2013, 11:32
Готовые ответы и решения:

Программное создание документа
Доброго времени суток! Господа, подскажите, как при программном создании...

Программное создание и проведение документа "ПоступлениеТоваров&q
Требуется программно создать и проводить документ &quot;ПоступлениеТоваров&quot;, Бух...

Программное создание номенклатуры
доброго времени суток. нужно программно создать Элемент...

Программное создание диаграмм в 8.0
Расскажите (или дайте ссылку) как построить график в 1С 8.0 программно! ;)

Программное создание и удаление ревизита формы в 1с 8.3 УФ
Всем добрый день. Никак не могу понять как удалить ранее программно...

22
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru