Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
Другие темы раздела
1С Вывод отчета на скд http://www.cyberforum.ru/1c-custom/thread1153606.html
Здравствуйте. Пока сделала следующий запрос (может имеет смысл разбить на 2, не знаю, как правильно): ВЫБРАТЬ РАЗРЕШЕННЫЕ МАКСИМУМ(ПрогнозПерсоналаСрезПоследних.Период) КАК Период, ...
Работа с Структурой 1С
Подскажите пожалуйста почему выдает ошибку {Обработка.ЗаявкиНаПоставкуГазовыхБаллонов.Форма.ФормаВводаЗаявки.Форма(179)}: Значение не является значением объектного типа (Свойство)...
Получение информации из подчинённого справочника 7.7 1С
Добрый форумчанам день или какое там у вас время суток. Раньше не приходилось сталкиваться с этой платформой и программировал только на PHP/MySQL/JavaScript. Понадобилось получать на сайт...
1С Кладр для своей конфигурации Здарвствуйте. я с 1с знакома недавно, поэтому не судите строго. возникла необходимость внедрить кладр в свою конфигурацию. я взяла за основу бп 2.0. вытянула оттуда необходимые объекты конфигурации и... http://www.cyberforum.ru/1c-custom/thread1152834.html
1С Ввести число в строке табличного поля http://www.cyberforum.ru/1c-custom/thread1150742.html
Ввести число в строке табличного поля, ввожу и ничего не изменяется...((( ТзНакл = Новый ТаблицаЗначений; Н = 1; Если ПроставитьРазвоз Тогда Если ВвестиЧисло(Н,"Введите порядковый номер...
1С Переделка внешнего обработчика для УПП 1с 8.2
Приветствую имеется внешняя обработка для УНФ позволяющая создать несколько заказов на производство на основании заказов от покупателя. Писалась и тестировалась для релиза 1.3.2.5 как ее переделать...
1С Заполнить таблицу значений
Как заполнить таблицу значений, полученную из старой ТЗ и очищенную с сохранением структуры колонок, в которой путем НайтиСтроки отобрали массив строк - этим же массивом
1С Нужен совет по конфигурации (Документы) Посоветуйте как лучше сделать. Есть два документа, скажем заявка и документ2, в котором проводится ее исполнение. В документе2 может включаться несколько заявок. Включенные в документ2 заявки... http://www.cyberforum.ru/1c-custom/thread1149551.html
1С Подписки на события, интерактивная настройка http://www.cyberforum.ru/1c-custom/thread1149229.html
Есть видео https://www.youtube.com/watch?v=MTxrZAuBBio Хотелось бы узнать, как такое можно реализовать. Есть ли что-то подобное в свободном доступе?
1С Вставить пустой номер в табличное поле Подскажите, как вставить пустой номер в табличного поля... http://www.cyberforum.ru/1c-custom/thread1148077.html
AnStr
0 / 0 / 0
Регистрация: 19.08.2013
Сообщений: 19
22.04.2014, 17:11  [ТС] 0

Расшифровка в отчете на скд

22.04.2014, 17:11. Просмотров 6489. Ответов 6
Метки (Все метки)

Ответ

У меня в модуле объекта отчета следующие процедуры:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
Процедура ПараметрыИсполненияОтчета() Экспорт 
    
    СтруктураНастроек = Новый Структура;
    СтруктураНастроек.Вставить("ДоработатьКомпоновщикПередВыводом", Истина);
        
    СтруктураНастроек.Вставить("ПроизвольнаяОбработкаРасшифоровки", Истина);
 
    УниверсальныйОтчет.УстановитьПараметрыИсполненияОтчета(СтруктураНастроек);
    
КонецПроцедуры
 
функция ОбработатьРасшифровку(Расшифровка, СтандартнаяОбработка, ОтчетОбъект, ФормаОтчета) Экспорт
    СтандартнаяОбработка = Ложь;
    МассивПолейРасшифровкиСРесурсами = ТиповыеОтчеты.ПолучитьМассивПолейРасшифровки(Расшифровка, ФормаОтчета.ДанныеРасшифровки, , Истина);
    
     ДотупноеПоле = Неопределено;
     Если МассивПолейРасшифровкиСРесурсами.Количество() > 0 тогда
         ДотупноеПоле = ТиповыеОтчеты.ПолучитьДоступноеПоле(Новый ПолеКомпоновкиДанных(МассивПолейРасшифровкиСРесурсами[0].Поле), ОтчетОбъект.КомпоновщикНастроек.Настройки.ДоступныеПоляВыбора);
     Иначе
         Возврат Неопределено;
     КонецЕсли;
     
     ДПоле = Строка(ДотупноеПоле.Поле);
 
     Если  ДПоле = "Прогноз" Тогда 
    ОткрытьФорму("ВнешнийОтчет.ПрогнозПерсоналаTotal.Форма.ФормаРасшифровкиПрогноза"); // не работает
     КонецЕсли; 
 КонецФункции


Вернуться к обсуждению:
Расшифровка в отчете на скд
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
22.04.2014, 17:11

Группировка полей в отчете СКД
Здравствуйте. Делаю отчеты в СКД в собственной конфигурации. Столбцы в отчете: Объект, Договор,...

Вывод квартала в отчете СКД
Здравствуйте. Делаю простой отчет на СКД в собственной конфигурации. Суть отчета - из регистра...

Использование расшифровки в отчете СКД
Есть отчет на СКД, хочу для полей данных открывать соответствующие формы объектов. В книге...

0
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru