Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
Другие темы раздела
1С Почтовый клиент в 1с http://www.cyberforum.ru/1c-custom/thread1169911.html
Здравствуйте. Подскажите как сделать почтовый клиент в своей конфе в управляемых формах, чтобы можно было читать, отправлять, удалять, письма . Заранее спасибо.
ЦРМ. Возможно ли каким-нибудь образом организовать хранение вложенных файлов 1С
Всем привет! Возник такой вопрос-в конфигурации есть регистр сведений "работа с клиентами" (CRM) Возможно ли каким-нибудь образом организовать хранение вложенных файлов(архивы,xls,pdf)?
Как сделать ввод на основании через форму (при нажатии галочки одобрено)? 1С
как сделать ввод на основании через форму? т.е. при нажатии галочки одобрено?
1С Нахождение максимума Уважаемые программисты!Можно ли найти программно максимум в колонке табличногоПоля и вывести его в реквизит документа? http://www.cyberforum.ru/1c-custom/thread1168932.html
1С Запрос (нужно данные привести к строке) http://www.cyberforum.ru/1c-custom/thread1168259.html
Есть запрос к справочнику: Запрос.Текст = " |ВЫБРАТЬ | ФИО.РегФИО КАК Наименование, | бла бла бла"; есть запрос к Регистру сведений Запрос.Текст = "ВЫБРАТЬ...
Вывести календарь на рабочий стол 1С
Подскажите пожалуйста нельзя ли в интерфейсе на вкладку рабочий стол как нибудь вывести календарь, и если можно то как? Заранее спасибо
На форму списка товаров добавить "ТабличноеПоле" с типом значений "ДеревоЗначений" 1С
1С.8.0 На форму списка товаров добавить "ТабличноеПоле" с типом значений "ДеревоЗначений". При открытии формы в табличном поле должны отображаться товары с указанием средних значений количества, в...
1С Неправильное суммирование итогов в СКД Здравствуйте! Сделал отчет с помощью СКД. Сначала один набор данных срабатывает, потом передает параметры второму набору данных: Запрос1: ВЫБРАТЬ ОтчетОРозничныхПродажахТовары.Количество,... http://www.cyberforum.ru/1c-custom/thread1168096.html
1С СНД в валюте http://www.cyberforum.ru/1c-custom/thread1167816.html
Не считает сальдо дебетовое на начало периода в валюте. в чем причина может быть? таким образом реализовал БИ = СоздатьОбъект("БухгалтерскиеИтоги"); БИ.ИспользоватьРазделительУчета(Фирма);...
1С Присоединение 2 строк к 1 ячейке в макете Хочу к 1 ячейке которая занимает 3 строки справа добавить 3 строки, 1 получилось вывести как на рисунке. а вот еще 2 строки добавить не выходит, подскажите как это решить. http://www.cyberforum.ru/1c-custom/thread1167813.html
yuliya1992
0 / 0 / 0
Регистрация: 19.03.2014
Сообщений: 8
08.05.2014, 13:54  [ТС] 0

Процедура на событие отчистки, т.е. вернуть отбор

08.05.2014, 13:54. Просмотров 877. Ответов 12
Метки (Все метки)

Ответ

вот код списка полностью:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
&НаКлиенте
Процедура ТекущийВрачПриИзменении(Элемент)
    ЭлементОтбора=Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ЭлементОтбора.ЛевоеЗначение=Новый ПолеКомпоновкиДанных("Врач");
    ЭлементОтбора.Использование=Истина;
    ЭлементОтбора.ВидСравнения=ВидСравненияКомпоновкиДанных.Равно;
    ЭлементОтбора.ПравоеЗначение=ТекущийВрач; 
    ЭлементОтбора.РежимОтображения=РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Обычный;
    Элементы.Список.Обновить();
 
КонецПроцедуры
 
 
&НаКлиенте
Процедура ТекущийПациентПриИзменении(Элемент)
    
    ЭлементОтбора=Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ЭлементОтбора.ЛевоеЗначение=Новый ПолеКомпоновкиДанных("Пациент");
    ЭлементОтбора.Использование=Истина;
    ЭлементОтбора.ВидСравнения=ВидСравненияКомпоновкиДанных.Равно;
    ЭлементОтбора.ПравоеЗначение=ТекущийПациент;
    ЭлементОтбора.РежимОтображения=РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Обычный;
    Элементы.Список.Обновить();
    
 
КонецПроцедуры
 
 
&НаКлиенте
Процедура ТекущаяДатаПриИзменении(Элемент)
    ЭлементОтбора=Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ЭлементОтбора.ЛевоеЗначение=Новый ПолеКомпоновкиДанных("Дата");
    ЭлементОтбора.Использование=Истина;
    ЭлементОтбора.ВидСравнения=ВидСравненияКомпоновкиДанных.Больше;
    ЭлементОтбора.ПравоеЗначение=НачалоДня(ТекущаяДата);
    ЭлементОтбора.РежимОтображения=РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Обычный;
    Элементы.Список.Обновить();
 
    ЭлементОтбора=Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ЭлементОтбора.ЛевоеЗначение=Новый ПолеКомпоновкиДанных("Дата");
    ЭлементОтбора.Использование=Истина;
    ЭлементОтбора.ВидСравнения=ВидСравненияКомпоновкиДанных.Меньше;
    ЭлементОтбора.ПравоеЗначение=НачалоДня(ТекущаяДата)+86400;
    ЭлементОтбора.РежимОтображения=РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Обычный;
    Элементы.Список.Обновить();
 
КонецПроцедуры
 
 
&НаКлиенте
Процедура ТекущийВрачОчистка(Элемент, СтандартнаяОбработка)
    
Список.Отбор.Элементы.Очистить();
 
    КонецПроцедуры
 
 
&НаКлиенте
Процедура ПриОткрытии(Отказ)
ЭлементОформления=Список.УсловноеОформление.Элементы.Добавить();
    ЭлементОтбора=ЭлементОформления.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    
    ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Остаток");
    ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.НеРавно;
    ЭлементОтбора.Использование=Истина;
    ЭлементОтбора.ПравоеЗначение=0;
    Элемент=ЭлементОформления.Оформление.Элементы[1];
    Элемент.Использование=Истина;
    Элемент.Значение=Новый Цвет (255,0,0);
    
    ЭлементОформления=Список.УсловноеОформление.Элементы.Добавить();
    ЭлементОтбора=ЭлементОформления.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Итого");
    ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
    ЭлементОтбора.Использование=Истина;
    ЭлементОтбора.ПравоеЗначение=0;
    Элемент=ЭлементОформления.Оформление.Элементы[1];
    Элемент.Использование=Истина;
    Элемент.Значение=Новый Цвет (0,0,255);
 
    КонецПроцедуры
 
 
&НаКлиенте
    Процедура ТекущийПациентОчистка(Элемент, СтандартнаяОбработка)
        Список.Отбор.Элементы.Очистить();
    КонецПроцедуры


Вернуться к обсуждению:
Процедура на событие отчистки, т.е. вернуть отбор
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
08.05.2014, 13:54
Готовые ответы и решения:

Как правильно настроить фильтр Фомы (Событие.Загрузка) + отбор по дате и статусу
Здравствуйте, подскажите пожалуйста Как правильно прописать настройки в VB(или Макросами) при...

Процедура: вернуть сумму и среднее арифметическое элементов массива
Cоздать процедуру, которая для заданного одномерного массива размерностью n элемнтов , возвратит...

цикл отчистки
всем привет, возник вопрос как сделать цикл удаления, а точнее отчистки определённой ячейки во...

Процедура на событие OnClick
Привет! ребята помогите разобраться плз... пишу свой класс, в конструкторе создаю контекстное меню...

Ждать событие и только тогда вернуть значение из функции
public override int Execute() { mouseHook.Start(); return 1; }...

12
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru