Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
Другие темы раздела
1С Передача параметров во вложенную схему СКД http://www.cyberforum.ru/1c-custom/thread1292947.html
СКД неправильно передает параметры в свою вложенную схему. Есть запрос, на основе которой ВложеннаяСхема1 работает. Запрос представляет собой срез последних из регистра цены, потом это все в ВТ ,...
1С 8.3.5 Преобразование значения к типу Число не может быть выполнено
При создании документа возникает следующая ошибка: {ОбщийМодуль.РасчетОсаго.Модуль(41)}: Преобразование значения к типу Число не может быть выполнено Рез = КТБ * ККТ * ККБМ.Коэффициент * ККВС * ККМ...
Подстановка фиксированных значений 1С
Помогите пожалуйста начинающему...У меня такая задача.Есть документ,в нем табличная часть и в ней три поля.Номенклатура,количество,цена.При выборе номенклатуры "Big" нужно чтоб в количество и цену...
1С 8.3.5 Отчет Здравствуйте! Помогите пожалуйста с отчетом. Он выводит всегда одного страхового агента в отчет (их 2). Какое свойство за это отвечает? Вот запрос в макете: ВЫБРАТЬ... http://www.cyberforum.ru/1c-custom/thread1290190.html
1С Маска http://www.cyberforum.ru/1c-custom/thread1289019.html
Здравствуйте, помогите с маской, данная маска работает, но требует быстрого ввода или использовать стрелку вправо. Как сделать нормальный, умеренный ввод и добавить обязательность ввода 17...
1С Итог Суммы в отчете
Здравствуйте. Подскажите, как рассчитать итог суммы в отчете с применением макета? Кусочек кода,в качестве примера. Как можно вычислить сумму цены, средней цены и наценки. &НаСервереБезКонтекста...
1С Записать значение в справочник
Добрый вечер! Пытаюсь записать значение Участок в справочник, тип одинаковый, выдает ошибку {Форма.Форма.Форма(98)}: Поле объекта недоступно для записи (Участок) Результат.Участок =...
1С Расположение ресурсов в отчете СКД Всем привет! Есть самописный отчет на СКД вида: | порода, м3 | контрагент | дата работы | пункт работы | сорт, м3 | итого | Ничего... http://www.cyberforum.ru/1c-custom/thread1288198.html
1С Как исправить ошибку? http://www.cyberforum.ru/1c-custom/thread1287778.html
Здравствуйте, при проведении документов, выдается сообщения: Здравствуй, Дорогой пользователь! Поступление товаров К1 от 28.03.2014 15:30:07. Ошибка при выполнении обработчика -...
1С Свойства КомОбъекта() Доброго времени суток, форумчане! Написал такой код: ДобавитьЗаписьВИсторию(" ЗП за год (Начало) "); Спр77 = База77.CreateObject("ЖурналРасчетов.Зарплата"); ... http://www.cyberforum.ru/1c-custom/thread1287474.html
Dethmontt
Модератор
Эксперт 1С
2672 / 2455 / 425
Регистрация: 10.03.2011
Сообщений: 8,801
Записей в блоге: 1
Завершенные тесты: 1
10.11.2014, 16:19 0

Внешняя обработка печати

10.11.2014, 16:19. Просмотров 1958. Ответов 28
Метки (Все метки)

Ответ

Чо не так то? Все есть в обработке!!!

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
//Функция запуска
Функция Печать() Экспорт
    ТипЗаявления = Неопределено;
    ПечатнаяФорма = Неопределено;
    
    Если ТипЗнч(ДополнительныеПараметры) = Тип("Структура") Тогда
        Если ДополнительныеПараметры.Свойство("ПечатнаяФорма") Тогда
            ПечатнаяФорма = ДополнительныеПараметры.ПечатнаяФорма;
        КонецЕсли;
        
        Если ПечатнаяФорма = "ПечатьСчета" Тогда
            ТабДокумент = ПечатьСчетаЗаказа("Заказ");
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
        
        Если ПечатнаяФорма = "ПечатьЗаявления" Тогда
            Если ДополнительныеПараметры.Свойство("ТипЗаявления") Тогда
                ТипЗаявления = ДополнительныеПараметры.ТипЗаявления;
            КонецЕсли;
            ТабДокумент = ПечатьЗаявление(ТипЗаявления); //тип может быть "Плита" или "Водонагреватель"
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
        
        Если ПечатнаяФорма = "ЗаявлениеНаДоставку" Тогда
            ТабДокумент = ПечатьЗаявлениеДоставка();
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
        
        Если ПечатнаяФорма = "ОтчетОРозничныхПродажах" Тогда
            ТабДокумент =  ПечатьОРП()
        КонецЕсли;
                
        Если ПечатнаяФорма = "ПКОИзОРП" Тогда
            СоздатьПКОНаОсновании()
        КонецЕсли;
        
        Если ПечатнаяФорма = "ПеремещениеСевергаз" Тогда
            ТабДокумент = ПечатьПеремещения();
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
        
        Если ПечатнаяФорма = "ГБОДоговораОказанияУслуг" Тогда
            ТабДокумент = ГБОДоговораОказанияУслуг();
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
        
        Если ПечатнаяФорма = "ГБОАктПриемаПередачи" Тогда
            ТабДокумент = ГБОАктПриемаПередачи();
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
 
        Если ПечатнаяФорма = "ГБОСоответствиеТС" Тогда
            ТабДокумент = ГБОСоответствиеТС();
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
        
        Если ПечатнаяФорма = "ГБОПроведениеИспытаний" Тогда
            ТабДокумент = ГБОПроведениеИспытаний();
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
        
        Если ПечатнаяФорма = "ГБОУдостоверение" Тогда
            ТабДокумент = ГБОУдостоверение();
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
        
        Если ПечатнаяФорма = "ГБОВозмездноеОказаниеУслуг" Тогда
            ТабДокумент = ГБОВозмездноеОказаниеУслуг();
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
        
        Если ПечатнаяФорма = "ГБОСертификаты" Тогда
            ТабДокумент = ГБОСертификаты();
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
 
        Если ПечатнаяФорма = "ГБОСчетЗаказ" Тогда
            ТабДокумент = ПечатьСчетаЗаказа("ЗаказГБО");;
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
        
        Если ПечатнаяФорма = "СчетЗаявлениеДоставка" Тогда
            ТабДокумент = ПечатьСчетаЗаказа("Заказ");
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Истина, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);    
            
            Если ДополнительныеПараметры.Свойство("ТипЗаявления") Тогда
                ТипЗаявления = ДополнительныеПараметры.ТипЗаявления;
            КонецЕсли;
            ТабДокумент = ПечатьЗаявление(ТипЗаявления); //тип может быть "Плита" или "Водонагреватель"
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Истина, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);    
            
            ТабДокумент = ПечатьЗаявлениеДоставка();
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 2, Истина, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);    
        КонецЕсли;
    КонецЕсли; 
КонецФункции // Печать()


Вернуться к обсуждению:
Внешняя обработка печати
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
10.11.2014, 16:19

Внешняя обработка для создания документа
Нужно создать внешнюю обработку для созданию общего заказа поставщику из остальных заказов с...

Планирование статей бюджетов и внешняя обработка
Добрый день! Подскажите алгоритм(хотя бы на пункта три, уже будет прекрасно) действий в...

Внешняя обработка для копирования документов
Здраствуйте, создаю внешнюю обработку для копирования документов. Не могу понять как застить ее...

0
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru