Форум программистов, компьютерный форум, киберфорум
Наши страницы

Что выполняют данные процедуры? - C++

Войти
Регистрация
Восстановить пароль
Другие темы раздела
C++ Использовение чужих dll в своем проекте http://www.cyberforum.ru/cpp-beginners/thread1305839.html
Добрый день, А я все никак не угомонюсь с библиотеками. В проекте возникла потребность использовать ф-ии из чужих длл . Тоесть я точно знаю, что в этой длл содержится одна ф-ия. Но я не знаю...
C++ Написать программу: сумма первых трех цифр числа равна сумме его последних трех цифр. Получить все шестизначные счастливые номера. Счастливым называют такое шестизначное число, для которого сумма его первых трех цифр равна сумме его последних трех цифр. (Определить функцию для... http://www.cyberforum.ru/cpp-beginners/thread1305837.html
Вычислить значение выражения C++
Учусь работать в среде cpp, подскажите пожалуйста, как правильно занести в 21 строке COS B в модуль и в 22 строке z=y+p+a/y(чтобы был в квадрате)+p; #include <conio.h> //для функции _getch...
C++ Работа с динамическими структурами
всем привет, и так: +++++++++++++++++++++ Тема: работа с динамическими структурами Цель работы: приобретение практических навыков обработки таких динамических структур, как связные списки и...
C++ Какая получится кодировка на винде? http://www.cyberforum.ru/cpp-beginners/thread1305830.html
std::wofstream XML; XML.open(Name.c_str()); XML<<L"<?xml version=\"1.0\" encoding=\"UTF\"?>"<<std::endl; XML<<L"<root>"<<std::endl; XML<<L"что то кириллическое"<<std::endl;;...
C++ Вычислить значение выражения Найти значение выражения 2-5! + 3-8! / 6! + 4! где га! означает факториал числа n (n! = n • 2 •... • n). (Определить функцию для расчета факториала натурального числа.) подробнее

Показать сообщение отдельно
Pro100 Andrei
4 / 4 / 0
Регистрация: 19.05.2014
Сообщений: 43

Что выполняют данные процедуры? - C++

20.11.2014, 12:15. Просмотров 389. Ответов 2
Метки (Все метки)

Определить результат выполнения следующих рекурсивных
процедур при п = 5:
а) алг Процедура1(арг дел п)
нач
если п>0
то
вывод п
Процедура1(п-1)
все
кон
б) алг Процедура2(арг пел п)
нач
если п>0
то
Процедура2(п-1)
вывод п
все
кон
в) м г ПроцедураЗ(арг цел п)
нач
если п>0
то.
вывод п
ПроцедураЗ(п-1)
вывод п
все
кон
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
 
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.