Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
Другие темы раздела
1С Отчет "Закупки" в УПП http://www.cyberforum.ru/1c/thread606359.html
В УПП 1.3.25.1 нужно в отчет "Закупки" добавить 2 колонки Дт и Кт по которым документ делает движения.
1С Отчет по продажам ТМЦ (партионный)
в Торговле+склад редакция 9.2 "Отчет по продажам ТМЦ" ОТКУДА БЕРЁТ СУММУ ПРОДАЖИ?? никак не могу догнать(((( из какого регистра и какое измерение??? Ток сильно не ругайтесь, я новичок...
зуп 1С
ЗУП вопрос есть, у нее справка НДФЛ записывается за все месяца начиная с февраля в общеей сумме а за март , апрель и май нет ничего.
1С Не работает запрос в 7.7. Гляньте где ошибка Следующий запрос должен вытащить всю номенклатуру из регистра "Продажи" и Сумму продажи из регистра "РеализованныйТовар". Почему запрос ничего не выбирает... ТекстЗапроса = ... http://www.cyberforum.ru/1c/thread606251.html
1С Добавление окна ввода контактной информации в документ УТ управляемое http://www.cyberforum.ru/1c/thread606205.html
Здравствуйте, имеется Управление торговлей, редакция 11.0 (11.0.8.11) . Скажите пожалуйста как добавить поле ввода, в котором при нажатии кнопки выбора будет открываться формочка Адресного...
Загрузить DBF файл 1С
Всем привет. Как мне здесь уже написали 1С 7.7 не может работать с dbf файлом более 1Гб(база действително стала "гнать" когда файл стал размером 1.01 Гб). Хорошо. Возникает необходимость резать...
Корректировка отчета 1С
Есть такая проблема с нововведенным элементом "Проценты к получению (уплате) (кредиты,займы)" в справочнике "Прочие доходы и расходы". Убрали принятие к НУ, проводка делается документом "операции,...
1С Наименование - Константа Я начинающий. Мне говорят. Классический пример константы - наименование. Объясните, пожалуйста, как это может быть константой, если у ООО может быть 6 наименований: полное, сокращенное на русском,... http://www.cyberforum.ru/1c/thread605949.html
1С Доработать документ реализации УПП http://www.cyberforum.ru/1c/thread605638.html
Приветствую. Такая задача, нужно при формировании документа реализации продукции в УПП 1,4 вставить кнопку по управлению процентом НДС. Чтобы при нажатии на эту кнопку все значения НДС стали равны...
1С 8.2 Выбор ссылки на элемент справочника Возникла запарка: необходимо сделать документ, в котором будет осуществляться запись клиента на время, но: клиент может быть новым или находиться в справочнике Клиенты необходимо сделать так, чтоб... http://www.cyberforum.ru/1c/thread605551.html
assa62
7 / 7 / 1
Регистрация: 30.10.2014
Сообщений: 55
09.02.2015, 19:41 0

Как спросить. Подразделы. Удалённый доступ. Импорт (и прочие факи)

09.02.2015, 19:41. Просмотров 19522. Ответов 16
Метки (Все метки)

Ответ

Код для 1С 7.7
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
Процедура ПодключитьсяКFTP(СписокКоманд)
     Текст = СоздатьОбъект("Текст");
     Для Инд = 1 По СписокКоманд.РазмерСписка() Цикл
          Текст.ДобавитьСтроку(СписокКоманд.ПолучитьЗначение(Инд));
     КонецЦикла;
     Текст.Записать(КаталогПользователя() + "par.ftp");
     ФС.УстТекКаталог(КаталогПользователя()); 
     Пауза(2);
     vbs = СоздатьОбъект("Текст");
     vbs.ДобавитьСтроку("Dim oShell");
     vbs.ДобавитьСтроку("Set oShell = WScript.CreateObject ("+ симв(34) + "WSCript.shell"+ симв(34) +")");
     vbs.ДобавитьСтроку("oShell.run " + симв(34) + "ftp.exe -s:" + симв(34) + симв(34)  +  КаталогПользователя() + "par.ftp" + симв(34) + симв(34) + симв(34) + ", 0, -1");
     vbs.ДобавитьСтроку("Set oShell = Nothing"); 
     vbs.Записать(КаталогПользователя() + "ftp.vbs");
     Пауза(1);
     Состояние("Получаю файлы с FTP...");
     WshShell   = СоздатьОбъект("WScript.Shell");
     КодВозвр   = WshShell.Run(Симв(34) + КаталогПользователя() + "ftp.vbs" + симв(34),1,-1);
 
     Состояние("Удаляю временные файлы...");
     ФС.УдалитьФайл(КаталогПользователя() + "par.ftp");
     ФС.УдалитьФайл(КаталогПользователя() + "ftp.vbs");
     ОчиститьОкноСообщений();
КонецПроцедуры
 
//=================================================/
Функция ПолучитьСписокФайловФТП() 
    спФТП.УдалитьВсе();
    Список = СоздатьОбъект("СписокЗначений");
    Список.ДобавитьЗначение("open " + СокрЛП(FTPСервер));
    Список.ДобавитьЗначение(СокрЛП(FTPПользователь));
    Список.ДобавитьЗначение(СокрЛП(FTPПароль));
    Список.ДобавитьЗначение("cd " + СокрЛП(FTPПутьНаСервереДляПолученияФайлов));
    Список.ДобавитьЗначение("dir *.* " + симв(34) + КаталогПользователя() + "dir.ftp" + симв(34));
    Список.ДобавитьЗначение("bye"); 
    Список.ДобавитьЗначение("quit"); 
    ПодключитьсяКFTP(Список);
    Состояние("Получаю файлы...");
    Если ФС.СуществуетФайл(КаталогПользователя() + "dir.ftp") = 1 Тогда 
        тТекст     = СоздатьОбъект("Текст");
        тТекст.Открыть(КаталогПользователя() + "dir.ftp"); 
        Для ы=1 по тТекст.КоличествоСтрок() Цикл
            текСтрока   = тТекст.ПолучитьСтроку(ы);
            спФТП.ДобавитьЗначение(текСтрока);
        КонецЦикла;  
        ФС.УдалитьФайл(КаталогПользователя() + "dir.ftp");
        Возврат 1;
    Иначе
        Возврат 0;
    КонецЕсли;
КонецФункции  
//=================================================/
Процедура ПолучитьФайлыЗаДату(ТипДокумента, Знач НачДата)
    КвоФайловЗаДату  = 0;
    спПараметров     = СоздатьОбъект("СписокЗначений");
    Список = СоздатьОбъект("СписокЗначений");
    Список.ДобавитьЗначение("open " + СокрЛП(FTPСервер));
    Список.ДобавитьЗначение(СокрЛП(FTPПользователь));
    Список.ДобавитьЗначение(СокрЛП(FTPПароль));
    Список.ДобавитьЗначение("cd " + СокрЛП(FTPПутьНаСервереДляПолученияФайлов));
    Если ПолучитьСписокФайловФТП() = 1 Тогда
        Для ч=0 по КонДата-НачДата Цикл
            ЗаДату    = НачДата + ч;
            Для ы=1 по спФТП.РазмерСписка() Цикл
                текСтрока   = спФТП.ПолучитьЗначение(ы);
                ДатаВВидеСтроки = Формат(ЗаДату, "ДггггММДД");
                Если Найти(текСтрока, Нрег(ТипДокумента) + "_" + ДатаВВидеСтроки) = 0 Тогда
                    Продолжить;
                КонецЕсли;
                текСтрока  = СтрЗаменить(текСтрока," ","#");
                текСтрока  = СтрЗаменить(текСтрока,"########","#");
                текСтрока  = СтрЗаменить(текСтрока,"#######","#");
                текСтрока  = СтрЗаменить(текСтрока,"######","#");
                текСтрока  = СтрЗаменить(текСтрока,"#####","#");
                текСтрока  = СтрЗаменить(текСтрока,"####","#");
                текСтрока  = СтрЗаменить(текСтрока,"###","#"); 
                текСтрока  = СтрЗаменить(текСтрока,"##","#");
                текСтрока  = текСтрока + "#";
                Парсить(текСтрока, спПараметров, "#"); 
                имяФайлаФТП   =  спПараметров.ПолучитьЗначение(спПараметров.РазмерСПиска());
                Список.ДобавитьЗначение("recv " + имяФайлаФТП + " " +  симв(34) + РабочийКаталогВременныхФайлов + имяФайлаФТП + симв(34));
                КвоФайловЗаДату  = КвоФайловЗаДату+1;
            КонецЦикла;  
        КонецЦикла;  
    КонецЕсли;
    Если Список.РазмерСписка() > 4 Тогда
        Список.ДобавитьЗначение("bye");
        Список.ДобавитьЗначение("quit"); 
        ПодключитьсяКFTP(Список)
    КонецЕсли;
    Форма.Обновить();
КонецПроцедуры
        
//=================================================/
Процедура ПолучитьФайлы(ТипДокумента)
    ТекДата = НачДата;
    ПолучитьФайлыЗаДату(ТипДокумента, ТекДата);
КонецПроцедуры
спФТП - список на форме обработки
FTPСервер, FTPПользователь, FTPПароль,FTPПутьНаСервереДляПолученияФайлов - текстовые поля на форме обработки.

Вернуться к обсуждению:
Как спросить. Подразделы. Удалённый доступ. Импорт (и прочие факи)
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
09.02.2015, 19:41
Готовые ответы и решения:

Как сделать удалённый доступ к системе?
Уважаемые коллеги! У меня дома компьютер с установленной Ubuntu. Хочу с рабочего иметь к нему...

Как предоставить безопасный удалённый доступ (SSHv2). И Как обеспечить защиту портов доступа на коммутатроре
Имеется почти законченная схема. В задании имеются ещё три пункта. 1) К сетевому оборудованию...

Удалённый доступ.
Доброго времени суток. У меня такой вопрос. У меня на первом компьтере динамический ip. Я использую...

Удалённый доступ
Ребят помогите найти программу удалённого доступа которая не будет отображаться, то есть поставил...

Удалённый доступ
Вот у меня такой вопрос! Хочу сделать удалёнку по локальной сети(без участия инета), но при этом...

16
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.