Форум программистов, компьютерный форум CyberForum.ru
Наши страницы

Код не видит элементы, находящиеся в hub - Windows Phone

Войти
Регистрация
Восстановить пароль
Другие темы раздела
Windows Phone При диплое приложения не работает некоторый функционал http://www.cyberforum.ru/windows-phone-dev/thread1386222.html
Всем привет. Есть приложение, отправляет данные на сервер. При запуске приложения сразу на девайс из студии все ок(основной вопрос передача данных в фоновом режиме). Проблема в том, что когда...
Windows Phone Реклама от AdMob подскажите что делать чтобы повысить доход на тыс.показов. я смотрел некоторые статьи по этому но там у людей по 0.10$, а у меня 0.01$. http://www.cyberforum.ru/windows-phone-dev/thread1385989.html
Windows Phone Как переделать под 8.1 код
Как можно переделать этот код с приложения 8.0 Silverlight пишу под WP 8.1? Прочитать файл созданный и заполоненный который в проекте, ругается "FileStream". И потом записать в этот же файл? Auto...
Разработка приложения с подключение к BD через службу Windows Phone
Здравствуйте! Написал приложение, BD, и службу. Возникла проблема с подключением. т.е. при запуске приложения через эмулятор не могу работать со службой т.к. служба использует адрес localhost, и...
Windows Phone В чем ошибка? http://www.cyberforum.ru/windows-phone-dev/thread1382569.html
Этот кусок кода предназначен для задания фонового изображения для элемента Page. private void TG2_Tapped(object sender, TappedRoutedEventArgs e) { ImageBrush berriesBrush = new...
Windows Phone Задать трек для агента фонового воспроизведения В продолжение своего предыдущего вопроса http://www.cyberforum.ru/windows-phone-dev/thread1372822.html У меня к сожалению так и не получилось заставить звук играть в фоне. Судя по дебаггеру, как я... подробнее

Показать сообщение отдельно
bykinator
1 / 1 / 2
Регистрация: 14.08.2014
Сообщений: 219

Код не видит элементы, находящиеся в hub - Windows Phone

03.03.2015, 00:38. Просмотров 990. Ответов 6
Метки (Все метки)

у меня код не видит названия всех textblock и прочих элементов которые находятся в hub, приложение переношу с wp8 на wp8.1 я давно это делал и решил щас доделать и там все работало, я отдельно создавал textblock и button сначала не в hub все видело а когда перенес textblock в hub то опять ошибка "Элемент "day_v" не существует в текущем контексте" помогите что делать
Проект во вложении
C#
1
2
3
4
5
6
7
Int64 test = 0;
 
        private void Button_Click(object sender, RoutedEventArgs e)
        {
            test++;
            test1.text = test.ToString();
        }
XML
1
2
3
4
5
6
7
8
9
10
11
12
13
<Grid>
        <Hub Header="Hub">
            <HubSection Header="HubSection 0" Width="400">
                <DataTemplate>
                    <Grid  Margin="30,36,46.833,340">
                        <TextBlock Name="test1" Text="0" FontSize="20" Margin="0,0,0,61" />
                        <Button Click="Button_Click" Content="Button" HorizontalAlignment="Left" Height="62" Margin="76,163,0,-101" VerticalAlignment="Top" Width="87"/>
 
                    </Grid>
                </DataTemplate>
            </HubSection>
        </Hub>
    </Grid>
и ошибка
Ошибка 1 Элемент "test1" не существует в текущем контексте.
помогите пожалуйста я приложение уже заканчиваю а эту фигню победить не могу даже не тестил нормально ни разу только кое как под 8,0 и все
0
Вложения
Тип файла: rar App11.rar (31.2 Кб, 0 просмотров)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
 
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru