Форум программистов, компьютерный форум CyberForum.ru

PhoneGap. Как его использовать? В чем его недостатки по сравнению с Android SDK, Windows Phone SDK, iOS SDK? - HTML5

Войти
Регистрация
Восстановить пароль
Другие темы раздела
HTML5 Как поставить google analytics в cordova app? http://www.cyberforum.ru/html5-mobile-apps/thread1398506.html
объясните пожалуста,или дайте ссылку как поставить google analytics в свой cordova app... :cry: у них очень мало документации
HTML5 Не могу разобраться Добрый день Всем ) Возникла такая проблема.... Все работает нормально на Компе (в браузере) но не хочет работать на Андроид Дивайсе. Приложения на Фонгап - получения данных о погоде. в ZIP архиве что я загружаю на http://build.phonegap.com есть 4 папки "CSS, js, res, weather-icon" и 5 файлов "config.xml - cordova.js - cordova_plugin.js - index.html - phonegap.js" Загружаю ZIP качаю... http://www.cyberforum.ru/html5-mobile-apps/thread1393423.html
HTML5 Swipe срабатывает со второго раза
Всем привет Ребята может кто сталкивался с проблемой swipeleft swiperight После свайпа, сразу никогда не срабатывает , только за вторым разом (Это на девайсе) пример рабочего для браузеров http://jsfiddle.net/gv2mutmu/11/ Тут то четко всё срабатывает. Я заметил , что если есть какой- то listview или grid layout то, только тогда такая проблема. Если скролить по пустом месту (которое не...
Использовать PhoneGap для создания сайта и приложения HTML5
Добрый день!! Нахожусь в процессе выбора платформы под разработку. Хотелось бы уточнить у специалистов ход разработки: 1. Сперва разрабатывается сайт с использованием js, css, html. 2. Затем этот сайт с помощью phoneGap конвертится в мобильное приложение, которое можно запускать на мобильных устройствах(ios, android). Полученное приложение предствляет собой ни что иное как специфический...
HTML5 Как добавить платформу в phoneGap? http://www.cyberforum.ru/html5-mobile-apps/thread1358252.html
Всем привет. Только начал ковырять phoneGap, сразу столкнулся с проблемкой. Пытаюсь добавить новую платформу в проект через командную строку. В терминале висит ошибка: cordova platform add android Creating android project... /home/abakan/.cordova/lib/npm_cache/cordova-android/3.6.4/package/bin/node_modules/q/q.js:126 throw e; ^ Error:...
HTML5 Определить Apple ID в Cordova Может кто знает, есть какой-то плагин у cordova, позволяющий определить Apple ID пользователя на iOS? Мне это нужно для того, чтобы с помощью этой учетки идентифицировать пользователя в приложении, если он, например, решит сменить девайс на другой, а данные остались те же. Буду очень благодарен за любую помощь, уже пару суток ищу, ничего не могу найти подробнее

Показать сообщение отдельно
Vorona
Peace 2 all shining faces
668 / 530 / 45
Регистрация: 05.03.2010
Сообщений: 1,277
23.03.2015, 00:23
Цитата Сообщение от Moon Speak Посмотреть сообщение
Вы не учли, что если у меня действительно ЧСВ over 9000 (как вы пишете), то ваше мнение насчет меня мне по-барабану? Пишите о сабже, а не обо мне.
я учел то, что вам нужно хоть капельку разобраться в том, что вы тут полный бред пишите, а потом приходить за помощью, так как я не намерен тратить свое время высокомерных болванов
если мое мнение вам по барабану, тогда ждите другого человека, который согласиться объяснять вам насколько полнейший бред вы пишите

это форум, и вы тут задаете конкретные вопросы, если же вы даже вопрос не можете поставить, вас отсылают разобраться в нем и приходить с правильным вопросом, а так как вопросов у вас тут 100500 и ни один из них не задан правильно, то о чем с вами можно говорить

Цитата Сообщение от Moon Speak Посмотреть сообщение
Я не знаток архитектуры ОС Android, но по-моему там все, что есть на экране, на низком уровне рисуется OpenGL.
тут всем по-барабану на "по-моему", есть факты и документация, которую вам стоит прочесть и избавиться от своих "по-моему", либо прислушиваться к тому, что вам пытаются объяснить, и чисто мой совет, который вам поможет в будущем - это перестаньте думать, что вы все знаете и угомоните свое чсв, это вам тут точно не поможет, лучше сядьте и почитайте то, что вам советуют, а потом приходите

Добавлено через 15 минут
Цитата Сообщение от Moon Speak Посмотреть сообщение
В Eclipse создал проект, кликнул Run - и все, вот тебе APK.
А тут надо сначала проект Gradle получить командной строкой, затем проект Gradle компилировать командной строкой. Что удобнее?
А чтобы не компилировать командной строкой (и поверить в том, что и PhoneGap может быть удобен), я и хотел бы глянуть IDE, где для PhoneGap есть такая вот кнопочка Run.
да прочитайте вы уже документацию, пожалуйста... я же вам пытаюсь объяснить что из-за своего невежества и мнения о том, что вы все знаете вам будет очень сложно выучить что-то новое

проектом на градл пользоваться так же просто как и на дргуих системах, просто вам надо прочитать как его правильно открыть, настроить и тд

еклипс это костыльная ide и вчерашний день

да и не нужно вам открывать никакие андроид проекты...
просто выполните в командной строек cordova build android
дальше выполните cordova run android и все

я же вам объясняю, проект создается как угодно, в еклипсе тоже можно установить плагин для градла, андроид студио по-умолчанию использует градл, не поленитесь, посмотрите в гугле как правильно открыть проект который менеджерится градлом

Цитата Сообщение от Moon Speak Посмотреть сообщение
Под рутом - возможно, но я не хочу так рисковать единственным смартфоном.
А без рута установить unsigned apk (в названии apk есть слово "unsigned") у меня не получается. Другого APK градл не выдает.
под каким еще рутом, не нужен никакой рут, чтобы установить апк дебаг версии на девайс, в этом одно прекрасное отличие от iOS
на iOS вам нужен платный сертификат для установки приложения на девайс, на Андроиде же вам ничего этого не нужно

а там ошибка что выдал градл, вы хоть читали ее? с чего вы взяли что это хоть каким-то боком относится к тому что вы пытаетесь установить дебаг версию???

Код
FAILURE: Build failed with an exception.
 
* Where:
Build file 'C:\Users\юзер\my-app\platforms\android\build.gradle' line: 3
 
* What went wrong:
A problem occurred evaluating root project 'android'.
> Failed to apply plugin [id 'android']
   > Gradle version 1.10 is required. Current version is 2.3. If using the gradl
e wrapper, try editing the distributionUrl in C:\Users\юзер\my-app\platforms\and
roid\gradle\wrapper\gradle-wrapper.properties to gradle-1.10-all.zip
 
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug
option to get more log output.
 
BUILD FAILED
 
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru