Форум программистов, компьютерный форум CyberForum.ru
Наши страницы

Не удается подключить NotificationCompat для старых версий - Программирование Android

Войти
Регистрация
Восстановить пароль
Другие темы раздела
Программирование Android Ошибка установки android sdk http://www.cyberforum.ru/android-dev/thread1492745.html
Уважаемые Гуру! Пытаюсь установить xamarin для программирования ios/adnroid. Получаю сообщение , что далее будет загружено и установлено android SDK 22.0.0. И далее сообщение об ошибке. Возможно я...
Программирование Android Как можно сделать маштабируемость экрана Есть ли возможность уменьшать, увеличивать представление приложения так же как мы делаем это в браузере http://www.cyberforum.ru/android-dev/thread1492450.html
Как сделать прозрачным фон GLSurfaceView (openGL ES2) Программирование Android
Наставьте на путь истинный, пожалуйста
Программирование Android Какие разрешения нужны для определения местоположения?
Какое разрешение нада прописать в манифест чтобы приложение могло определять местоположение?
Программирование Android Как определить устройство? http://www.cyberforum.ru/android-dev/thread1492334.html
Тяп-ляпаю клиент - сервер, хочу чтоб сервер понимал кому отправляет запрос. Как сделать чтоб определенный клиент определялся сервером и отправлял данные, а не каждому кто постучит без разбора и чтоб...
Программирование Android Google Maps API v2. Не отображается карта Доброго времени суток. На днях решил поработать с Google API Maps. И столкнулся с такой проблемой. Создал приложение, создал API Key Импортировал всё что нужно,все необходимые Permissions... подробнее

Показать сообщение отдельно
vindigo
18 / 18 / 3
Регистрация: 15.05.2014
Сообщений: 78

Не удается подключить NotificationCompat для старых версий - Программирование Android

04.07.2015, 12:31. Просмотров 280. Ответов 2
Метки (Все метки)

Всем привет! Такая проблема: не удается подключить NotificationCompat для старых версий. Ругается на строчку:
Java
1
nBld = new NotificationCompat.Builder(context);
вот gradle, как видно библиотека подключена:

Java
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
apply plugin: 'com.android.application'
 
android {
    compileSdkVersion 22
    buildToolsVersion "22.0.1"
 
    defaultConfig {
        applicationId "com.myapp.app"
        minSdkVersion 14
        targetSdkVersion 22
        versionCode 1
        versionName "1.0"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}
 
dependencies {
    compile fileTree(include: ['*.jar'], dir: 'libs')
    compile 'com.android.support:appcompat-v7:22.2.0'
    compile 'com.android.support:support-v4:22.2.0'
}
import android.support.v4.app.*; импорт присутствует, переустановка студии, обновление всего до последних версий ничего не дало, есть идеи?
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
 
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru