Форум программистов, компьютерный форум, киберфорум
Наши страницы
С++ под Linux
Войти
Регистрация
Восстановить пароль
Другие темы раздела
C++ Linux INI файлы в Linux http://www.cyberforum.ru/cpp-linux/thread1519152.html
Приветствую всех. Каким способом можно считать ини файлы в Linux? Буду благодарен за помощь) P.S. нужно что-то типо этого в виндоус: GetPrivateProfileString
Аналог GetModuleFileName для Linux C++ Linux
Приветствую всех. Можете, пожалуйста, дать аналог функции GetModuleFileName для линукса? P.S. функция получает полный путь + название файла(в котором функция запущена). Добавлено через 27...
Литература по сокетам в Linux C++ Linux
Здравствуйте, прошу подкинуть литературы по Сокетам в Linux. Интересует больше всего создание сервиса который слушал бы определенный порт с которого идут некоторые данные и дальнейшая их оброботка....
C++ Linux Низкоуровневая разработка GUI Здравствуйте. Захотелось почитать про низкоуровневые библиотеки разработки GUI (аля WinAPI вроде в *nix это X11) но годной литературы(статьи/книги/видео уроки) не нашел посоветуйте форумчане! P.S.... http://www.cyberforum.ru/cpp-linux/thread1517664.html
C++ Linux Портирование ассемблерной функции с MSVC на GCC http://www.cyberforum.ru/cpp-linux/thread1517653.html
Мои попытки не привели ни к чему вразумительному. Так что прошу помощи... bool IsMemoryOnStack( LPVOID pVoid ) { LPVOID dwStackTop = 0; LPVOID dwStackLowCurrent = 0; __asm { ...
C++ Linux Работа с функциями tcsetattr, fcntl на C в Linux
Здравствуйте, уважаемые форумчане! Разбираюсь к кодом программы, написанной на C под Linux. Попались функции tcsetattr и fcntl. Немного разобрался с их работой и предназначением сам, но очень...
C++ Linux Не получается собрать cpp файл
Товарищи, Прошу заранее меня извинить, за возможно дурацкие вопросы, но я совсем не программист. В связи со спецификой моего железа, понадобилось собрать данный пакет (OS Linux Mint 17.2):...
C++ Linux Контроль версий Eclipse Решил писать код си++ в эклипсе под линуксом. Слышал о такой штуке как контроль версий. Нужно чтобы при каждом сохранение или автоматическом сохранение и компиляции файлов, сохранялась предыдущая... http://www.cyberforum.ru/cpp-linux/thread1514972.html
C++ Linux Ошибка undefined symbol: basic_string char_traits http://www.cyberforum.ru/cpp-linux/thread1514320.html
Пишу либу и собираю под Ubuntu 64bit компилятором gcc 5.1 32bit. В либе используется std::string. Библиотека запускается на другой системе и падает с ошибкой: undefined symbol:...
C++ Linux GTK. Размещение виджетов в окне Доброго времени суток. Стоит задача: разместить кнопку (button) в произвольном месте экрана поверх поля рисования (DrawingArea). Vbox как-то не очень помогает, т.к. кнопка размещается сразу под... http://www.cyberforum.ru/cpp-linux/thread1514294.html
DiffEreD
1444 / 781 / 257
Регистрация: 21.06.2011
Сообщений: 1,740
Записей в блоге: 2
26.08.2015, 09:31  [ТС] 0

Version `GLIBCXX_3.4.21' not found

26.08.2015, 09:31. Просмотров 5653. Ответов 4
Метки (Все метки)

Ответ

Решил проблему вчера таким способом:
Bash
1
2
3
4
sudo add-apt-repository ppa:ubuntu-toolchain-r/test 
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade


Вернуться к обсуждению:
Version `GLIBCXX_3.4.21' not found
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
26.08.2015, 09:31
Готовые ответы и решения:

GLIBCXX_3.4.21 not found
Добрый день. На форуме находил уже схожую тему, но решение, предложенное там не помогла...

./massdown: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by ./massdown)
всем хай! собираю свою программу на новом железе х86_64 долго не получалось скомпилить. при...

Python version 3.4.3 not found in registry matplotlib
Добрый вечер. При установке пакета matplotlib появляется ошибка, прикрепленная ниже. (На тот...

Ошибка cannot be opened because it is version 782. This server supports version 706 and earlier
Есть проект для которого база данных (далее-БД) создается с использованием Code First При сборке...

Bootstrap's JavaScript requires jQuery version 1.9.1 or higher, but lower than version 3
ребят почему так пишет Bootstrap's JavaScript requires jQuery version 1.9.1 or higher, but lower...

4
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru